• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

2nd CSS issue

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 General] >> Installation and Planning >> 2nd CSS issue Page: [1]
Login
Message << Older Topic   Newer Topic >>
2nd CSS issue - 7.Jul.2009 2:54:57 AM   
verukins

 

Posts: 58
Joined: 27.Sep.2002
Status: offline
Hi all,
       Im currently going through one of those "it should ahve only taken 15 minutes" scenarios im hoping someone can help with.

I have a client with a primary site and a DR site. The primary site has a multi-node ISA 2006 cluster, which is fine, the DR site, i am working at moving it into the ISA enterprise, giving them CSS redundandcy etc.

I eventaully got ISA 2006 CSS installed at the DR site (after many inter-site non-ISA firewall issues), the modified the install to include the ISA services - all good.

I upgraded to SP1, rebooted and although the firewall services are fine, the CSS Adam instance wont start - in the app log i get

Active Directory could not be initialized.

The directory service cannot recover from this error.

User Action
Restore the local directory service from backup media.

Additional Data
Error value:
-1811 JET_errFileNotFound, File not found

When having a look under C:\program files\isa etc etc\adamdata\ the adamntds.dit file isnt there anymore!

While i have no idea what made this file disappear, the disppointing thing is, ISA 2006 will not let me uninstall until i start that service, yet i cannot start the service!

so, my questions are
1) Any idea's on how to get the ISASTGCTRL service to start? i realise i need to get an adam database in there for it to start with - but how ?
2) Anyone have any idea why my original adamntds.dit disappeared after SP1 ? and suggestions on how to make sure it doesnt happen again ?
Post #: 1
RE: 2nd CSS issue - 7.Jul.2009 9:08:20 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi V,

Wow. Never seen anything like that before.

Sounds like a PSS call is in your future

Let us know what they say, it would be very interesting to know the resolution.

Thanks!
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to verukins)
Post #: 2
RE: 2nd CSS issue - 7.Jul.2009 9:55:38 AM   
verukins

 

Posts: 58
Joined: 27.Sep.2002
Status: offline
Hi Tom,
many hours later (im the type of person that cant let things go)

1) delete the service out of the registry and reboot
2) run isa setup and un-install - accept the warning message about the CSS state being out of whack
3) using adam adsiedit to remove the additional css server from the primary site css
4) re-install using the "install CSS and ISA services" option instead of doing them seperately
5) apply SP1, reboot

all fine (with the exception that web traffic isnt working, even though ISA is passing it, a tracert is fine etc - so im going to assume thats an external firewall issue until i get onto the network guys tommorow morning)

The bit that threw me was the adamntds.dit "disappearing" - maybe its because of the "2 step" install, or maybe something just went whacky... after the 16 hour day, i think i'll worry about investigating that later.

(in reply to tshinder)
Post #: 3
RE: 2nd CSS issue - 8.Jul.2009 8:10:32 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi V,

Wow! Good work. I don't think I'd have figured that out myself.

Good to hear you got it working and thanks for giving us the follow up information.

HTH,
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to verukins)
Post #: 4

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 General] >> Installation and Planning >> 2nd CSS issue Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts