• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

ActiveSync Exch. 2003, ISA 2006 with different names

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 Publishing] >> Exchange Publishing >> ActiveSync Exch. 2003, ISA 2006 with different names Page: [1]
Login
Message << Older Topic   Newer Topic >>
ActiveSync Exch. 2003, ISA 2006 with different names - 21.Apr.2008 8:55:03 AM   
Christoph37

 

Posts: 9
Joined: 13.Mar.2006
Status: offline
Hello,

I have set up a test environment for publishing Exchange 2003 ActiveSync with ISA 2006.

It does not seem to work if the internal name of the Exchange Server is different from the external one. The ISA Server uses a certficate with the external name (equal to the Public Name, e.g. eas.domain.tld), and the Exchange Server uses a cert. with the internal name (e.g. exch.domain.tld).

This setup works for OWA and RPC/HTTPS, but not for Active Sync so far; the Windows Mobile 5.0 emulator gives error 85010014 and in the ISA logging I see Internal server error 500, which usually points to a wrong certificate common name.

"Forward the original hostheader..." is not checked and I can see the request going to exch.domain.tld in the Isa server 2006 log.

Have I missed a step?!

If you need more info, don t hesitate to ask :)

Christoph

< Message edited by Christoph37 -- 21.Apr.2008 8:59:51 AM >
Post #: 1
RE: ActiveSync Exch. 2003, ISA 2006 with different names - 29.Apr.2008 10:02:16 AM   
Christoph37

 

Posts: 9
Joined: 13.Mar.2006
Status: offline
Doesn´t anybody have an idea, what´s wrong here?`

If I open IE and browse to https://eas.domain.tld, I get an authentication form. After I enter my credentials I get a page with error 101/105, which states that authentication does work, but WM 5.0 keeps getting error 85010014.

Christoph

(in reply to Christoph37)
Post #: 2
RE: ActiveSync Exch. 2003, ISA 2006 with different names - 15.May2008 1:29:13 PM   
Christoph37

 

Posts: 9
Joined: 13.Mar.2006
Status: offline
Finally found the underlying problem.

The ISA server was not the culprit. And it can handle different external and internal names for ActiveSync quite well.

The problem was that I only had one Exchange Server and Active Sync doesn´t work if SSL is enabled on the /Exchange virtual directory.
The problem does not occur if you have an Exchange FE/BE configuration.

MS KB Article 817379 (http://support.microsoft.com/kb/817379/en-us) shows how to remediate the situation if you do not have an Exchange front-end server available.


Best regards

Christoph

(in reply to Christoph37)
Post #: 3

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 Publishing] >> Exchange Publishing >> ActiveSync Exch. 2003, ISA 2006 with different names Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts