• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Can't get Web Proxy clients to autodiscover

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 Web Proxy] >> Web Proxy Client >> Can't get Web Proxy clients to autodiscover Page: [1]
Login
Message << Older Topic   Newer Topic >>
Can't get Web Proxy clients to autodiscover - 13.Aug.2010 10:31:12 AM   
Dr Zoidberg

 

Posts: 1
Joined: 13.Aug.2010
Status: offline
Hello.
I'm new to ISA server (but not to Windows or AD) and am trying to set up a test environment where's it's used as a Web Proxy with autoconfiguration of clients.
I've got the server installed and configured ok so it works if a client is manually set to use proxy.mydomain.com on port 8080 - I can see their session and history in the logs.

Now on to autodiscovery..
On the properties for the network within ISA I have ticked the "Publish automatic discovery information....."
Following the instructions here http://technet.microsoft.com/en-us/library/cc302584.aspx I initially tried the DNS method of autoconfiguration. The first hiccup was that my DNS server refused to resolve wpad.mydomain.com to an IP address but I found out how fix that using this link http://www.mpking.com/archives/36-WPAD-does-not-resolve-in-DNS.html
Once the DNS issue was fixed I tested the browsers and they didn't use the proxy server, though if I tried, I could download the wpad file from wpad.mydomain.com/wpad.dat

Next I tested the DHCP method and set option 252 to be http://wpad.mydomain.com/wpad.dat , rebooted a test machine on that subnet and started to surf, but again it didn't send traffic to the proxy server....

Does anyone have any handy pointers where I might be going wrong as it all seems correct to me but I'm sure I've missed something really obvious.
Post #: 1
RE: Can't get Web Proxy clients to autodiscover - 13.Aug.2010 8:11:45 PM   
elmajdal

 

Posts: 6022
Joined: 16.Sep.2004
From: Lebanese in Kuwait
Status: offline
Tom Shinder explained this with a step  by step article.

Check his article here : http://www.isaserver.org/tutorials/Configuring-WPAD-Support-ISA-Firewall-Web-Proxy-Firewall-Clients.html

_____________________________

Tarek Majdalani

Windows Expert - IT Pro MVP
Facebook : https://www.facebook.com/ElMajdal.Net

(in reply to Dr Zoidberg)
Post #: 2
RE: Can't get Web Proxy clients to autodiscover - 12.Dec.2012 8:38:18 AM   
mmh

 

Posts: 1
Joined: 12.Dec.2012
Status: offline
Dear Sir,

i m using ISA server standard edition 2006 .
From my ISP , we need to First Login to ISP with given username and password.after login request success we have to use proxy server and port that ISP given.
i was planning to use with my ISA server to Clients with no proxy setting at their browser also with phones.

I was configure at ISA server at webchaning rule with upstream proxy server
and there i fill the proxy and port that ISP given .

i can access internet(with no proxy setting) but not Https
when i use https://www.facebook.com it doesn't work.
other page like
www.livescore.com and other http was work.

please let me know how to use https to work.
regards
MMH

(in reply to elmajdal)
Post #: 3

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 Web Proxy] >> Web Proxy Client >> Can't get Web Proxy clients to autodiscover Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts