• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Error code 64: Host not available

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 Firewall] >> HTTP Filtering >> Error code 64: Host not available Page: [1]
Login
Message << Older Topic   Newer Topic >>
Error code 64: Host not available - 28.Feb.2006 3:12:25 PM   
hanstheunissen

 

Posts: 4
Joined: 28.Feb.2006
Status: offline
I have an ISA server 2004 Enterprise version installed on top of MS windows server w2k3 (no Sp1). The isa server has 3 network interfaces. Two isa servers are in an array and they are in load balancing on both internal and external interfaces. The third interface is used for array communication and is therefore not load balanced. Both servers also act as webproxy servers and are configured to do caching.

I have the following problem:
On some (but not all) of the user PC's (acting as web proxy client) there is a "Error code 64: Host not available" when trying to get some pages. The requested page displas without problems on othe user PC's. I checked:

-Both PC's were handled by the same "HTTP allow"rule.
-Both PC's have IE 6.0 (latest version)
-Anonymous access is allowed on the ISA server to this site

Any ideas
Post #: 1
RE: Error code 64: Host not available - 28.Feb.2006 6:15:43 PM   
LLigetfa

 

Posts: 2187
Joined: 10.Aug.2004
From: fort frances.on.ca
Status: offline
I had a lot of 64 errors before enabling PMTUDiscovery.

_____________________________

The School of Hard Knocks is a mean teacher. She gives the exam before the lesson.

(in reply to hanstheunissen)
Post #: 2
RE: Error code 64: Host not available - 2.Mar.2006 10:13:58 AM   
hanstheunissen

 

Posts: 4
Joined: 28.Feb.2006
Status: offline
I reconfigured it, did not help in all cases however. If someone has an additional idea, that would be very welcome.

(in reply to LLigetfa)
Post #: 3
RE: Error code 64: Host not available - 2.Mar.2006 2:11:13 PM   
LLigetfa

 

Posts: 2187
Joined: 10.Aug.2004
From: fort frances.on.ca
Status: offline
There may be other reasons for that error and other general slowness.  You need to review your entire config.  There are DNS settings, NIC ordering, binding of protocols, etc.

_____________________________

The School of Hard Knocks is a mean teacher. She gives the exam before the lesson.

(in reply to hanstheunissen)
Post #: 4
RE: Error code 64: Host not available - 7.Mar.2006 3:19:49 PM   
PRAA

 

Posts: 3
Joined: 2.Mar.2006
Status: offline
It seems to be a bug in implementation of HTTP1.1. A workaround for this would be turning of HTTP1.1 on the client.

On the client goto tools->internet options -> Advanced, under HTTP 1.1 setting clear one or both options (Use HTTP1.1 and Use HTTP1.1 through proxy server).


(in reply to LLigetfa)
Post #: 5
RE: Error code 64: Host not available - 9.Mar.2006 11:42:43 AM   
hanstheunissen

 

Posts: 4
Joined: 28.Feb.2006
Status: offline
Thank both of you guys. The solution of Peter Rausch (PRAA) did the job.

Hans

(in reply to PRAA)
Post #: 6
RE: Error code 64: Host not available - 28.Mar.2006 4:52:17 PM   
hanstheunissen

 

Posts: 4
Joined: 28.Feb.2006
Status: offline
I opened a premier call at Microsoft. The cause of the problem seemed to be the HTTP compression in ISA 2004. Open the ISA management console | click "add ins". Now choose the tab "webfilters". If you disable the "compression filter" and the caching compressed content filter" it also solves the problem. I also got hotfixes from them; one for standard (ISA2004SE-KB915045-x86-ENU.msp) and one for enterprise edition ISA server (ISA2004EE-KB915045-x86-ENU.msp). So it is a known problem. The hotfixes are probably not yet public available.

Hans

(in reply to hanstheunissen)
Post #: 7
RE: Error code 64: Host not available - 6.Nov.2006 4:08:01 AM   
desigan

 

Posts: 1
Joined: 6.Nov.2006
Status: offline
Hi Guys,

First off I just want to say thanks for the info on this forum it really is helpful.

The problem I'm having is exactly the same as
hanstheunissen. I have tried everything you guys have mentioned but still no luck. It's a just a few websites that I'm having an issue with. I access the website fine but as soon as i try to access one particular aspect of this website my server loses the connection.

So guys any advice or help. It would be much appreciated.

Thanks,

Desigan


(in reply to hanstheunissen)
Post #: 8
RE: Error code 64: Host not available - 13.Dec.2006 7:57:52 AM   
wynandjordaan

 

Posts: 4
Joined: 13.Dec.2006
Status: offline
Hi Guys.

I have tried all the solutions you suggested in this thread, but I cannot seem to get to the codeproject.com site. It gives me the Error Code 64 message. I disabled the Cache filters and set the Registry value (EnablePMTUDiscovery) to 1, still no luck.

The ISA Log allows the traffic to the website.

Any help would be appreciated.
Thanks.

(in reply to desigan)
Post #: 9
RE: Error code 64: Host not available - 13.Dec.2006 7:58:42 AM   
wynandjordaan

 

Posts: 4
Joined: 13.Dec.2006
Status: offline
Ignore this msg - posted twice

< Message edited by wynandjordaan -- 13.Dec.2006 8:00:35 AM >

(in reply to desigan)
Post #: 10
RE: Error code 64: Host not available - 29.Jan.2007 4:48:51 AM   
sureshkanan

 

Posts: 1
Joined: 29.Jan.2007
Status: offline
Hi,

I am also facing same problem. Any help would be appreciated

Regards,
Suresh

(in reply to wynandjordaan)
Post #: 11
RE: Error code 64: Host not available - 29.Jan.2007 5:33:09 AM   
wynandjordaan

 

Posts: 4
Joined: 13.Dec.2006
Status: offline
Hi Suresh

I did manage to fix my error 64 problem, but can't exactly remeber what I did. I think what help with most of my problems was the fact that on my DHCP server the gatway wasn't configured. So just have a look and see if the client pc has a gateway configured.

Good luck
Wynand Jordaan

(in reply to sureshkanan)
Post #: 12
RE: Error code 64: Host not available - 21.May2007 9:19:23 AM   
slfurr

 

Posts: 4
Joined: 17.Mar.2004
From: Pennsylvania
Status: offline
I was having the same problem.  If I logged in on different computers with the same user name, I encountered the problem on some machines and not others.  I realized that the problem was with the PC, not the user, firewall, or ISA.    I went to one of the machines giving me a problem, deleted the browsing history on the IE (Ver 6 & 7), restarted the browser, and the problem was gone!  I just went to IE | Tools | Internet Options | General | Browsing History | Delete | Delete All. 

It worked on all of my machines giving me problems.

_____________________________

slfurr

(in reply to wynandjordaan)
Post #: 13
RE: Error code 64: Host not available - 18.Jun.2007 9:31:26 AM   
pwiddowson

 

Posts: 1
Joined: 11.Jun.2007
Status: offline
Hi All,
 
I have the same problem... but the way it works is slightly wierd.
 
If I use a cabled connection via the internal proxy server (which has the problem) it works...
 
however, if users connect wirelessly... it doesn't.
 
The problem only so far effects Attaching Files when using Outlook Web Access... Nothing has changed, but one day... it just decided to stop working (whether the power-cut did anything... but we've had several before)
 
About the only thing really that has changed is the implementation of VirusScan 8.5 (which we don't have Patch 1 for yet), however, with this disabled on Client, Proxy AND Exchange - it still fails totally.
 
I've tried everything in this topic and even tried playing with DNS/DHCP settings and still nothing.

(in reply to slfurr)
Post #: 14
RE: Error code 64: Host not available - 25.Jun.2007 1:39:12 PM   
sottiled

 

Posts: 18
Joined: 4.Dec.2004
Status: offline
I have necountered a new twist on Error 64.  I have a pair of NLB ISA 2004 SP2 servers and am attempting to enable RPC over HTTP.  I have no problems accessing the RPCProxy.dll query however the remote clients can't resolve the Exchange server boxes.  After looking into the logs and monitoring a session I noticed HTTP codes of 503 and 64 and the URL it was attempting to connect to was:

http://secure.mydomain.com:443/rpc/rpcproxy.dll?myexchangeserver:6004

I see one log line returns a 503 and the next one returns a 64.

Not sure what the next step for debugging this should be.  Any ideas?

(in reply to pwiddowson)
Post #: 15
RE: Error code 64: Host not available - 6.Nov.2008 12:43:21 PM   
luismcpereira

 

Posts: 1
Joined: 5.Nov.2008
Status: offline
I'm getting this error also. The solution in post #7 (disable the compression filter) worked for me. The hotfix sollution doesn´t apply cause I have ISA 2004 SP3 (already includes the hotfix).

Any suggestions?

Thanks.

Luís Pereira

(in reply to sottiled)
Post #: 16
RE: Error code 64: Host not available - 23.Apr.2009 12:19:47 PM   
weirjamin

 

Posts: 2
Joined: 23.Apr.2009
Status: offline
I have read dozens and dozens of articles on this same issue not only on Experts-Exchange but Microsoft, Websense, and a ton of other websites. I foudnd this article when trying to fix my websene install with an ISA 2006 server for Terminal Server 2003 users to Proxy through for authentication and web filtering.

I really hope what fixed mine will help you. I have been working on this problem for over  a week.

In out network layout We have a Cisco ASA firewall as the bridgehead. The ISA 2006 server is running in proxy only mode.  Also the ISA 2006 and Websense are on the same physical server in VM Ware on thir own Server 2003 32bit  to cut down on hardware costs.

I got it working finally. The issue was wits the Cisco ASA URL Filter Statements.

The ISA want happy till the URL-Server statement on the ASA Firewall was changed to: url-server (INSIDE) vendor websense host  (ip address of websense server)  timeout 60 protocol TCP version 4 connections 10
The defaults which work fine if you don’t have an ISA server are time out 30, TCP version 4, Connections 5.

I also had to enable "longurl-truncate" and "cgi-truncate" on the "Filter URL" statement but this problem wasn’t isolated to the ISA 2006 server. So the Statement would look like: filter url http 0.0.0.0 0.0.0.0 0.0.0.0 0.0.0.0 allow longurl-truncate cgi-truncate

I will also include the solution for getting the proxy setting on all Internet Explorers on a terminal server using Group Policy. 
1: Create a new OU
2: Put terminal servers that you need proxy servers set on in that ou.
3: Create a new Group Policy on the OU.
4: Go to ComputerConfiguration - Administrative Templates - Windows Components - Internet Explorer.
5: Open the Setting: Make Proxy Settings Per Machine(Rather than Per User) and set it to enable.
6: Log in to each Terminal Server as the Local administrator account and set the proxy server information in the Connections Tab of Internet Explorer.
7: Reboot the terminal server. All users that log in from that point will have the Proxy Server information that you defined in Step 6.

I am going to put this solution on all the Forums that I have visited in hopes that no one else will ever have to go though what I had to.

Hope this Helps!

(in reply to hanstheunissen)
Post #: 17
RE: Error code 64: Host not available - 23.Apr.2009 1:03:53 PM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
quote:

ORIGINAL: weirjamin

I have read dozens and dozens of articles on this same issue not only on Experts-Exchange but Microsoft, Websense, and a ton of other websites. I foudnd this article when trying to fix my websene install with an ISA 2006 server for Terminal Server 2003 users to Proxy through for authentication and web filtering.

I really hope what fixed mine will help you. I have been working on this problem for over  a week.

In out network layout We have a Cisco ASA firewall as the bridgehead. The ISA 2006 server is running in proxy only mode.  Also the ISA 2006 and Websense are on the same physical server in VM Ware on thir own Server 2003 32bit  to cut down on hardware costs.

I got it working finally. The issue was wits the Cisco ASA URL Filter Statements.

The ISA want happy till the URL-Server statement on the ASA Firewall was changed to: url-server (INSIDE) vendor websense host  (ip address of websense server)  timeout 60 protocol TCP version 4 connections 10
The defaults which work fine if you don't have an ISA server are time out 30, TCP version 4, Connections 5.

I also had to enable "longurl-truncate" and "cgi-truncate" on the "Filter URL" statement but this problem wasn't isolated to the ISA 2006 server. So the Statement would look like: filter url http 0.0.0.0 0.0.0.0 0.0.0.0 0.0.0.0 allow longurl-truncate cgi-truncate

I will also include the solution for getting the proxy setting on all Internet Explorers on a terminal server using Group Policy. 
1: Create a new OU
2: Put terminal servers that you need proxy servers set on in that ou.
3: Create a new Group Policy on the OU.
4: Go to ComputerConfiguration - Administrative Templates - Windows Components - Internet Explorer.
5: Open the Setting: Make Proxy Settings Per Machine(Rather than Per User) and set it to enable.
6: Log in to each Terminal Server as the Local administrator account and set the proxy server information in the Connections Tab of Internet Explorer.
7: Reboot the terminal server. All users that log in from that point will have the Proxy Server information that you defined in Step 6.

I am going to put this solution on all the Forums that I have visited in hopes that no one else will ever have to go though what I had to.

Hope this Helps!


Was this the correct thread for this reply?

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to weirjamin)
Post #: 18

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2004 Firewall] >> HTTP Filtering >> Error code 64: Host not available Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts