• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Getting cached copies even though the webpages are set to no cache...HELP

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 Cache] >> General >> Getting cached copies even though the webpages are set to no cache...HELP Page: [1]
Login
Message << Older Topic   Newer Topic >>
Getting cached copies even though the webpages are set ... - 8.Nov.2005 12:22:00 PM   
JakinH

 

Posts: 13
Joined: 2.Nov.2005
From: Wisconsin
Status: offline
Alright, need some advice here.

I will use yahoo.com for my example because I see it there, but this is happening for many login type sites...some of which we control and have verified cache settings for.

I go to fantasysports.yahoo.com and receive the page just fine. I click sign-in and enter my credentials. It accepts them and redirects back to the main page and I appear to not be logged in....Unless I press CTRL-F5. Then I come up as logged in.

Now, I go to my neighbors PC and type in the URL. Bam! He is logged in as me.

I have viewed the headers, and they are have all the necessary settings to not cache. Yet it is obvious that the cached versions are being returned.

The only caching rule currently is the default one - Only if valid, cache, (user auth, dynamic, and offline all UNchecked.)

What is going on, and how do we fix it?
Post #: 1
RE: Getting cached copies even though the webpages are ... - 16.Nov.2005 3:04:44 PM   
JakinH

 

Posts: 13
Joined: 2.Nov.2005
From: Wisconsin
Status: offline
Ok, we seem to have gotten this working.  I created an identical rule to the default one and applied it, and now it works.

Is this a known bug?


(in reply to JakinH)
Post #: 2
RE: Getting cached copies even though the webpages are ... - 18.Nov.2005 4:30:28 PM   
engel.aloisius

 

Posts: 15
Joined: 27.Jul.2002
From: austria
Status: offline
having a similar problem here: isa is caching everything, but  it is told not to do so in the file-headers. still cant get it up working ...

this is my code (1. for browser, 2. for isa)
Code:
<meta http-equiv="cache-control" content="no-cache">
<meta http-equiv="pragma" content="no-cache">



< Message edited by engel.aloisius -- 18.Nov.2005 4:31:31 PM >

(in reply to JakinH)
Post #: 3
RE: Getting cached copies even though the webpages are ... - 18.Nov.2005 4:58:07 PM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Most likely the browser cache. This is what I see in 99.97% of the cases like this.

HTH,
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to engel.aloisius)
Post #: 4

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2004 Cache] >> General >> Getting cached copies even though the webpages are set to no cache...HELP Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts