• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

In-place upgrade failed 2004-2006

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 General] >> Installation and Planning >> In-place upgrade failed 2004-2006 Page: [1]
Login
Message << Older Topic   Newer Topic >>
In-place upgrade failed 2004-2006 - 26.Sep.2006 12:08:43 AM   
GeoTech

 

Posts: 26
Joined: 23.May2001
From: Richmond, VA USA
Status: offline
The last time (2000-2004) I tried an in place upgrade with ISA I was VERY sorry. While I backed up my configuration files, neither the upgrade succeeded or the restore of my backup file once 2000 was reinstalled. So this time I took full measures against having to stay up until 5am rebuilding my production ISA server including making an image of the boot/os partition. As it turned out, I was glad I did!

Before beginning the install, I made sure I uninstalled the FW client share and rebooted the server, checking the event logs and making sure everything was perfect. I also ran the ISA baseline analyzer and it gave me a clean bill of health. I then backed up my configuration and shutdown and burned the GHOST image, disconnected the network cables, rebooted and began the upgrade of 2004 Standard Edition to 2006 Standard Edition.

The installation went well for the first 10 min and then the Firewall service failed to re-start, although the Windows Installer said everything went peachy and completed successfully. A reboot confirmed that my ISA box was toast, the event log errors started with the Link Translator service failing for "unknown reason" and then all ISA services fail to start. So I tied uninstalling and reinstalling 2006, that worked great until I tried to import my 2004 configuration backup. The restore wizard, correctly identifies the files as a 2004 backup and informs me that it will be converted to 2006 format. But, after restore and trying to restart the services it fails with the same results.

Now this is EXACTLY what happened to my 2000-2004 upgrade. In that case I rebuilt the server config manually from handwritten notes using 2004 (notes really come in handy sometimes) and it has essentially went unchanged since then. This time I just restored the GHOST image and stayed at 2004 level until I can sort this out.

My deductive reasoning is that the config file in someway causes this problem. While I do have a complex network, multiple subnet WAN, split DNS, perimeter network etc. The config should not kill the box should it? The only 3rd party app I have running is WebDirect and I did try uninstalling that with no luck.

So, how did I trouble shoot this and resolve. I really need the site-site VPN features in 2006 for a European office my company has opened and I donít have the time to rebuild from scratch and despite it all, it should just work out of the box.


Thx Ken
 
Post #: 1
RE: In-place upgrade failed 2004-2006 - 26.Sep.2006 1:25:43 AM   
carlos_andres

 

Posts: 44
Joined: 28.Jan.2004
From: Venezuela
Status: offline
Hi Geo,

In place upgrade Works Fine, I have done it myself with a lot of 2004 servers, please check any Owa publishing with the "/Exchange\" parameter which is no compatible with 2006 Version, disable that rule and go foward with the upgrade process.

It should work.

Let me know.

(in reply to GeoTech)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 General] >> Installation and Planning >> In-place upgrade failed 2004-2006 Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts