• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Problem with ISA 2006 EE logging to SQL 2005 SP2

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 Firewall] >> Logging and Reporting >> Problem with ISA 2006 EE logging to SQL 2005 SP2 Page: [1]
Login
Message << Older Topic   Newer Topic >>
Problem with ISA 2006 EE logging to SQL 2005 SP2 - 19.Apr.2007 7:36:06 AM   
wzegwaard

 

Posts: 1
Joined: 19.Apr.2007
Status: offline
We have an array of two load balanced ISA 2005 EE (virtual) servers and we want them to log to a 2-node SQL (physical) server cluster (SQL 2005 EE SP2). So we configured a database with tables with the SQL files from the C:\program files\Microsoft ISA Server dir. At the SQL server we configure windows integrated users with rights on the databases and use ISA 2006 to test the connection. The connection to the database is ok.
We apply the changes and the logging to SQL starts and all goes fine. But when we reboot, at startup the ISA servers (Firewall Service) stops working, because the SQL server cannot be connected.
When we try to reach the SQL server with a ping or a telnet after the server started up, we succeed to reach the server.  An connection test in the firewall logging configuration also succeeds.

We did try to log to a named instance and a default instance, both scenarios didnít work out well.
Is this a known problem?  How can we solve this problem?
Post #: 1
RE: Problem with ISA 2006 EE logging to SQL 2005 SP2 - 19.Apr.2007 10:56:39 AM   
bigtallim

 

Posts: 4
Joined: 6.May2005
From: United States
Status: offline
I wish I was part of the solution "wzegwaard", but I am compounding the problem.

ISA server 2006 -- SQL Server 2000 (SP4)

I too have created a database from the SQL files located on the ISA server disk.  I have followed the explicit direction from the knowledge base article listed below.
http://support.microsoft.com/kb/838710

I test my connection to the SQL server (b.t.w. SQL and ISA are on the same server in my environment) and I receive a positive connection.  When I apply the changes in the ISA Management Console (great addition in 2006).  The changes seem to apply o.k. but then my microsoft firewall service stops, and it will not restart, untill I change the logging feature back to the  MSDE Database option. 

I am trying to use the Web Proxy report logging. 

(in reply to wzegwaard)
Post #: 2
RE: Problem with ISA 2006 EE logging to SQL 2005 SP2 - 26.Apr.2007 4:21:32 AM   
tvbruwae

 

Posts: 69
Joined: 19.Jul.2005
Status: offline
This problem does not seem to be restricted to ISA 2006 either. We just installed SQL Server 2005 + SP2 onto our ISA Server 2004 EE + SP1. When changing the logging from the local MSDE instance to this local SQL (named) instance, an alert is raised ("unspecified error"). Still, the test button reports that the connection to the SQL database is fine..

Hopefully someone is able to shed some light on this. Meanwhile we reconfigured the alert so that the ISA services are not stopped when a log failure alert occurs.


(in reply to bigtallim)
Post #: 3
RE: Problem with ISA 2006 EE logging to SQL 2005 SP2 - 27.Apr.2007 10:03:58 PM   
bigtallim

 

Posts: 4
Joined: 6.May2005
From: United States
Status: offline
I decided to post this issue to the microsoft private forums and I received a response.  There wasn't much information given, but he left behind a link to a site I found might be useful.

I won't be onsite with the client that has this issue untill Tuesday, but I thought I would share the link (if it sheds any light at all).  I am afraid to try this fix remotely, becuase if I shut down my firewall service.  I will probably lose my VPN connection.

Logging to an SQL database in ISA Server 2004 does not work

http://support.microsoft.com/kb/890307/en-us

-- I hope it helps you guys.  If you figure anything out -- please let me know!

(in reply to tvbruwae)
Post #: 4

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 Firewall] >> Logging and Reporting >> Problem with ISA 2006 EE logging to SQL 2005 SP2 Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts