• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

error in publishing a mail server

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2000 General] >> Server Publishing >> error in publishing a mail server Page: [1] 2   next >   >>
Login
Message << Older Topic   Newer Topic >>
error in publishing a mail server - 13.Jul.2005 2:14:00 AM   
nnmmss

 

Posts: 96
Joined: 30.Nov.2004
Status: offline
I want to publish my internal mail server, so i did exactly what I found in "publishing a mail server with ISA server" in this site, but i get this error
"Winsock Error 10065 The host is unreachable. Are you connected to the network?
"
how can i check the error ?

one more thing i should add.
I did telnet as following in mdaemon server

telnet 127.0.0.1 110
+OK par.com POP MDaemon 6.8.5 ready <MDAEMON-F200507131244.AA4454504MD7911@p
pars.com>

but when i do so
telnet Ip_Valid_ISA_Server 110
i just a get cursor do nothing and i can't type anything and after the second i get this
"
Connection to host lost.

C:\Documents and Settings\Administrator.PARS.000>"

if i add the invalid Ip of ISA server to the default gateway of the mail server i can multipop in mail server but i can't send email and i get this error

Message-ID: <001301c58795$1471db10$4c88a8c0@peim.com>
Attempting to send message to gateway.
Attempting SMTP connection to [Invalid_Ip_Isa : 25]
Waiting for socket connection...
Winsock Error 10061 The other host is either down or has refused to connect with you at that IP and/or on that port.
SMTP session abnormally terminated, 0 bytes transferred
I should say these tests have done from inside the Lan.
i am really confused. should set the default gateway of mail server to the Invalid Ip of ISA server? if yes , so why i can't send email, and if No I can neither send email nor receive email.
please help me

one more thing: I tried to restart the smtp service ,so i get this error
C:\Documents and Settings\Administrator.PARS>net stop smtpsvc
System error 1060 has occurred.

The specified service does not exist as an installed service.

does ISA server add the smtp service when publishing the server?

[ July 13, 2005, 08:37 AM: Message edited by: nnmmss ]
Post #: 1
RE: error in publishing a mail server - 13.Jul.2005 4:38:00 PM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hi nnmmss,

make sure the internal mail server is configured as a SecureNAT client and it can resolve external FQDN's.

Once the above done, inbound mail should work if your public MX record points to the IP address of the ISA external interface used in the server publishing rule.

To be able to send outbound mail, there must be a protocol and site&content rule allowing it.

HTH,
Stefaan

(in reply to nnmmss)
Post #: 2
RE: error in publishing a mail server - 14.Jul.2005 1:05:00 AM   
nnmmss

 

Posts: 96
Joined: 30.Nov.2004
Status: offline
Thank you for your answer. at first i should say i am not like you professional

1- about SecureNAT : I read http://www.isaserver.org/tutorials/The_SecureNAT_Client.html and as i told you i have set the ISA invalid Ip as a default gateway for mail server, and also installed Firewall client on mail server. is that all i should do for configuring the mail server as aSecureNAT ?

2- about resolving external FQDN's: the mail server can resolve the FQDN's without any problem

3- i can receive the mails ( inbound mail)

4- but i can not send email (outbound mail). I have a rule in site& content rule-->Allow(any request,any time,all destination,all contetnt).
and 2 protocol rules as following
1-All Protocol-all Ip traffic-allow-always
2-Mail Wizard SMTP -SMTP protocol-allow -always
are these enough? should i add anything else?

and also i did so:
telnet ISA_VALID_IP 25
but it doesn't give the hello message and drop connection immidiately.
and also i tried to stop the smtp service at ISA server so i did:
net stop smtpsvc
i got this error
"System error 1060 has occurred.

The specified service does not exist as an installed service.
"
is this normal? shouldn't i have the smtp service at ISA server?
thank for your attention

[ July 14, 2005, 07:39 AM: Message edited by: nnmmss ]

(in reply to nnmmss)
Post #: 3
RE: error in publishing a mail server - 14.Jul.2005 4:05:00 PM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hi nnmmss,

1. Do *not* install the Firewall client on servers, especially not if you want to server publish them. So, deinstall the Firewall client.

2. & 3. After you done the above, can you still resolve external FQDN's and receive inbound mails?

4. Did you install IIS on ISA server itself? You shouldn't unless you want to place a mail relay server on ISA itself.

Also, if you want to test your mail publishing rule you should do it from an external host. The reason for it is that you can't loop through the ISA external interface.

HTH,
Stefaan

(in reply to nnmmss)
Post #: 4
RE: error in publishing a mail server - 16.Jul.2005 6:31:00 AM   
nnmmss

 

Posts: 96
Joined: 30.Nov.2004
Status: offline
Thank you so much Stefaan .
1- I unistalled the Firewall client and now i can resolve the FQDN's

2- I can pop my email without problem , but i cannot send email to outside of the company. i get this error
Sat 2005-07-16 14:18:21: Session 5; child 1
Parsing Message <c:\mdaemon\remoteq\pd50000000001.msg>
From: myemail@company.com
To: myemail@hotmail.com
Subject: this is a test
Message-ID: <WorldClient-F200507161416.AA16370000@company.com>
Attempting to send message to gateway.
Attempting SMTP connection to [ISA_INVALID_IP : 25]
Waiting for socket connection...
Winsock Error 10061 The other host is either down or has refused to connect with you at that IP and/or on that port.
SMTP session abnormally terminated (Bytes in/out: 0/0)

and if i want to send email directly to the receipnt server i get this error

Attempting MX: P=005 D=hotmail.com TTL=(23) MX=[mx1.hotmail.com] {65.54.166.99}
Attempting SMTP connection to [65.54.166.99 : 25]
Waiting for socket connection...
Socket connection established (192.168.136.76 : 2564 -> 65.54.166.99 : 25)
Waiting for protocol initiation...
Socket connection closed by the other side (how rude!)

and i should add that if i give a valid IP to the mail server it works fine, but behind the ISA it has problem.

i am really going crazy Stefaan .
a)why i cand send email from the company to the other emails.

b)one more question i have. by publishing a mail server on ISA server , does ISA server have SMTP service or the mail server just have the SMTP server and it is just mapped?

c) is this normal
telnet ISA_VALID_IP 25
it doesn't give the hello message and drop connection immidiately.

Thank you so much

[ July 16, 2005, 08:13 AM: Message edited by: nnmmss ]

(in reply to nnmmss)
Post #: 5
RE: error in publishing a mail server - 16.Jul.2005 5:11:00 PM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hi nnmmss,

OK, let's try to clear up the confusion.

1. Does the inbound mail work? I assume it does. Is this correct?

2. Does POP3 to an external POP3 server work? It seems to be. Is this correct?

3. Does SMTP to an external SMTP server work? I guess it doesn't. Is this correct?

Also, what are the ISA logs telling you? Make sure you have enabled the logging of all fields in the ISA MMC. The fields Rule#1 (protocol rule), Rule#2 (site&content rule) and ResultCode contain very important debugging information.

HTH,
Stefaan

(in reply to nnmmss)
Post #: 6
RE: error in publishing a mail server - 17.Jul.2005 1:42:00 AM   
nnmmss

 

Posts: 96
Joined: 30.Nov.2004
Status: offline
OK, let's try to clear up the confusion.

1. yes, inbound mail works

2. yes, POP3 to an external POP3 server works

3. yes, you are right. SMTP to an external SMTP server doesn't work
this is a part of the ISA log file (Firewall)
#Fields: c-ip|cs-username|c-agent|sc-authenticated|s-svcname|s-computername|cs-referred|r-host|r-ip|r-port|time-taken|cs-bytes|sc-bytes|cs-protocol|cs-transport|s-operation|cs-uri|cs-mime-t ype|s-object-source|sc-status|s-cache-info|rule#1|rule#2|sessionid|connectionid

192.168.136.76|-|-|N|fwsrv|TEMP-ISA|-|-|65.59.184.12|80|149475|11106|593568|80|TCP|Connect|-|-|-|20000|-|-|-|192|5357

192.168.136.76|-|-|N|fwsrv|TEMP-ISA|-|-|207.46.253.188|80|62169|692|490|80|TCP|Connect|-|-|-|20000|-|-|-|192|5358

192.168.136.76|-|-|N|fwsrv|TEMP-ISA|-|-|64.4.50.99|25|-|-|-|25|TCP|Connect|-|-|-|10053|-|All protocols|Allow rule|192|5360

192.168.136.76|-|-|N|fwsrv|TEMP-ISA|-|-|65.54.190.50|25|-|-|-|25|TCP|Connect|-|-|-|10053|-|All protocols|Allow rule|192|5361

192.168.136.76|-|-|N|fwsrv|TEMP-ISA|-|-|65.54.167.5|25|-|-|-|25|TCP|Connect|-|-|-|10053|-|All protocols|Allow rule|192|5362

192.168.136.76|-|-|N|fwsrv|TEMP-ISA|-|-|65.54.167.230|25|-|-|-|25|TCP|Connect|-|-|-|10053|-|All protocols|Allow rule|192|5363

192.168.136.76|-|-|N|fwsrv|TEMP-ISA|-|-|69.56.100.18|110|861|-|-|110|TCP|Connect|-|-|-|0|-|All protocols|Allow rule|192|5359

192.168.136.76|-|-|N|fwsrv|TEMP-ISA|-|-|69.56.100.18|25|-
|-|-|25|TCP|Connect|-|-|-|10053|-|All protocols|Allow rule|192|5364

192.168.136.76|-|-|N|fwsrv|TEMP-ISA|-|-|69.56.100.18|110|6239|52|160|110|TCP|Connect|-|-|-|20000|-|All protocols|Allow rule|192|5359

i cannot understand where is the problem?
and one more question is this normal that by telnetting the ISA_VALID IP port 25 i get no answer?(from outside the company)
Thank you stefan

(in reply to nnmmss)
Post #: 7
RE: error in publishing a mail server - 17.Jul.2005 3:42:00 PM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hi nnmmss,

according to the log file the POP3 connection does work:
quote:
192.168.136.76|-|-|N|fwsrv|TEMP-ISA|-|-|69.56.100.18|110|861|-|-|110|TCP|Connect|-|-|-|0|-|All protocols|Allow rule|192|5359
192.168.136.76|-|-|N|fwsrv|TEMP-ISA|-|-|69.56.100.18|110|6239|52|160|110|TCP|Connect|-|-|-|20000|-|All protocols|Allow rule|192|5359

The first entry is the connection request, the second entry is the connection close. Take note that all entries belonging to the same connection must have the same values for the sessionid and the connectionid. With the connection close the number of bytes transferred in/out is also shown.

If we look now at en entry for the SMTP connection, we seen the following:
quote:
192.168.136.76|-|-|N|fwsrv|TEMP-ISA|-|-|65.54.190.50|25|-|-|-|25|TCP|Connect|-|-|-|10053|-|All protocols|Allow rule|192|5361
You can clearly see that the connection request does not succeed (sc-status <> 0). The result shown is the Windows Sockets Error Code 10053 (WSAECONNABORTED). This code means:
quote:
Software caused connection abort: An established connection was aborted by the software in your host computer, possibly due to a data transmission time-out or protocol error.
I looks that the client application has aborted the connection. To be really sure you should take a netmon trace on the ISA internal and external interface to see what is happening on the wire.

If you telnet on TCP port 25 from an external host to your published internal mail server, then the connection should succeed and the banner should normally display. What is your 'ISA_VALID IP'. I can then try it from here.

Also, did you create manually some IP packet filters on ISA server?

HTH,
Stefaan

(in reply to nnmmss)
Post #: 8
RE: error in publishing a mail server - 18.Jul.2005 7:47:00 AM   
nnmmss

 

Posts: 96
Joined: 30.Nov.2004
Status: offline
HI Stefan

Thank so much again.
i try to monitor via netmon tommorrow. but at a glance, the request of send email from port 25 is giving to invalid_ip of ISA from mail server but no such a request from VALID_IP.

but i have these IP packet filters on ISA.

Name|Mode|Filter Type|Protocol|Direction|Local Port|Remote Port|ICMP Type|ICMP Code|Local Computer|Remote Computer

DNS Filter|Allow|DNS LookUp|UDP|Send Receive|All Ports|53| | |Default External Ip Address|Any

Http Outbound|Allow|Custom Filter|TCP|Outbound|Dynamic|80| | |Default External Ip Address|Any

ICMP outbound|Allow|ICMP all outbound|ICMP|Outbound| | | All Types|All Codes |Default External Ip Address|Any

ICMP Ping response(in)|Allow|ICMP ping response|ICMP|Inbound| | |0|0|Default External Ip Address|Any

ICMP Source Quench|Allow|ICMP Source Quench|ICMP|Inbound| | |4|0|Default External Ip Address|Any

ICMP Timeout|Allow|ICMP Timeout|ICMP|Inbound| | |11|All Codes|Default External Ip Address|Any

ICMP Unreachable in|Allow|ICMP Unreachable |ICMP|Inbound| | |3|All Codes|Default External Ip Address|Any

SecureNAT PPTP|Allow|PPTP Call|47|Both| | | | |Default External Ip Address|Any

Terminal service Inbound|Allow|Customer Filter|TCP|Inbound|3389|All Ports| | |Default External Ip Address|Any

and This is what i have get from network monitoring
I wanted to send email from mail server :192.168.136.76 to mine@hotmail.com
  • From 192.168.136.76 To ISA/ std Qry for hotmail.com of type Mail Xchg on Class INET add.
  • From ISA to 192.9.9.3/std Qry for hotmail.com of type Mail Xchg on Class INET add.
  • From 192.9.9.3 to ISA/std Qry Resp. for hotmail.com of type Mail Xchg on Class INET add.
  • ISA to 192.168.136.76/std Qry Resp. for hotmail.com of type Mail Xchg on Class INET add.
  • FROM 192.168.136.76 to 65.54.252.99(hotmail.com)/DES=SMTP PORT ( here i don't understand anything)
  • FROM 192.168.136.76 to 65.54.252.99(hotmail.com)/SRC=SMTP PORT ( here i don't understand anything)
    but i should say in last 2 items above the mail server itself wants to connect to the server(192.168.136.76 to 65.54.252.99) is this right?

Thank you Stefan

[ July 18, 2005, 08:52 AM: Message edited by: nnmmss ]

(in reply to nnmmss)
Post #: 9
RE: error in publishing a mail server - 18.Jul.2005 3:40:00 PM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hi nnmmss,

quote:
but at a glance, the request of send email from port 25 is giving to invalid_ip of ISA from mail server but no such a request from VALID_IP.
What do you mean by that? If an internal host must connect to an external SMTP server then the destination IP address is that of the external SMTP server and the service is TCP port 25.

quote:
This is what i have get from network monitoring
I wanted to send email from mail server :192.168.136.76 to mine@hotmail.com

From 192.168.136.76 To ISA/ std Qry for hotmail.com of type Mail Xchg on Class INET add.
From ISA to 192.9.9.3/std Qry for hotmail.com of type Mail Xchg on Class INET add.
From 192.9.9.3 to ISA/std Qry Resp. for hotmail.com of type Mail Xchg on Class INET add.
ISA to 192.168.136.76/std Qry Resp. for hotmail.com of type Mail Xchg on Class INET add.
FROM 192.168.136.76 to 65.54.252.99(hotmail.com)/DES=SMTP PORT ( here i don't understand anything)
FROM 192.168.136.76 to 65.54.252.99(hotmail.com)/SRC=SMTP PORT ( here i don't understand anything)
but i should say in last 2 items above the mail server itself wants to connect to the server(192.168.136.76 to 65.54.252.99) is this right?

Are you running a DNS server on ISA itself? It seems to be.
Yes, the internal mail server should connect to the IP address returned by the DNS MX query. So, that's OK.

So, it sounds you can't even telnet from the internal mail server to the IP address returned by the DNS MX query (IP address 65.54.252.99) on TCP port 25. Can you telnet from the internal mail server to the IP address of your ISP SMTP server on TCP port 25? If the latter works, it isn't an ISA problem but maybe your ISP doesn't allow you to use any SMTP server except their SMTP servers. If that's the case, you should use them as SMTP relay server (smart host in Exchange terminology).

BTW --- the IP packet filters seem to be fine.

HTH,
Stefaan

(in reply to nnmmss)
Post #: 10
RE: error in publishing a mail server - 19.Jul.2005 5:30:00 AM   
nnmmss

 

Posts: 96
Joined: 30.Nov.2004
Status: offline
quote:
Are you running a DNS server on ISA itself? It seems to be.
Yes I am running the DNS server(which is forwarder one) on ISA Server. but any domain could be resolved very well.

quote:
Can you telnet from the internal mail server to the IP address of your ISP SMTP server on TCP port 25?
i should say we don't use the ISP smtp server, we send email directly for our server to other servers. any way if i want to telnet to any smtp server from mail server i get this message immidiately
"Connection to host lost."

and i should add that i can telnet to that smtp server if i bypass the firewall.
and there is one protocol rule i have "ALL protocol/All Ip Trrafic/Always"

Thanks

[ July 19, 2005, 08:32 AM: Message edited by: nnmmss ]

(in reply to nnmmss)
Post #: 11
RE: error in publishing a mail server - 21.Jul.2005 2:12:00 AM   
nnmmss

 

Posts: 96
Joined: 30.Nov.2004
Status: offline
Hi stephan

I found something, if i install Firewall client in mail server , anything will be fine, it means by installing that, i can send and receive email without any problem,
but should i install the Firewall client on mail server or not?

Thanks

(in reply to nnmmss)
Post #: 12
RE: error in publishing a mail server - 21.Jul.2005 2:19:00 PM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hi nnmmss,

the Firewall client should *not* be installed on a server! If a server need outbound access, that server should be configured as a SecureNAT client. This implies however that you should apply your protocol and site&content rules for that server to a client address set containing the IP address of that server.

Now, the rule for the outbound mail (SMTP protocol) is in fact very similar as the rule for the POP3 access and the latter is working. So, I suggest you create for testing purposes an all open protocol (all IP traffic, any request, always) and site&content (all destinations, any request, all content) rule. If it is working then with the server configured as SecureNAT client, we know for sure it is a rule problem.

BTW --- keep in mind that ISA processes the rules in the following order:
1. Deny rules applying to any request (anonymous).
2. Allow rules applying to any request (anonymous).
3. Deny rules applying to client address sets or users and groups (authenticated).
4. Allow rules applying to client address sets or users and groups (authenticated).


HTH,
Stefaan

(in reply to nnmmss)
Post #: 13
RE: error in publishing a mail server - 23.Jul.2005 7:37:00 AM   
nnmmss

 

Posts: 96
Joined: 30.Nov.2004
Status: offline
Thank u stephan, You helped me alot, the problem solved. let me tell what i have done.
1)in protocol rule, I defined a rule for pop3(because my pop3 also stoped from working)

2) and the mosting interresting was that SMTP didn't work because of the VirusScan, i disabled it, so i could send email. i think i have to go to the Virus scan setting to tell it not to block port 25(i think)

now i have 2 other questions.
a) i want to use worldclient also as a mdaemon web mail.what should i do first? on what subject i should search in this site?

b) next question is that if i have a VPN between ISA and mail server as bellow
----------
| ISA | valid_Ip, Invalid(10,10,10,1)
----------
^
|
---------- Ip:10.10,10.3
| VPN |
---------- Ip:192.168.136.3
^
|
----------
| Mail | Invalid Ip: 192.168.136.2
----------

which ip should i set in mail server defualt gateway, to make it SecureNAT? i think it is 192.168.136.3,isn't it?

Thank you stephan, Thank you so much

[ July 23, 2005, 07:40 AM: Message edited by: nnmmss ]

(in reply to nnmmss)
Post #: 14
RE: error in publishing a mail server - 23.Jul.2005 4:59:00 PM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hi nnmmss,

aha... those damned antivirus programs. I'm not an advocate of running the classic workstation or server antivirus programs on ISA itself. Especially not those with a build in firewall. [Big Grin]

In any case, I'm very glad to hear your inbound and outbound mail is up and running now. [Smile]

About your two questions, I have a hard time figuring out what you are trying to achieve. Please, could you elaborate a little bit more on it?

Thanks,
Stefaan

(in reply to nnmmss)
Post #: 15
RE: error in publishing a mail server - 24.Jul.2005 2:17:00 AM   
nnmmss

 

Posts: 96
Joined: 30.Nov.2004
Status: offline
Hi Stephan

Again Thank you, because you helped me a lot to solve the problem. and about 2 other problems

1)mdaemon (mail server) uses Worldclient for its web mail. but this configuration that i had set in ISA, users from outside the LAN can work with Outlook Express inorder to send and receive emails. now i users from outside the LAN can send/Receive email via web mail(worldclient). specifically the worldclient can be accessed via the port 3000, so form that LAN, i can send email by http://Internalmail:3000
now i want to publish this worldclient to the internet. what should i do? where should i start from? what subject should i search for?

2)The position of Mail server to ISA server is like following ,at this time:
---------
| ISA | Which has 2 Ip,(valid * Invalid)
---------
^
|
---------
| Mail | Which has 1 invalid Ip
---------
inorder to make the mail server a SecureNat , I have set the invalid Ip address of ISA in default gateway of Mail server.
now the question is that if i want to use VPN in my network as following

----------
| ISA | valid_Ip, Invalid(10,10,10,1)
----------
^
|
---------- Ip:10.10,10.3
| VPN |
---------- Ip:192.168.136.3
^
|
----------
| Mail | Invalid Ip: 192.168.136.2
----------
The question is that what Ip should be set in default gateway of Mail server? I think i should be 192.168.136.3. is that right?

Thanks so much
nnmmss

(in reply to nnmmss)
Post #: 16
RE: error in publishing a mail server - 24.Jul.2005 6:05:00 AM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hi nnmmss,

1. If the mail client is HTTP compliant then you should definitely take a look at Web Publishing. If that wouldn't work you can always fallback to Server Publishing.

2. First of all, you should adopt a little bit your terminology. We use here the terms internal and external IP addresses of the ISA internal and external interfaces instead of the terms invalid or valid IP addresses. [Wink]
So, in a simple non-routed internal network, the default gateway of the SecureNAT clients should be configured with the ISA internal IP address. For a routed internal network it is a little bit more complex. Check out Jim's excellent article http://www.isaserver.org/tutorials/Designing_An_ISA_Server_Solution_on_a_Complex_Network.html for more info.
What's the purpose of the VPN in the internal network? I'm a strong advocate of 'keep it simple', especially when you want to have a good understanding of the overall security as a result of the implemented protection measures. [Razz]

BTW --- do you not consider an upgrade to ISA Server 2004. I strongly suggest it, especially when Web Publishing and VPN is used.
Also, the books I definitely recommend are:
- http://www.amazon.com/exec/obidos/ASIN/1928994296/isaserver (ISA 2000).
- http://www.amazon.com/exec/obidos/ASIN/1931836663/isaserver (ISA 2000).
- http://www.amazon.com/exec/obidos/ASIN/1931836191/isaserver/ (ISA 2004).

HTH,
Stefaan

(in reply to nnmmss)
Post #: 17
RE: error in publishing a mail server - 24.Jul.2005 8:23:00 AM   
nnmmss

 

Posts: 96
Joined: 30.Nov.2004
Status: offline
Hi Stefaan

i did web publishing. but different problems occured. let me tell what i did first
a)i did as this article told me:http://www.isaserver.org/tutorials/Publishing_A_Web_Site_Using_ISA_Server_Part_2.html
b)in ISA Server Properties->Incoming web request
-> Connection-> two options occure
1) if i checked "Ask unathenticated users for identification", the user come to the webmail, enter it's username and password (window1) and the the page worldclient appears ,enter account/password, but whatever he/she wants to do ,the window1 appears. the window1 appears many times (during the time that i am in webmail)sometimes it will accpet the username sometimes no. for example i get this error message after entering n times of my username and password, when i wanted to press send button in webmail.

"401 Unauthorized - The server requires authorization to fulfill the request. Access to the Web server is denied. Contact the server administrator. (12209)"

2) if i unchecked "Ask unathenticated users for identification", so the window1 doesn't appear and just the first page of webmail appear but i can not login into webmail.

well although challenging with kind of problem drive me crazy, but i learned a lot, thanks for your help.

[ July 24, 2005, 08:56 AM: Message edited by: nnmmss ]

(in reply to nnmmss)
Post #: 18
RE: error in publishing a mail server - 24.Jul.2005 3:14:00 PM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hi nnmmss,

it's a long time ago I have used Web publishing on ISA 2000. Nevertheless, how is the user authenticating against the web mail server: basic authentication or some form?

To the best of my memory it should work if you don't ask authentication on the incoming web request listener and the web mail server uses basic authentication. Of course, if the web mail server uses some form, then you might ask for basic authentication on the incoming web request listener.

HTH,
Stefaan

(in reply to nnmmss)
Post #: 19
RE: error in publishing a mail server - 25.Jul.2005 9:10:00 AM   
nnmmss

 

Posts: 96
Joined: 30.Nov.2004
Status: offline
Hi Stefan

if i set the authentication to Integrated, then for every action in web mail , a window appears which ask username and password for ISA server authtication. and sometimes it does not accept the correct username and password.

and if i set no authentication is needed ,then nothing works.

which is the best? should i concentrate on asking users for authentication or not?
is there any article for authentication problem . becuase in setting the authentication is required, it makes users crazy because it asks their username and password thousands times.

Thanks

(in reply to nnmmss)
Post #: 20

Page:   [1] 2   next >   >> << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2000 General] >> Server Publishing >> error in publishing a mail server Page: [1] 2   next >   >>
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts