• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Client err msg:"The protocol (http) specified in address not valid

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2000 General] >> Installation >> Client err msg:"The protocol (http) specified in address not valid Page: [1]
Login
Message << Older Topic   Newer Topic >>
Client err msg:"The protocol (http) specified in a... - 26.Oct.2001 12:41:00 AM   
brigzy

 

Posts: 3
Joined: 26.Oct.2001
From: leeds, west yorkshire, uk
Status: offline
Hi
External IE cleints get some of the web site default page then receive the error "The protocol specified in this address is not valid. Make sure the address is correct, and try again".

If you have any clue as to the cause I could do with some moral support!
Brigzy

Post #: 1
RE: Client err msg:"The protocol (http) specified ... - 26.Oct.2001 6:29:00 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi Brigzy,

I haven't seen this one before. Are you using a FQDN in your Destination Set?

Thanks!

Tom

------------------
http://www.isaserver.org/shinder/


Get It Here!


(in reply to brigzy)
Post #: 2
RE: Client err msg:"The protocol (http) specified ... - 26.Oct.2001 12:08:00 PM   
brigzy

 

Posts: 3
Joined: 26.Oct.2001
From: leeds, west yorkshire, uk
Status: offline
Hi Tom
thanks for your reply.
The web site in question is on the ISA server itself on port 80. I read in the ISA help that I shouldn't use a destination set if WEB is on the ISA Server - but to use IP Packet Filters - allowing HTTP Inbound on port 80 - so this I have done!

There is another oddidty that might help you shed some light ... when I try to access the web site from the internal network (via proxy server) the page displays OK but then a file download dialogue appears with a stange file name.

Next thing I was going to try (tonight 1800 GMT) was to replace the default page with a simple 'Hello World' htm page - just in case my web page is the problem.

Brigzy

quote:
Originally posted by tshinder:
Hi Brigzy,

I haven't seen this one before. Are you using a FQDN in your Destination Set?

Thanks!

Tom



(in reply to brigzy)
Post #: 3
RE: Client err msg:"The protocol (http) specified ... - 28.Oct.2001 5:08:00 PM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi brigzy,

Things get tricky when you're running a web site on the ISA Server itself. Yes, you can open port 80 on the external interface, but then you'll have to make sure the incoming web requests listener isn't listening on the same port. You can disable the incoming web requests listener by selecting the 'individual' listeners option and leaving it empty.

You might try publishing the web site using an alternate port on the internal interface. Make sure to disable socket pooling! Check out www.isaserver.org/shinder for more information on this.

HTH,
Tom

------------------
http://www.isaserver.org/shinder/


Get It Here!


(in reply to brigzy)
Post #: 4
RE: Client err msg:"The protocol (http) specified ... - 29.Oct.2001 4:18:00 PM   
brigzy

 

Posts: 3
Joined: 26.Oct.2001
From: leeds, west yorkshire, uk
Status: offline
Thanks for your advice ... follwing your guidlines I now have the WEB on a seperate server .. and things are looking better.
After reading one of your tutorials (properly) I realise I have made a mistake with the Active Directory install - I have configured it as a root server.

This would explain why my NSLOOKUP's fail, even though the WEB proxy service works fine.
So tonights mission is to reinstall Active Directory, DNS etc on the DC.

Many thanks for your help.
Brigzy
PS most excellent and informative web site!

quote:
Originally posted by tshinder:
Hi brigzy,

Things get tricky when you're running a web site on the ISA Server itself. Yes, you can open port 80 on the external interface, but then you'll have to make sure the incoming web requests listener isn't listening on the same port. You can disable the incoming web requests listener by selecting the 'individual' listeners option and leaving it empty.

You might try publishing the web site using an alternate port on the internal interface. Make sure to disable socket pooling! Check out www.isaserver.org/shinder for more information on this.

HTH,
Tom



(in reply to brigzy)
Post #: 5

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2000 General] >> Installation >> Client err msg:"The protocol (http) specified in address not valid Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts