• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

WinMx

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2000 Misc.] >> Gaming >> WinMx Page: [1]
Login
Message << Older Topic   Newer Topic >>
WinMx - 29.Oct.2002 4:24:00 PM   
Mr.Bluesman

 

Posts: 3
Joined: 29.Oct.2002
Status: offline
It seems this has been asked alot, but I still can't get it to work. I have the following setup: 3 protocol definitions: 1- port 6699 TCP Inbound, 2- Port 6257 UDP receive, 3- Port 6257 UDP Send.
IP Packet Filters: 1 -Allow TCP both directions - Local and remote ports set to Any. 2- Allow UDP both directions - Local and remote ports set to any.
Protocol Rule: Allow the 3 protocol definitions listed above.
Trying to connect using the Socksv4 proxy & Firewall client is installed.
Am I missing a setting here? Thanks for any help.
Post #: 1
RE: WinMx - 30.Oct.2002 4:23:00 PM   
ASHRID

 

Posts: 68
Joined: 6.Nov.2001
From: Southampton, Hampshire, UK
Status: offline
IF you have the firewall client installed you shouldnt need any additional config (protocols/ports etc).

Been a while since I used it though

(in reply to Mr.Bluesman)
Post #: 2
RE: WinMx - 22.Nov.2002 10:00:00 PM   
ustraveler99

 

Posts: 2
Joined: 10.Nov.2002
From: South Texas
Status: offline
I am having the same problem that you had.

I have set up protocol rules, packet rules, publishing rules, installed the firewall client and cannot get passed the blinking yellow "connecting" icon.

I have 2 protocol definitions:
1- port 6699 TCP Inbound,
2- Port 6257 UDP send receive,

IP Packet Filters:
1 -Allow TCP both directions - Local and remote ports set to Any.
2- Allow UDP both directions - Local and remote ports set to any.

Protocol Rule:
Allow the 2 protocol definitions listed above.

I have tried with and without the Socksv4 proxy

I have installed the Firewall client on the winmx workstation.

I have also tried where the winmx workstation points to the ISA server as a proxy server.

I have uninstalled winmx, rebooted and re-installed.

Nothing seems to work.

I am sooo frustrated. Can someone offer me some help here? What am I missing?

Thanks!
Traveler

(in reply to Mr.Bluesman)
Post #: 3
RE: WinMx - 24.Nov.2002 6:36:00 PM   
tabbertmj

 

Posts: 6
Joined: 24.Nov.2002
From: Minnesota
Status: offline
I think I have found the answer. WinMX is set to connect with a secondary connection. Right now I have to may ports open, but I did get WinMX to connect. I have a protocol definition as follows...

6699 TCP Inbound

Secondary Connections:

1728 TCP Outbound
1769-1772 UDP Receive Send
1885-1886 UDP Receive Send
6257 UDP Receive Send
6699 TCP Outbound
7950-7952 TCP Outbound

I hope that will help somebody. I would like to hear other results with those settings. I will try to narrow them down some. But it is a start. Good luck.

Mike

(in reply to Mr.Bluesman)
Post #: 4
RE: WinMx - 12.Dec.2002 2:30:00 PM   
mboczek

 

Posts: 81
Joined: 13.Jun.2002
From: Corunna, Ontario
Status: offline
I used to have winmx working but about 6 months ago had to rebuild my isa server. Of course when I finally got round to re-enabling winmx - it didn't work.

It appears that my older version of winmx (sorry, it was either 2.2.x or 3.2.1 (not sure which)) was trying to connect to some winmx.com servers that it couldn't resolve (find). I updated to 3.31 and the problem went away.

Anyone who tries the following setup without success should try updating to winmx 3.31 before giving up [Wink]

Protocol Definitions:-
(1)port 6699 TCP inbound, no secondaries
(2)port 6699 TCP outbound, no secondaries
(3)port 6257 UDP send/receive, no secondaries
(4)port 6257 UDP receive/send, no secondaries

Protocol Rule:-
allow, selected protocols, all the above ie 1 to 4.

IP Packet Filters
(5) Custom, UDP protocol, direction both, fixed local port 6257, remote port all.
(6) Custom, TCP protocol, direction both, fixed local port 6699, remote port all.

Server Publishing Rules
(7) (int ip as required), external IP default, map using rule (4) above.
(8) (int ip as required), external IP default, map using rule (1) above.

WinMX
Outgoing TCP Connection - connect direct
Incomming TCP - listen on port 6699
In/out UDP - send & receive datagrams on port 6257
Host name resolution - use operating system
Network - make a primary connection

Firewall Client (probably unnecesary)
app winmx, localbindtcpports, 6699
app winmx, localbindudpports, 6257

The above works with winmx installed on a pc on a lan behind an ISA server - may need to change if running on the isa itself.

It allows primary connects, including uploads (although they seem slow - not a bad thing [Razz] ).

Disable packet filter (6) to prevent uploads.
Without the UDP rules I could get a connection, but didn't receive any search responses.

Other than the last few comments I'm not sure which of these rules are mandatory and which can be omitted. You are welcome to refine...

Malc

(in reply to Mr.Bluesman)
Post #: 5
RE: WinMx - 14.Dec.2002 5:04:00 PM   
jedy

 

Posts: 8
Joined: 14.Dec.2002
From: Germany
Status: offline
@malc

thank you for the detailed discription! =)

I have tried your setup but I am still having problems ... =(

My problem is the server publishing rule. I can not specify the external ip default because the ISA works with an dial-out connection.

Can someone give me a configuration making Winmx workt behind the ISA without an server publishing rule!??

Thanks!

jedy

(in reply to Mr.Bluesman)
Post #: 6
RE: WinMx - 26.Dec.2002 5:23:00 PM   
jedy

 

Posts: 8
Joined: 14.Dec.2002
From: Germany
Status: offline
Hello!

After hard work WinMX 3.31 runs on my client so far [Wink]

So I would like to share my experience with ISA and WinMX. With observance of the following steps the configuration was successful!

1) Create a protocol rule to allow all IP traffic outbound
2) Use the firewall client
3) Create two protocol definitions
1. primary: 6699 TCP in
secondaries: 1024-5000 udp send/receive
1024-5000 udp receive/send
6257 udp send/receive
6257 udp receive/send
(secondaries probably unnecesary)

2. 6257 UDP receive/send
no secondaries
4) Create a protocol rule with the above protocol definitions

WinMX Configuration:

Network: make a secondary connection
Outgoing TCP: direct
Incomming TCP: listen Port 6699
In/Out UDP: send/receive port 6257

Firewall Client Applications:
WinMX.exe: remotebindudp 6257
WinMX.exe: localbindudp 6257
WinMX.exe: remotebindtcp 6699
WinMX.exe: localbindtcp 6699

good luck =)

jedy

(in reply to Mr.Bluesman)
Post #: 7
RE: WinMx - 23.Jan.2003 3:37:00 PM   
Joe F.

 

Posts: 5
Joined: 17.Feb.2002
From: Italy
Status: offline
Now finally WinMX runs on my S-NAT Clients!
First, i've made the 4 protocol definitions like Malc Boczek (and of course selected all in protocol rule). I have not added the packet filters and server publishing rules, but 3 more protocol rules for TCP Outgoing Port 7950,7951,7952. And it works [Smile]

(in reply to Mr.Bluesman)
Post #: 8
RE: WinMx - 26.Feb.2003 3:16:00 PM   
djmrmagic

 

Posts: 4
Joined: 26.Feb.2003
From: London, UK
Status: offline
YES ! Joe F, your the man. Where did you get those ports from?? But mine now works as a Secure NAT client! Thanks!

(in reply to Mr.Bluesman)
Post #: 9

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2000 Misc.] >> Gaming >> WinMx Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts