Upgrade from 2000 to 2004 breaks published servers (Full Version)

All Forums >> [ISA Server 2004 General ] >> Installation



Message


perryhs -> Upgrade from 2000 to 2004 breaks published servers (17.Aug.2004 9:38:00 AM)

I have upgraded from 2000 to 2004 fairly successfully. I ran tests using the migration tool and reading the log files for errors before doing the upgrade, so the actual upgrade process went smoothly and everything seems to work just as before - with one exception: I can no longer access my internal Exchange 2003 through OWA, nor can I access my internal web site externally. The error message is the standard 10061 "connection refused". The connection was never refused under ISA 2000, so there must be some configuration differences between 2000 and 2004. All of my publishing rules seem to have been imported correctly from the old server, and, according to the release notes and migration notes from Microsoft, these publishing rules "should" be working. Have I missed something here?

[ August 18, 2004, 03:14 PM: Message edited by: phs ]




tshinder -> RE: Upgrade from 2000 to 2004 breaks published servers (17.Aug.2004 9:41:00 PM)

Hi Phs,

1. Configure the Web Proxy clients to use the autoconfiguration script

2. Configure Web Proxy clients for Direct Access, so that they bypass the Web Proxy for internal network resources.

3. Setup your split DNS asap!

HTH,
Tom




perryhs -> RE: Upgrade from 2000 to 2004 breaks published servers (18.Aug.2004 3:23:00 PM)

I'm sorry I was unclear about the problem. My internal clients which run (and those that don't run) the firewall client software have no problem accessing the site. However, when I sit at home or try to access the site from another subnet, the attempt fails, although it was successful before.

Perhaps I misunderstood you. Do you mean to say that anyone who accesses our site externally must install the web proxy client on their machines? I really don't want to restrict access to the site just to those that work here...




Uju Sivas -> RE: Upgrade from 2000 to 2004 breaks published servers (19.Aug.2004 4:33:00 PM)

for the connection refuse issues,
after upgrade, and once reboot the ISA server,

DID YOU RESTART YOUR DNS SERVER ?




perryhs -> RE: Upgrade from 2000 to 2004 breaks published servers (22.Aug.2004 11:52:00 AM)

Thanks for the tip. I had restarted the dns servers; and, although it looked for a moment that there was trouble in dns-land, in the end I figured it had to be ISA. Sure enough, when looking through the long list of firewall settings, I discovered that for some inexplicable reason, ISA 2004 forgot to migrate one of my published servers from ISA 2000. I used the simple publishing wizard to republish the missing server, and everything else worked again as it used to.

I guess the lesson to be learned here is that if you migrate, write down (or export) all of the settings on the old server first and then double check each one against the new server to see if everything made it.

The new ISA works like a charm.




Page: [1]