• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Citrix Web Interface clients, Getting refused to establish a connection error

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 General ] >> General >> Citrix Web Interface clients, Getting refused to establish a connection error Page: [1]
Login
Message << Older Topic   Newer Topic >>
Citrix Web Interface clients, Getting refused to establ... - 23.Aug.2004 12:04:00 PM   
MayurP

 

Posts: 2
Joined: 23.Aug.2004
From: London
Status: offline
I have some client accessing my Citrix WebInterface (NFuse) server thru their internal ISA Server Proxy server.

They receive the below error when they try to connect to the published application.

Proxy connection failed: The configured proxy server refused to establish a connection.

Clients can connect successfully when they use an ISP dialup modem account to connect to the internet and access our Citrix servers.

The problem is only when they visit this organisation and try and connect to our Citrix servers from the company internal LAN using the Browser Proxy server settings they receive this error.

Has anyone had a similar issue? what could be blocking this.

Thanks
Post #: 1
RE: Citrix Web Interface clients, Getting refused to es... - 23.Sep.2004 9:16:00 PM   
mcosta54

 

Posts: 2
Joined: 23.Sep.2004
Status: offline
Any luck on a fix for this issue?

(in reply to MayurP)
Post #: 2
RE: Citrix Web Interface clients, Getting refused to es... - 24.Sep.2004 8:54:00 PM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hi Mike,

what protocols are *exactly* used? Is this HTTP or HTTPS for the NFuse (Web) part and ICA (TCP port 1494) for the ICA client?

Also, is the ISA server at the customer site installed in Web Proxy or Integrated mode?

HTH,
Stefaan

(in reply to MayurP)
Post #: 3
RE: Citrix Web Interface clients, Getting refused to es... - 29.Sep.2004 5:02:00 PM   
jbentivoglio

 

Posts: 16
Joined: 28.Aug.2002
Status: offline
I'm having the same error pop up for my users. While trying to connect to their ICA applications using the Program Neighborhood Agent they get the error message.

I have created a rule to allow http, https, and ica from internal and local host to my application server with the web interface but the error still appears.

(in reply to MayurP)
Post #: 4
RE: Citrix Web Interface clients, Getting refused to es... - 29.Sep.2004 8:51:00 PM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hey guys,

In order to connect with an ICA client succesfully to an external Citrix server you must have enabled two protocols.

First of all the ICA protocol (TCP port 1494 outbound). I believe this is a predefined protocol. You can verify that this protocol rule is working with the command telnet <citrixserver> 1494 from a client. The telnet connection should succeed and you should get an answer like ICA...ICA...ICA.

The second protocol is used for the Citrix farm browsing (which server to connect to for which application). Now, that is depending on the Citrix server release. So, you'll have to check that with the Citrix administrator.

The old style of Citrix browsing uses the UDP protocol. If you need that, create a protocol definition for UDP port 1604 send receive.
The new style of Citrix browsing is called TCP/IP+HTTP (XML service) and uses by default TCP port 80 outbound. Here you'll have to check with the Citrix administrator on which port he has enabled the XML service.

Note however that if the Citrix Secure Gateway is used all traffic will probably be HTTP/HTTPS.

HTH,
Stefaan

(in reply to MayurP)
Post #: 5
RE: Citrix Web Interface clients, Getting refused to es... - 29.Sep.2004 10:53:00 PM   
jbentivoglio

 

Posts: 16
Joined: 28.Aug.2002
Status: offline
Thanks for the help Stefaan,

I think my setup is a little different than Mike's and I'm confused. How would I correct this error message when the users and the Metaframe XP servers are all on the internal network? Do I need to create an access rule on my back end ISA2004 box even though the "Bypass proxy for local addresses" is enabled?

(in reply to MayurP)
Post #: 6
RE: Citrix Web Interface clients, Getting refused to es... - 29.Sep.2004 11:02:00 PM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hi Jeff,

when both the client and the servers are on the internal network, that traffic should *never* go through the ISA server in the first place.

Because your question is about ISA 2004, I suggest you re-post your question in the appropriate ISA 2004 forums. Otherwise it is very confusing! [Wink]

HTH,
Stefaan

(in reply to MayurP)
Post #: 7
RE: Citrix Web Interface clients, Getting refused to es... - 13.Oct.2004 1:14:00 AM   
grinn253

 

Posts: 76
Joined: 12.Jul.2004
From: Seattle
Status: offline
quote:
Originally posted by spouseele:

First of all the ICA protocol (TCP port 1494 outbound). I believe this is a predefined protocol. You can verify that this protocol rule is working with the command telnet <citrixserver> 1494 from a client. The telnet connection should succeed and you should get an answer like ICA...ICA...ICA....
The old style of Citrix browsing uses the UDP protocol. If you need that, create a protocol definition for UDP port 1604 send receive.HTH,
Stefaan

Thanks! Stefaan for answering a question i didn't yet have prior to just a couple of hours ago. [Big Grin]

Have a great day!
Edgardo

[ October 13, 2004, 01:15 AM: Message edited by: grinn253 ]

(in reply to MayurP)
Post #: 8
RE: Citrix Web Interface clients, Getting refused to es... - 13.Oct.2004 5:33:00 PM   
sikoniko

 

Posts: 57
Joined: 14.Oct.2002
Status: offline
I get this same message. It only happens with USE PROXY SERVER FOR LAN setting checked under connections. If I uncheck it, it works for my internal server.

I have installed a test box with presentation server 3.0. would the 1604 UDP port still apply?

(in reply to MayurP)
Post #: 9
RE: Citrix Web Interface clients, Getting refused to es... - 20.Oct.2004 4:13:00 PM   
tinto

 

Posts: 247
Joined: 9.Sep.2004
From: Italy
Status: offline
quote:
The old style of Citrix browsing uses the UDP protocol. If you need that, create a protocol definition for UDP port 1604 send receive.
hi,

in ISA2004 is already defined the ICA protocol, which has the UDP 1604 etc etc as secondary connection. I had to allow my pc to connect to a remote citrix server and adding ICA protocol in the allowed outbound prot. were enough to ma ke this strange thing work [Wink]

(in reply to MayurP)
Post #: 10

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2004 General ] >> General >> Citrix Web Interface clients, Getting refused to establish a connection error Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts