• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Web sites are loading very slow! Why? II

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 Cache] >> General >> Web sites are loading very slow! Why? II Page: [1]
Login
Message << Older Topic   Newer Topic >>
Web sites are loading very slow! Why? II - 2.May2006 8:24:03 PM   
jamnana

 

Posts: 10
Joined: 28.Apr.2006
Status: offline
Okay....I'm beginning to think that it's now either a hardware or more likely configuration problem.....probably with DNS. I have the internal AD DNS servers setup to forward to ISA 2004, which is setup as a Cache-ony DNS with forwarding out to ISP's DNS servers.

I have added the EnablePMTUDiscovery value of 1 and added the access rule and still having problems.....I'm running a 64 bit CPU and using SATA drives.....would this type of hardware effect caching????? I can see the CPU causing problems but thought I should mention the SATA drives. My ISA 2000 system works as expected and has no problems loading sites.

Does a Cache-Only DNS server slow down the loading of web pages until it begins to use it own records to resolve web request?

I ran the firewall client and web proxy client and both are loading pages very slow and it usually will only load about 3/4 of the page and then locks-up.
Post #: 1
RE: Web sites are loading very slow! Why? II - 4.May2006 3:45:06 PM   
jamnana

 

Posts: 10
Joined: 28.Apr.2006
Status: offline
I think I found the problem. My AV software was causing the cache or loading of pages to load real slow. As soon as I stopped those services....everything was working normal again. Now I need to setup some rule or should it be an application filter to allow this program to run on the local box and sync with server to get it's updates. I ran netstat and it looks like there are four TCP ports that need to be opened on the ISA box and one TCP port connection on the AV server.

(in reply to jamnana)
Post #: 2
RE: Web sites are loading very slow! Why? II - 4.Jul.2006 11:39:23 AM   
AlexMC

 

Posts: 9
Joined: 20.Jun.2006
Status: offline
First thing i would do (although you may have already done this) is to disable 'On-Access Scanning' for your AV software.

Generally, you shouldn't use it on these sorts of servers (like Exchange, SQL, etc) - you can then setup a scan job over night which would pick up an nasties that lurk on the box.

If you must, then I think you have to un-scan the ISA, the SQL, and the Cache directories.  Not sure exactly, but it would make sense to exclude them.  Maybe someone can confirm?

Just a thought in case you haven't already done so.

< Message edited by AlexMC -- 4.Jul.2006 11:47:22 AM >

(in reply to jamnana)
Post #: 3
RE: Web sites are loading very slow! Why? II - 18.Aug.2006 3:23:59 AM   
Brick

 

Posts: 2
Joined: 18.Aug.2006
Status: offline
I have been looking for the cause of this slow internet web browsing all over the forums and you guys have sorted it out for me! And the solution was soo simple! Thanks!!
 
 
Other indicators of this problem are pages only half loading with some images and pictures not loading first time. 
 
Just to help anyone else in my position if you are experiencing very slow web browsing with ISA2004 on Server2003 first check the EnablePMTUDiscovery registry entry is set to 1 as explained in this Microsoft support doc.
 
http://support.microsoft.com/default.aspx/kb/905179/en-us
 
 
And also make sure you donít have Antivirus real time scanning enabled on your ISA box or at least not scanning the ISA cache. I didnít notice since real time scanning was enabled by default!
 
Once I fixed these two things browsing at all my ISA secured sites went back to how it should be!
 
Hope this help everyone!
 
Regards
 

(in reply to AlexMC)
Post #: 4

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2004 Cache] >> General >> Web sites are loading very slow! Why? II Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts