• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

OWA publishing with FBA and redirection - still not working!

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 General ] >> Exchange Publishing >> OWA publishing with FBA and redirection - still not working! Page: [1]
Login
Message << Older Topic   Newer Topic >>
OWA publishing with FBA and redirection - still not wor... - 25.May2006 6:29:33 PM   
andyhwc

 

Posts: 13
Joined: 23.May2006
Status: offline
I still cannot get the "/exchange" redirection working on the unihome ISA at DMZ, problem first posted here:
http://forums.isaserver.org/Help!__OWA_%2fExchange_redirect_problem/m_2002017290/tm.htm
 
below is the latest observations...
 
 
When ISA is joined to the internal domain.  Force Authetication is ON.

When I entered https://owa.internal.org/exchange, URL will be translated to
https://owa.internal.org/CookieAuth.dll?GetLogonWrapper?url=%2Fexchan...

When I entered https://owa.internal.org/, URL will be translated to
https://owa.internal.org/CookieAuth.dll?GetLogonWrapper?url=%2F&reason=0

https://owa.internal.org/exchange always work.

https://owa.internal.org/ shows "404 Page not found" after logon credential
is entered at the logon form, but if you change the URL to
https://owa.internal.org/exchange, the inbox is displayed immediately.



When ISA is NOT a domain member.  Force Authetication is ON.
The authentication process fail on both https://owa.internal.org or
https://owa.internal.org/exchange with below error even when the correct
logon credential is entered:

"You could not be logged on to Outlook Web Access. Make sure your
domain\user name and password are correct, and then try again."



Post #: 1
RE: OWA publishing with FBA and redirection - still not... - 30.May2006 1:34:29 AM   
andyhwc

 

Posts: 13
Joined: 23.May2006
Status: offline
look like I asked a stupid question that nobody want to jump in...

Anyway I workaround the /Exchange redirection problem by using the error page redirection instead.  I still like to know why the path redirection doesn't work for me. 

(in reply to andyhwc)
Post #: 2
RE: OWA publishing with FBA and redirection - still not... - 26.Jun.2006 5:35:14 PM   
andyhwc

 

Posts: 13
Joined: 23.May2006
Status: offline
The redirection problem never goes away!  A small numbers of users get "You do not have permission to view this page" error when they enter http or https URL without the /Exchange.  So the 12202r.htm code doesn't work for them.  Those affected clients are using basic XP Pro machine at home, no custom error pages, one of the user even tried turn off the firewall but same error. 


12202r.htm is like below...

<HTML>
<body onLoad="SecurePortRedirect();">
</body>
<script language="javascript">
function SecurePortRedirect()
{
strURL = location.host;
if(strURL == "email.owa.ca")
{
strSecure = "https://email.owa.ca/exchange";
document.location = strSecure;
}
}
</script>
</html>

(in reply to andyhwc)
Post #: 3
RE: OWA publishing with FBA and redirection - still not... - 27.Jun.2006 10:15:37 AM   
yatin_fredrick

 

Posts: 13
Joined: 26.Jun.2006
Status: offline
you may want to ensure that the forms-based authentication is ON in the Listener's properties.
Secondly, "ensure" that you have added /Exchange\ in the paths tab of your Web rule properties.
Note: you do not have to create a new rule as mentioned in one of the msexchange.org article. You simply add /Exchange\ in existing rules.

I did it yesterday and it worked.

Remove Integrated Authentication if selected.
In addition to /Exchange\, ensure that \Exchange\* and  \Exchweb\* paths are present


hope this helps.

(in reply to andyhwc)
Post #: 4
RE: OWA publishing with FBA and redirection - still not... - 27.Jun.2006 1:42:58 PM   
andyhwc

 

Posts: 13
Joined: 23.May2006
Status: offline
Why do I still need /Exchange\ if I am using 12202r.htm for redirection?

(in reply to yatin_fredrick)
Post #: 5
RE: OWA publishing with FBA and redirection - still not... - 27.Jun.2006 3:03:38 PM   
yatin_fredrick

 

Posts: 13
Joined: 26.Jun.2006
Status: offline
I dont know about script that you wrote. I guess the script can be mainly useful for http to https redirection as you see in ISA_redirects.zip tool from isatools.org.

It is always easier and "supported" operation when you simply add /Exchange\ in paths tab. It works like a charm.
You can temporarily remove the script and try this trick and it should work.

Do update me in case...

Reference:
http://www.msexchange.org/articles/Redirecting-OWA-Users-Correct-Directories-Protocols-Part1.html

(in reply to andyhwc)
Post #: 6

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2004 General ] >> Exchange Publishing >> OWA publishing with FBA and redirection - still not working! Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts