• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

SonicWall frontend and ISA 2004 backend

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 Cache] >> Web Proxy client >> SonicWall frontend and ISA 2004 backend Page: [1]
Login
Message << Older Topic   Newer Topic >>
SonicWall frontend and ISA 2004 backend - 11.Sep.2006 7:17:42 AM   
GerhardC

 

Posts: 4
Joined: 5.May2006
Status: offline
I had recently been working on an issue which I thought might interest other people that have a similar problem.

Following a new implementation we had been experiencing issues access Hotmail mailboxes and issues with replying/forwarding messages using Yahoo mail.

The client had a SonicWall 3060 as the edge firewall and ISA 2004 with SP2 (with KB916106 applied) as back firewall.
When configured to surf directly through the SonicWall the above websites functioned 100%, but proxying through ISA gave us the following error:





Network Access Message: The page cannot be displayed








Explanation: The request timed out before the page could be retrieved.

Try the following:

Refresh page: Search for the page again by clicking the Refresh button. The timeout may have occurred due to Internet congestion.
Check spelling: Check that you typed the Web page address correctly. The address may have been mistyped.
Access from a link: If there is a link to the page you are looking for, try accessing the page from that link.
Contact website: You may want to contact the website administrator to make sure the Web page still exists. You can do this by using the e-mail address or phone number listed on the website home page.
    If you are still unable to view the requested page, try contacting your administrator or Helpdesk.










    Technical Information (for support personnel)

    Error Code 64: Host not available
    Background: The gateway or proxy server lost connection to the Web server.
    Date: 9/11/2006 4:57:06 AM
    Server: servername
    Source: Remote server



      Initially believing that this issue was an ISA related problem i then connected the ISA directly to the internet connection (no SonicWall as edge) only to find that Hotmail worked 100%... In other words the SonicWall was doing something wrong once the ISA was proxying the request.

      Doing a couple of searches I came up with the following article on the SonicWall page referring to issues accessing Hotmail and some other websites.





      SonicWALL:
      Now, based on what you told me I understand that:
    • You want help with Content Filtering.
    • You want help with Content Filter Service (Standard or Premium).
    • You are unable to access Hotmail and some other sites with Content Filtering Service (CFS) enabled.


      SonicWALL:
      This issue occurs when CFS is enabled on the SonicWALL and is then configured to use an external Web Proxy Server which does not comply with TCP RFC 1323. Upgrading to 3.1.0.11 Enhanced may resolve this problem. If the issue persists, follow these additional steps:
      1. Access the hidden diag.html page.
      2. Click Internal Settings.
      3. Deactivate the 'Enforce Host Tag Search with for CFS' check box.
      4. Click Apply then Close to save the change and return to the regular management interface.

      And yes you guessed it, once we had disabled the security feature on the SonicWall article the Hotmail and Yahoo access suddenly started working.  The firewall was already running a higher build than the proposed 3.1.0.11 so disabling was the only fix.

      As this is a hidden setting I have not been able to get any documentation explaining what the feature does exactly, but it has something to do with the Content Filtering System built into the SonicWall firewall.  It also only affects certain websites (in this case Hotmail) and only when using ISA as a proxy server.

      Once I get an answer from the support I will post the functionality and what happens when this feature is disabled. 

      I found a couple of forum articles where other people had similar issues using Squid proxies and SonicWall and it might be related.

      Hope this helps you guys somewhere,

      /GC

      < Message edited by GerhardC -- 12.Sep.2006 4:34:34 AM >
    • Post #: 1
      RE: SonicWall frontend and ISA 2004 backend - 12.Sep.2006 10:21:15 PM   
      mgfirewall

       

      Posts: 7
      Joined: 9.Aug.2006
      From: OC
      Status: offline
      Thank you sir, this proved to resolve the same issue we were experiencing.  We have a SonicWALL 4060 running enhanced firmware with ISA2004sp2 behind it.  We saw similar behaviour last year that affected traffic to many sites, however this time we only had problems with hotmail.  That CFS is great stuff but can prove troublesome at times.

      (in reply to GerhardC)
      Post #: 2
      RE: SonicWall frontend and ISA 2004 backend - 29.Aug.2010 6:25:32 AM   
      joshiearayil

       

      Posts: 1
      Joined: 29.Aug.2010
      Status: offline
      Thanks you very much..This really helped me to resolve the same issue...

      I was doing all kind of experimnets on ISA 2006 to resolve this issue

      This article helped me...

      (in reply to GerhardC)
      Post #: 3

      Page:   [1] << Older Topic    Newer Topic >>
      All Forums >> [ISA Server 2004 Cache] >> Web Proxy client >> SonicWall frontend and ISA 2004 backend Page: [1]
      Jump to:

      New Messages No New Messages
      Hot Topic w/ New Messages Hot Topic w/o New Messages
      Locked w/ New Messages Locked w/o New Messages
       Post New Thread
       Reply to Message
       Post New Poll
       Submit Vote
       Delete My Own Post
       Delete My Own Thread
       Rate Posts