• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

ISAServer stopped working after upgrade to 2006

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 General] >> General >> ISAServer stopped working after upgrade to 2006 Page: [1]
Login
Message << Older Topic   Newer Topic >>
ISAServer stopped working after upgrade to 2006 - 7.Oct.2006 1:17:56 PM   
fermo111

 

Posts: 17
Joined: 7.Oct.2006
Status: offline
I have migrated from ISAServer Standard 2004 to ISAServer Standard 2006. After the installation completed, ISAServer would not start anymore. All the Application Filters fail loading. The only way to make ISAServer start is to disable all of them.

I tried to uninstall ISAServer 2006 and go back to 2004 with no success. Same problem.

Any help?

Luca
Post #: 1
RE: ISAServer stopped working after upgrade to 2006 - 8.Oct.2006 11:55:15 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi Luca,

That's unusual. I've done many in place upgrades without any problems at all.

Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to fermo111)
Post #: 2
RE: ISAServer stopped working after upgrade to 2006 - 9.Oct.2006 5:35:31 PM   
fermo111

 

Posts: 17
Joined: 7.Oct.2006
Status: offline
Thanks Tom.

After many attempts to delimitate the problem, I have found that there are 5 Application Filters that prevent ISA from starting. These are:
- DNS Filter
- FTP Access Filter
- H.323 Filter
- RTSP Filter
- SOCKS V4 Filter

The other filters are OK. As soon as I enable one of these, ISA does not start and I get the following error:

ISA Server could not load the application filter SOCKS V4 Filter ({25765C04-C80B-494C-914E-286297DB8C8E}). FilterInit failed with the error code 0x800401f3. To attempt to activate this application filter again, stop and restart the Firewall service.

The error is the same for every one of the 5 filters listed above.

Are there any tools that I can use to find out what the problem could be?

Thanks

Luca

(in reply to tshinder)
Post #: 3
RE: ISAServer stopped working after upgrade to 2006 - 9.Oct.2006 7:41:03 PM   
fermo111

 

Posts: 17
Joined: 7.Oct.2006
Status: offline
I found the problem!

The registry key HKCR\FPC.Root did not have read permissions to NETWORK SERVICE. Adding the right permissions fixed the problem.

Luca

(in reply to fermo111)
Post #: 4
RE: ISAServer stopped working after upgrade to 2006 - 11.Oct.2006 10:36:45 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi Luca,

How did that happen? The ISA Firewall should have set the permissions correctly. Sounds like someone has been playing with hardening guides

Thanks!
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to fermo111)
Post #: 5
RE: ISAServer stopped working after upgrade to 2006 - 12.Oct.2006 5:40:56 PM   
fermo111

 

Posts: 17
Joined: 7.Oct.2006
Status: offline
Hi Tom,

I have no idea how it could happen. For sure I did not run any hardening tool during the upgrade . In any case ISA Server seems to lack a little on the tracing side. When there is a problem I get only a laconic message in the Event Log saying very little.

Luca

(in reply to tshinder)
Post #: 6
RE: ISAServer stopped working after upgrade to 2006 - 12.Oct.2006 9:06:22 PM   
elmajdal

 

Posts: 6022
Joined: 16.Sep.2004
From: Lebanese in Kuwait
Status: offline
quote:

ORIGINAL: fermo111

I found the problem!

The registry key HKCR\FPC.Root did not have read permissions to NETWORK SERVICE. Adding the right permissions fixed the problem.

Luca


 and how did u know that this specific registery key had this specific permission missing !!!

how did u google this issue ?

_____________________________

Tarek Majdalani

Windows Expert - IT Pro MVP
Facebook : https://www.facebook.com/ElMajdal.Net

(in reply to fermo111)
Post #: 7
RE: ISAServer stopped working after upgrade to 2006 - 13.Oct.2006 8:45:10 AM   
fermo111

 

Posts: 17
Joined: 7.Oct.2006
Status: offline
Hi elmajdal,

infact I could not find this specific answer in Google. So, I looked in Google for other problems that people had with the application filters, and I found one post where the problem originated in the registry. I then run RegMon (www.sysinternals.com) while starting the Microsoft Firewall service and noticed few Access Denied errors in the RegMon log. Then, for any of these keys, I gave RW permissions to the NETWORK SERVICE user (the user under which Microsoft Firewall runs) and restarted each time the Microsoft Firewall service, until I found the key that fixed the problem.

Luca

(in reply to elmajdal)
Post #: 8
RE: ISAServer stopped working after upgrade to 2006 - 13.Oct.2006 10:15:25 AM   
elmajdal

 

Posts: 6022
Joined: 16.Sep.2004
From: Lebanese in Kuwait
Status: offline
Nice troubleshooting steps man

Tarek.

_____________________________

Tarek Majdalani

Windows Expert - IT Pro MVP
Facebook : https://www.facebook.com/ElMajdal.Net

(in reply to fermo111)
Post #: 9

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 General] >> General >> ISAServer stopped working after upgrade to 2006 Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts