• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

OWA published via ISA 2006 (LDAP Auth)

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 Publishing] >> Exchange Publishing >> OWA published via ISA 2006 (LDAP Auth) Page: [1]
Login
Message << Older Topic   Newer Topic >>
OWA published via ISA 2006 (LDAP Auth) - 21.Nov.2006 11:47:27 PM   
AfricanIvory

 

Posts: 6
Joined: 21.Nov.2006
Status: offline

I have the following config:

ISA2006 server configured as an edge firewall (not part of any domain) publishing a single Exchange 2003 server. The domain in which the Exchange 2003 server is resident has a single active directory DC (Windows 2003). I followed the article that Tom published (to the letter):
ISA Firewall Publishing OWA and RPC/HTTP with a Single IP Address: Part 1 - Single Exchange Server with Separate DC Scenario/LDAP Authentication. The DC also hosts an Enterprise Certificate Authority to issue certs for the Client to ISA and ISA to Exchange encryption as the article dictates.

ISSUES:

  • I have this exact scenario but when I attempt to setup LDAP authentication with AD it fails to find the DC.
  • I can't seem to master the URL redirect issue. I need to revisit the doc tomorrow to confirm the Link Mapping section.
This issue results in me being able to connect to the OWA site if I specify the /Exchange piece in the URL but I am unable to logon without the LDAP authentication working. The inside adapter is used to the internal DNS thus the ISA server does resolve the DC, it just doesn't "find" the LDAP DC as configured in the LDAP Server set.

Any ideas?

Thanks

Ivor



< Message edited by AfricanIvory -- 22.Nov.2006 1:19:24 AM >
Post #: 1
RE: OWA published via ISA 2006 (LDAP Auth) - 22.Nov.2006 2:07:43 PM   
AfricanIvory

 

Posts: 6
Joined: 21.Nov.2006
Status: offline

It seems that the Http to https as well as the www.domainname.net to www.domainname.net/exchange has been solved by Global Link Translation settings.

The only outstanding issue is the configuration of the LDAP authentication. When I edit the Users tab on the OWA Rule, I attempt to setup an LDAP user group contained in AD. I select the server set <as setup under the General section of ISA2006>. I enter the group name as it appears in AD but I still get the following message:

"None of the configured LDAP servers is available for verifying the user." (I used a domain admins account for the username and password for accessing the LDAP server section.)

Is this a bug? A known one? Any workarounds available yet?

Thanks

Ivor

(in reply to AfricanIvory)
Post #: 2
RE: OWA published via ISA 2006 (LDAP Auth) - 1.Dec.2006 12:00:43 PM   
blueberryKJ

 

Posts: 9
Joined: 1.Dec.2006
Status: offline
I had that problem while setting up my ISA server this week.  The ISA firewall was blocking LDAP traffic to the AD.  I tried unblocking LDAP and LDAP GC from local to my server subnet, and many other combinations.  For some reason, it only worked when I allowed local to all networks.  My ISA is in the DMZ of my network, and is in a workgroup.  Security is controlled by another firewall, so this shouldn't be a security concern in my configuration ...I hope.   Try unblocking that traffic and see if it works for you.

(in reply to AfricanIvory)
Post #: 3

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 Publishing] >> Exchange Publishing >> OWA published via ISA 2006 (LDAP Auth) Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts