• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

IMAPS Publishing Problem

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 Publishing] >> Exchange Publishing >> IMAPS Publishing Problem Page: [1]
Login
Message << Older Topic   Newer Topic >>
IMAPS Publishing Problem - 4.Jul.2007 6:56:29 AM   
maekee

 

Posts: 7
Joined: 26.Mar.2007
Status: offline
Hi Everyone,
Have got a small problem with my IMAPS Publishing.
Maybe this is a Server Publishing issue?

The ISA Server 2006 is working as a front firewall with a Exchange 2003 Server on the inside.

We have a OWA up and running, but we dont have a public certificate yet. But we press Yes on the popup and everything works.

Have successfully published the mail through IMAP4 via GPRS on our my phone. But not got IMAPS to work, just get the error "Server cannot be found"

Found a link to the "ISA Server 2004/Exchange Server Deployment Kit" documentation but it looks so simple there.. havent got it work work.

What are the steps that i am missing.. beginning to think its the certificate that is causing the problem.

Any idea´s?

/Maekee
Post #: 1
RE: IMAPS Publishing Problem - 6.Jul.2007 3:41:30 PM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi Maekee,

Does the client system trust the certificate bound to the IMAP4 site?

Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to maekee)
Post #: 2
RE: IMAPS Publishing Problem - 9.Jul.2007 4:05:18 AM   
maekee

 

Posts: 7
Joined: 26.Mar.2007
Status: offline
How do i know if the client trust the certificate?

This is what has been done so far:

1. Created a "IMAPS Server" Server Publishing Rule
2. Rule: Allow - IMAPS (993) Traffic (default ports)
From Anywhere to "internal exchange server"
Requests appear to come from original client.
Listens on external (external IP). No special schedule.

GPRS Phone Settings:
email,  connection type: IMAP (IMAP or POP), username: domain\username, password, Encryption: SSL, incoming port: 993, outgoing port: 25.

If i try to recieve mail from the phone i get: "The server could not be found"

In the ISA i see the following packets:
Packet 1:
Client IP: The Phone connecting
Destination IP: Internal Exchange Server
Destinaton Port: 993
Protocol: IMAPS Server
Action: Initiated Connection
Rule: IMAPS Publising
Result Code: 0x0 ERROR_SUCCESS

Packet 2:
Same as Packet 1, except:
Action: Closed Connection
Result Code: 0x80074e21 FWX_E_ABORTIVE_SHUTDOWN

So these to seems getting through some how?

Then two more packets that get Denied:
Packet 3:
Client IP: The Phone connecting
Destination IP: External ISA Firewall IP (public)
Destinaton Port: 993
Protocol: IMAPS
Action: Denied Connection
Rule: (empty)
Result Code: 0x0040017 FWX_E_TCP_NOT_SYN_PACKET_DROPPED

Packet 4:
Same as Packet 3

And now i am stuck.. hope this helps you help me. :)

/Maekee

< Message edited by maekee -- 9.Jul.2007 4:58:51 AM >

(in reply to tshinder)
Post #: 3
RE: IMAPS Publishing Problem - 9.Jul.2007 8:45:22 AM   
maekee

 

Posts: 7
Joined: 26.Mar.2007
Status: offline
Problem solved

Some how the certificate unassigned itself on the exchange server.

I went in to System Manager:
Administrative Groups\First Administrative Group\Servers\servername\Protocols\IMAP4\default IMAP Virtual server

Right Click it and choose properties, tab Access.
Clicked Certificate and assigned the correct one

You also have to check in AD on the user under the tab
Exchange Features and Enable IMAP4. (This takes about 1 minute)

But thanks for the replays anyway

/Maekee

(in reply to maekee)
Post #: 4
RE: IMAPS Publishing Problem - 14.Jul.2007 3:13:10 PM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Good to hear you got it working and thanks for the follow up!

Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to maekee)
Post #: 5

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 Publishing] >> Exchange Publishing >> IMAPS Publishing Problem Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts