• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Cache returns incorrect site

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 Cache] >> General >> Cache returns incorrect site Page: [1]
Login
Message << Older Topic   Newer Topic >>
Cache returns incorrect site - 28.Aug.2007 6:12:25 AM   
Rye035

 

Posts: 10
Joined: 8.Nov.2006
From: Philippines
Status: offline
I am not sure if any of have encountered the same problem. We have been experiencing a recurring problem regarding our ISA 2004's cache. Whenever our web proxy clients connect to certain sites, ISA server returns the incorrect site though the URL on the address bar contains the correct URL. I also tried accessing the site from the ISA server itself (proxied through localhost) and it displays the same incorrect site. I know you might conclude that this is due to DNS poisoning... but I'm not sure. I tried to ping the site URL from a client PC and it displays the incorrect site's IP address. Performing a ping from the ISA server displays the correct IP of the site. I'll show you what I mean...

Ping from a client computer:
C:\>ping mail.yahoo.com
Pinging www.petermaas.nl [82.192.68.48] with 32 bytes of data:
Reply from 10.100.100.2: TTL expired in transit.
Reply from 10.100.100.2: TTL expired in transit.
Reply from 10.100.100.2: TTL expired in transit.
Reply from 10.100.100.2: TTL expired in transit.

Ping statistics for 82.192.68.48:
   Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
   Minimum = 0ms, Maximum = 0ms, Average = 0ms


Ping from the ISA server computer
C:\>ping mail.yahoo.com
Pinging login.yahoo.akadns.net [209.73.168.74] with 32 bytes of data:
Reply from 209.73.168.74: bytes=32 time=210ms TTL=49
Reply from 209.73.168.74: bytes=32 time=215ms TTL=50
Reply from 209.73.168.74: bytes=32 time=207ms TTL=49
Reply from 209.73.168.74: bytes=32 time=210ms TTL=50

Ping statistics for 209.73.168.74:
   Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
   Minimum = 207ms, Maximum = 215ms, Average = 210ms


As you can see, the correct IP address for mail.yahoo.com is resolved on the ISA server computer. When I tried to browse from the ISA server computer without indicating the proxy (localhost) on the browser options, I can browse the site correctly. The correct site is displayed by not passing through the ISA firewall. DNS Poisoning...? Any idea why this happens? I'm completely stumped...
Post #: 1
RE: Cache returns incorrect site - 28.Aug.2007 9:53:07 PM   
jmilito

 

Posts: 321
Joined: 10.Oct.2006
From: MICHIGAN, US
Status: offline
Before you tear out your hair re-check your DNS setup on ISA


http://www.microsoft.com/technet/isa/2004/plan/configuring_dns.mspx


Also you may want to run the latest ISA BPA tool available on Microsoft's website.

(in reply to Rye035)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2004 Cache] >> General >> Cache returns incorrect site Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts