• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

External Interface Stops randomly

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 General] >> General >> External Interface Stops randomly Page: [1]
Login
Message << Older Topic   Newer Topic >>
External Interface Stops randomly - 29.Oct.2007 3:45:48 PM   
bdiekmann

 

Posts: 26
Joined: 15.Nov.2004
Status: offline
Greetings all,

I have an ISA 2006 server in a 3-leg configuration (External, Internal and perimeter).
Randomly (as I have not found any corrolating data), the external interface stops passing traffic (from outside to in, Inside to Outside, Local host to outside and VPN connections). All other connections work fine. The only way to get connectivity working again is to reboot the server (I have tried disabling and repairing the NIC to no avail).

The External and Internal NIC is an onboard (Dell Server) Broadcom NetXtreme Gigabit and the perimeter is a 3com PCIE.

I have looked through logs and cannot find any reason for this behavior.

Any help would be greatly appreciated (before I go and open a case with MS).

bdiekmann
Post #: 1
RE: External Interface Stops randomly - 31.Oct.2007 10:17:32 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Is Windows 2003 SP2 installed on this machine?

Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to bdiekmann)
Post #: 2
RE: External Interface Stops randomly - 31.Oct.2007 10:26:41 AM   
bdiekmann

 

Posts: 26
Joined: 15.Nov.2004
Status: offline
Tom,

Windows 2003 R2 SP1 (and I already hear the groans.....)

I will update it to SP2 tonight.

bdiekmann

(in reply to tshinder)
Post #: 3
RE: External Interface Stops randomly - 1.Nov.2007 9:49:38 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
After updating to SP2, make sure that you fix the RSS bug. You can find information on that in my blog.

HTH,
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to bdiekmann)
Post #: 4
RE: External Interface Stops randomly - 5.Nov.2007 10:45:23 AM   
bdiekmann

 

Posts: 26
Joined: 15.Nov.2004
Status: offline
Thanx Tom

Installed SP2 (and was carefule about some of the publishibg issues) and applied the RSS fix.

Much better behavior now.

bdiekmann

(in reply to tshinder)
Post #: 5
RE: External Interface Stops randomly - 5.Nov.2007 7:35:01 PM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Great! Good to hear you got things working and thanks for the follow up!

Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to bdiekmann)
Post #: 6
RE: External Interface Stops randomly - 26.Nov.2007 2:48:35 PM   
bdiekmann

 

Posts: 26
Joined: 15.Nov.2004
Status: offline
Tom,

hope you see this (before I start a new topic).
After patching the ISA server for the RSS problem, everything has been fine until Thanksgiving (always on a holiday). The ISA server is exhibiting the same symptoms again. Runs fine for a random period of time, then the external NIC stops passing traffic (or at least passing traffic correctly).

Any ideas of where to stat looking?

Bill Diekmann

(in reply to tshinder)
Post #: 7
RE: External Interface Stops randomly - 27.Nov.2007 9:56:32 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi Bill,

This strongly indicates a hardware problem. The NIC might be going bad, or maybe the cable the NIC is connected to, or maybe the switch or switch port the cable is plugged into. Maybe even the UPS that the switch is plugged into.

HTH,
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to bdiekmann)
Post #: 8
RE: External Interface Stops randomly - 17.Jan.2008 7:21:10 PM   
bdiekmann

 

Posts: 26
Joined: 15.Nov.2004
Status: offline
Tom,

Again, hope you follow up on older postings.

Since the last post I have done the following.

Build a new server and installed ISA 2006 and migrated everyhting to new hardware. I am still having the issue where the External Interface still stops allowing traffic to pass. I have tried to do a repair on the NIC and it refuses to clear the ARP (and therefore does not finish the repair), I have also tried disabling and then re-enable. Once the NIC is dis-abled, only a reboot will bring it back online (the last graceful reboot took the server 5 hours to save settings.

I have taken the previous server (with assumed hardware issue) and uninstalled ISA 2006 and installed ISA 2004 and put it back in place......it has been rock solid for 30 days.

I see a lot of postings about the RSS issue, but I have made the changes.
There is nothing in any of the event logs other than ISA reporting that it cannot validate my external verifiers.

Any thoughts on how to proceed? I would love to continue to use ISA 2006, but I may roll everything back to ISA 2004.

Bill Diekmann

(in reply to tshinder)
Post #: 9
RE: External Interface Stops randomly - 18.Jan.2008 9:44:13 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi Bill,

Could you be triggering a flood protection? ISA 2006 has much better flood protection settings and that might be what's going on. Check the Event Viewer for ISA related events.

Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to bdiekmann)
Post #: 10
RE: External Interface Stops randomly - 21.Jan.2008 4:13:06 PM   
bdiekmann

 

Posts: 26
Joined: 15.Nov.2004
Status: offline
Tom,

No, I have turned off all of the Flood protection.

The only events in Event Viewer are the MOnitoring points that are erroring. There is nothing to indicate any issues with ISA.

A couple of items to note (as I have now seen this on several installations)
1. All of the NICs are Broadcom NetXtreme
2. If you try to do a repair on the NIC, you get an error about not being able to clear teh ARP cache
3. If you disable the NIC (which it will do), you cannot re-enable the NIC without rebooting

Bill Diekmann

(in reply to tshinder)
Post #: 11
RE: External Interface Stops randomly - 22.Jan.2008 12:56:35 PM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Broadcom. Could it be the RSS bug?

Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to bdiekmann)
Post #: 12
RE: External Interface Stops randomly - 13.Feb.2008 4:56:13 PM   
bdiekmann

 

Posts: 26
Joined: 15.Nov.2004
Status: offline
Tom,

Hope all is well.

Follow up on this thread from me, as I am still having issues.

I have double and triple checked the RSS bug fix
I have turned off all of the flood controls.

I had another lock up today. required a hard boot of the server

One thing of note (as I am watching the system monitors in realtime)

I notice that at times my Active UDP Connections are high and that available UDP mappings are low (considering that I have VoIP (video) traffic over VPN, seems reasonable).
I also notice that I run low (out of) Available worker threads at times.

Is this normal to be so low on threads and mappings?
Is there a way to increase these?

It was worse when I had internal network users using it as a proxy, but I have removed that and it appears to be better. (guess I will have to build a second ISA server just for proxying).

Any further thoughts on how to diagnose the External NIC stop?

Bill Diekmann

(in reply to tshinder)
Post #: 13
RE: External Interface Stops randomly - 14.Feb.2008 11:19:33 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
I had something similar happen to me recently. DNS publishing just stopped working. No evidence of anything else wrong, but the DNS server publishing rule just quit. That's a UDP protocol. What I suspect happened was that a short power outtage stopped the connection  on the external interface for a moment and that caused the problem.

HTH,
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to bdiekmann)
Post #: 14

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 General] >> General >> External Interface Stops randomly Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts