Web Listener doesn't see IP address. Event ID 21216 (Full Version)

All Forums >> [ISA 2006 Firewall] >> General



Message


jbrown04 -> Web Listener doesn't see IP address. Event ID 21216 (19.Nov.2007 12:27:37 PM)

Hello -
 
I am trying to bring up an ISA 2006 server in parallel to our ISA 2004 server.  I had issues migrating the 2004 rules to 2006, so I decided to simply manually add the rules to 2006.
 
After shutting the 2004 server off and adding all the IP addresses to the 2006 box, I started adding rules for our web sites.  Every web site I try to publish generates Event Log ID 21216:
 
Event Type: Error
Event Source: Microsoft ISA Server Web Proxy
Event Category: None
Event ID: 21216
Date:  11/18/2007
Time:  11:40:50 PM
User:  N/A
Computer: 
Description:
The Web publishing rule Info failed because the Web listener selected for the rule is not valid. Verify that the Web listener specifies a valid IP address on this computer.

 
None of the web publishing rules work. I can see all the IP addresses on the NIC, and I can see the IP addresses when I select them for the Web Listeners. 
ISA 2006 Standard (Version: 5.0.5721.240), Server 2003 SP1.
 
Anyone have any experience with this?  Any help is appreciated.
 
Thanks.




mylo -> RE: Web Listener doesn't see IP address. Event ID 21216 (24.Nov.2007 2:38:30 PM)

Couple of things:

- Did you join the ISA 2006 Server to the same array as the 2004 server?
- Have you tried removing and recreating the listeners?

Failing that.. can you post your IP configuration for your new ISA Server 2006 to the forums?

Regards,
Mylo




jbrown04 -> RE: Web Listener doesn't see IP address. Event ID 21216 (26.Nov.2007 12:34:51 PM)

Hello -

Thanks for your response.  I am past that error and I am working through multiple other problems.  At this point I am going to rebuild from sratch and start over.

Thanks again for your response though.




markr999 -> RE: Web Listener doesn't see IP address. Event ID 21216 (18.Apr.2008 4:22:33 AM)

I'm getting the same but on an ISA 2004 SP3

Event ID: 21216
Source: Microsoft ISA Server Web Proxy

Web publishing rule [PKI] failed because the Web listener selected for the rule is not valid. Verify that the Web listener specifies a valid IP address on this computer.

I've deleted the rule and listener and recreated them. The rule was working until 3 days ago. There are 4 servers in the array, each with an additional IP assigned to each untrusted NIC respectively. The listener has all 4 addresses listening. This is a straight forward web server publishing rule publishing an internal server on port 80. If I type the internal address in the browser (on one of the ISAs) the website is displayed, but it will not work when I type the listener address in the browser. I get an ISA denied URL message "Error Code: 403 Forbidden. The server denied the specified Uniform Resource Locator (URL)". Logging reveals that the rule seems to being bypassed and is being denied by "80 http Denied Connection [Enterprise] Default rule.

Other webpublishing rules on this server are functioning correctly.

Any ideas?
Denied Connection
[Enterprise] Default rule




Page: [1]