• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

I get an error in the event viewer, 14057

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 Misc.] >> ISA 2006 Programming >> I get an error in the event viewer, 14057 Page: [1]
Login
Message << Older Topic   Newer Topic >>
I get an error in the event viewer, 14057 - 27.Jun.2008 11:04:28 AM   
mattias.bergkvist

 

Posts: 5
Joined: 21.Oct.2007
Status: offline
I get an error in the event viewer, 14057:
The Firewall service stopped because an application filter module P:\Program  Files\Microsoft ISA Server\wspsrv.exe generated an exception code C0000005 in  address 004702DC when function CompleteAsyncAccept was called. To resolve  this error, remove recently installed application filters and restart the 

Are there someone that know what it can be?

C0000005 is ACCESS_VIOLATION but where?

It is always happening when I install my webfilter, but I have try and catch everywhere in my code, so if it happens there I catch it. I have no idée what it can be.

I use ISA 2006.

Regards
Mattias
Post #: 1
RE: I get an error in the event viewer, 14057 - 2.Jul.2008 5:39:00 AM   
mattias.bergkvist

 

Posts: 5
Joined: 21.Oct.2007
Status: offline
Hello Everybody!

Is there any body who knows what it can be?

Regards
Mattias Bergkvist

(in reply to mattias.bergkvist)
Post #: 2
RE: I get an error in the event viewer, 14057 - 18.Jul.2008 9:37:10 AM   
fixitchris

 

Posts: 148
Joined: 23.May2007
Status: offline
So the CompleteAsyncAccept throws an Access Denied?

(in reply to mattias.bergkvist)
Post #: 3
RE: I get an error in the event viewer, 14057 - 18.Jul.2008 12:09:16 PM   
JesseA

 

Posts: 51
Joined: 15.Aug.2002
Status: offline
I doubt CompleteAsyncAccept can be related to web filters. So probably it is just an after-effect of some another problem. For example it could be a memory corruption caused by your web filter. In this case you can try to use page heap flags in debugging tools.

(in reply to fixitchris)
Post #: 4
RE: I get an error in the event viewer, 14057 - 10.Sep.2008 11:25:02 AM   
Nick [UWE]

 

Posts: 12
Joined: 5.Feb.2008
Status: offline
We're getting something very similar to this as well ... only started happening recently. We've just setup debugdiag so should hopefully have some useful info soon.

(in reply to JesseA)
Post #: 5
RE: I get an error in the event viewer, 14057 - 10.Oct.2008 2:48:44 AM   
mattias.bergkvist

 

Posts: 5
Joined: 21.Oct.2007
Status: offline
I think it was a bad pointer to the memcpy that cause the error.
I do all the copy myself instead for using memcpy.

I hope it help someone
Mattias Bergkvist

(in reply to Nick [UWE])
Post #: 6
RE: I get an error in the event viewer, 14057 - 13.Feb.2009 3:57:07 PM   
m_kk

 

Posts: 25
Joined: 21.Nov.2007
Status: offline
I am having the same issue. Its amazing so many people having a similar problem but there is no solution anywhere. The only solution I encountered was to reinstall ISA.

MS has an article on this with a fix (http://support.microsoft.com/kb/956268) but even with the fix my ISA crashed after 3 weeks. So all it did was to delay the crash.

I wonder if Semantic anti virus has to do with it because some of related problems i encountered had it installed.

It might be a MS problem. If any one finds a solution please post it in here.

(in reply to mattias.bergkvist)
Post #: 7
RE: I get an error in the event viewer, 14057 - 13.Feb.2009 4:43:24 PM   
Dumber

 

Posts: 278
Joined: 21.Mar.2008
Status: offline
I don't know anything of ISA programming but errr...
Are you running a hostbased virusscanner on the ISA server?
If yes, remove it. If not, well ignore my post

_____________________________

Marcel
Netherlands

MCTS, MCITP (SA,EA) MCP, MCSA:Security, MCSE:Security, CCNA, CCSA, CCSE, CCSE+
No matter how secure, there is always the human factor.
http://www.phetios.com/

(in reply to m_kk)
Post #: 8
RE: I get an error in the event viewer, 14057 - 13.Feb.2009 5:07:52 PM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
quote:

ORIGINAL: Dumber

I don't know anything of ISA programming but errr...
Are you running a hostbased virusscanner on the ISA server?
If yes, remove it. If not, well ignore my post


If you can't remove it (due to corporate policy) then have a look at this.

Cheers

JJ

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to Dumber)
Post #: 9
RE: I get an error in the event viewer, 14057 - 20.Feb.2009 7:34:33 AM   
Nick [UWE]

 

Posts: 12
Joined: 5.Feb.2008
Status: offline
Ok, make sure you clean up all your memory after use ... that is all ;)

(in reply to Nick [UWE])
Post #: 10

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 Misc.] >> ISA 2006 Programming >> I get an error in the event viewer, 14057 Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts