• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

E2K3 & ISA 2006 & Windows Mobile 6.1

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 Publishing] >> Exchange Publishing >> E2K3 & ISA 2006 & Windows Mobile 6.1 Page: [1]
Login
Message << Older Topic   Newer Topic >>
E2K3 & ISA 2006 & Windows Mobile 6.1 - 17.Apr.2009 6:56:47 AM   
shabbir.jadliwala

 

Posts: 19
Joined: 26.Feb.2008
From: Indian in Ireland
Status: offline
Hi,

I have published an Exchange Server 2K3 over the ISA server 2006.
I works fine via Internet Explorer and also through Active Sync device with Windows Mobile 5.

But when I try to connect using Active Sync with Windows Mobile 6.1 on HTC Pro I get error: 0x80072ee2 on the device. I was previously getting error: ISA 0x85010001 and that went away with the modification in Registry as below:

HKLM\System\CurrentControlSet\Services\W3Proxy\Parameters\PassOPTIONSToPublishedServer - Data value to 1.

Is there any settings needed to be modified on the ISA server to allow Active Sync to work?

Thanks for help.

_____________________________

Best Regards,

Shabbir
Post #: 1
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 17.Apr.2009 12:07:46 PM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
Are you using any HTTP filters on your publishing rules?

Cheers

JJ

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to shabbir.jadliwala)
Post #: 2
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 17.Apr.2009 12:11:27 PM   
shabbir.jadliwala

 

Posts: 19
Joined: 26.Feb.2008
From: Indian in Ireland
Status: offline
Hi Jason,

One of the last rules I have to disallow any HTTP or HTTPS accept for the ones published via the ISA to the Internet.

And I am not using Certificate for Push Mail and Active Sync on the ISA.

Regards,

Shabbir

_____________________________

Best Regards,

Shabbir

(in reply to Jason Jones)
Post #: 3
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 17.Apr.2009 12:19:43 PM   
shabbir.jadliwala

 

Posts: 19
Joined: 26.Feb.2008
From: Indian in Ireland
Status: offline
Allowed Connection
Log type: Web Proxy (Reverse)


Status: 400 Bad Request


Client agent: MSFT-PPC/5.2.1203
Object source: Internet (Source is the Internet. Object was added to the cache.)
Cache info: 0x40040008 (Request includes the AUTHORIZATION header. Response includes the CACHE-CONTROL: NO-CACHE or PRAGMA: NO-CACHE header. Response should not be cached.)
Processing time: 546 ms
MIME type: -

_____________________________

Best Regards,

Shabbir

(in reply to shabbir.jadliwala)
Post #: 4
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 17.Apr.2009 12:47:05 PM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
Can you provide details of your publishing rules? Did you use the Exchange publishign wizard for these?

Cheers

JJ

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to shabbir.jadliwala)
Post #: 5
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 20.Apr.2009 4:33:41 AM   
shabbir.jadliwala

 

Posts: 19
Joined: 26.Feb.2008
From: Indian in Ireland
Status: offline
Hi Jason,

I used Exchange Publishing Wizard to publish the W2K3 E2K3 server.
As I said I am not using a certificate, so only publishing on an HTTP site.

I have the standard settings, used for a few other Exchange servers, which I have publised.

It works fine with a Windows Mobile 5.0 PDA, but not working for the WM6.0 and higher version. I did try for a few published exchange servers and still the same.

Also had made the Registry change as above, but still not working.

Is there any settings I need to do on the server or ISA or PDA to get this working?

Thanks & Best Regards,

Shabbir


_____________________________

Best Regards,

Shabbir

(in reply to Jason Jones)
Post #: 6
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 22.Apr.2009 5:02:37 AM   
shabbir.jadliwala

 

Posts: 19
Joined: 26.Feb.2008
From: Indian in Ireland
Status: offline
Hi Jason,

Any update on this issue?

Or can anyone else help me with the same?

_____________________________

Best Regards,

Shabbir

(in reply to shabbir.jadliwala)
Post #: 7
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 22.Apr.2009 5:05:57 AM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
Sorry, never done ActiveSync with HTTP as this means credentials are passing clear text - far from ideal for the small cost of a cert...

If you are using HTTP, have you configured the listener to "allow authentication over HTTP"?

I would need more detail about your Exchange publishing rules and listeners to see if you have got something wrong...

Cheers

JJ

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to shabbir.jadliwala)
Post #: 8
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 22.Apr.2009 5:12:57 AM   
shabbir.jadliwala

 

Posts: 19
Joined: 26.Feb.2008
From: Indian in Ireland
Status: offline
Thanks for the reply.

Yes I have enabled "Allow Authentication over HTTP" in the Listener I am using.

I am not using Certificate, because we have a few Mailservers published and wasn't sure at the start how to set up different certificates for each server published. I would love to move to that in future.

I will try and send some screenshots with the publishing rules.

_____________________________

Best Regards,

Shabbir

(in reply to Jason Jones)
Post #: 9
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 22.Apr.2009 5:50:55 AM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
Ok, screenshots look ok.

The fact that it works on WM5 must prove your publishing rules are ok I guess...the only issue I have seen like this is where HTTP filters were applied to the publishing rule which specifically affected WM6.

Sorry I can't be any more help

Cheers

JJ

< Message edited by Jason Jones -- 22.Apr.2009 6:11:19 AM >


_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to shabbir.jadliwala)
Post #: 10
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 22.Apr.2009 5:55:22 AM   
shabbir.jadliwala

 

Posts: 19
Joined: 26.Feb.2008
From: Indian in Ireland
Status: offline
Thanks for trying.
I will see if MS can help me with the same.

Thanks again.

_____________________________

Best Regards,

Shabbir

(in reply to Jason Jones)
Post #: 11
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 22.Apr.2009 6:12:52 AM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
quote:

ORIGINAL: shabbir.jadliwala

Thanks for trying.
I will see if MS can help me with the same.

Thanks again.


I wish I had more time and access to the system to help further, it is probably something quite simple...it usually is!

Good luck with MS and please post back the solution...

Cheers

JJ

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to shabbir.jadliwala)
Post #: 12
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 22.Apr.2009 7:19:10 AM   
shabbir.jadliwala

 

Posts: 19
Joined: 26.Feb.2008
From: Indian in Ireland
Status: offline
Client Agent
MSFT-PPC/5.2.1203

Authenticated Client
 

Service
Reverse Proxy

Server Name
W2K3ISA

Referring Server
-

Destination Host Name
mobilemail.mydomain.com

Transport
TCP

MIME Type
-

Object Source
Internet

Source Proxy
 

Destination Proxy
 

Filter Information
Req ID: 0d7816c9; Compression: client=Yes, server=No, compress rate=4% decompress rate=0%

Network Interface
 

Raw IP Header
 

Raw Payload
 

Source Port
6263

Processing Time
6667

Bytes Sent
364

Bytes Received
480

Result Code
 

HTTP Status Code
400 Bad Request

Cache Information
0x40040008

Error Information
0x480

Log Record Type
Web Proxy Filter

Authentication Server
ldap.mydomain.com

Log Time
22/4/2009 12:02

Destination IP
192.168.0.10

Destination Port
110111

Protocol
http

Action
Allowed Connection

Rule
WEBISA

Client IP
210.185.164.29

Client Username
(LDAP)Adrian

Source Network
Internal

HTTP Method
POST

URL
http://mobilemail.mydomain.com/Microsoft-Server-ActiveSync?User=adrian&DeviceId=F1F74FF0CF5AAC3AED12F84AEF12DBB9&DeviceType=PocketPC&Cmd=GetHierarchy

_____________________________

Best Regards,

Shabbir

(in reply to Jason Jones)
Post #: 13
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 22.Apr.2009 7:36:53 PM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
What do you see in the Exchange server IIS logs - do you see the HTTP 400 errors?

If so, the problem may lie behind ISA...

Cheers

JJ

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to shabbir.jadliwala)
Post #: 14
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 23.Apr.2009 4:46:56 AM   
shabbir.jadliwala

 

Posts: 19
Joined: 26.Feb.2008
From: Indian in Ireland
Status: offline
Hi Jason,

I don't get any HTTP 400 errors on the Exchange servers. The only ones I see are on the ISA server logs.

 
HTTP Status Code: 400 Bad Request




_____________________________

Best Regards,

Shabbir

(in reply to Jason Jones)
Post #: 15
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 23.Apr.2009 4:55:01 AM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
Ah, ok

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to shabbir.jadliwala)
Post #: 16
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 23.Apr.2009 4:58:51 AM   
shabbir.jadliwala

 

Posts: 19
Joined: 26.Feb.2008
From: Indian in Ireland
Status: offline
Installing the Microsoft Internet Security and Acceleration (ISA) Server 2006 Supportability Update from MS site. Lets see if that helps.

_____________________________

Best Regards,

Shabbir

(in reply to Jason Jones)
Post #: 17
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 23.Apr.2009 5:27:05 AM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
quote:

ORIGINAL: shabbir.jadliwala

Installing the Microsoft Internet Security and Acceleration (ISA) Server 2006 Supportability Update from MS site. Lets see if that helps.


Are you not running Service Pack 1 then?

Bit surprised you are asking forum questions before doing basic stuff like installing service packs and updates...surely this is the first thing to try???

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to shabbir.jadliwala)
Post #: 18
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 24.Apr.2009 5:46:28 AM   
shabbir.jadliwala

 

Posts: 19
Joined: 26.Feb.2008
From: Indian in Ireland
Status: offline
Hi Jason,

After trying all the things on the ISA and Exchange server I have finally managed to get the Active Sync working with HTC and WM6.1.

Not sure what fixed it, but the last step I took was to set up Active Sync on the Windows XP PC. Connect the HTC with the system and do a Sync for Contacts and Emails using the same.

Then I set up Wireless Sync on the phone and set it up to sync the Calendar and Tasks and that worked.

After that I deleted both Windows & Wireless Active Sync connections on the HTC phone and set up a new user on the HTC for Wireless Active Sync to sync all Contacts, Calendar, Emails and Task and it worked.

quote:

Bit surprised you are asking forum questions before doing basic stuff like installing service packs and updates...surely this is the first thing to try???


Thanks for all your help and sorry to be posting all in here.

_____________________________

Best Regards,

Shabbir

(in reply to Jason Jones)
Post #: 19
RE: E2K3 & ISA 2006 & Windows Mobile 6.1 - 24.Apr.2009 7:57:19 AM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
No worries, glad to hear you got it working!

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to shabbir.jadliwala)
Post #: 20

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 Publishing] >> Exchange Publishing >> E2K3 & ISA 2006 & Windows Mobile 6.1 Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts