• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

RE: Microsoft & Trend sites are not working

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 Firewall] >> HTTP Filtering >> RE: Microsoft & Trend sites are not working Page: <<   < prev  1 [2]
Login
Message << Older Topic   Newer Topic >>
RE: Microsoft & Trend sites are not working - 29.Apr.2009 6:49:49 PM   
inderjeet

 

Posts: 463
Joined: 25.Nov.2008
Status: offline
Another interested thing is that ISA tries to do the Forward Lookup but fails to do so. The  h_addr_list:  property remains Empty. This could be due to DNS server not responding on time or could be due to request going to a wrong DNS Server.

[3]1424.270 04/28/2009-10:34:13.031 [00000003 14421777 14421778] [WP_POLICY proxyext BASE_REQUEST::CheckRules request.cxx@5701] Info:At this stage DNS resolution will be done only using local DNS cache.

[3]1424.270 04/28/2009-10:34:13.031 [00000003 14421777 14421778] [WP_POLICY proxyext BASE_REQUEST::ForwardLookup request.cxx@7537] Info:WPPISAPUBLIC:We are going to perform forward lookup of [trendmicro.com].

[3]1424.270 04/28/2009-10:34:13.031 [00000003 14421777 14421778] [WP_POLICY proxyext BASE_REQUEST::ForwardLookup request.cxx@7573] Info:WPPISAPUBLIC:Failed to perform forward lookup. Error: 11001(WSAHOST_NOT_FOUND). We will try to continue with the information we have.

[3]1424.270 04/28/2009-10:34:13.031 [00000003 14421777 14421778] [WP_POLICY proxyext BASE_REQUEST::BuildRuleHostEnt request.cxx@7935] Info:WPPISAPUBLIC:The HOSTENT structure we will use for policy check is

h_name: trendmicro.com
h_aliases:
h_addr_list:


This Proves to some extent that this is a DNS Issue. My recommendation is that you setup your Internal DNS server to forward DNS query requests to your ISPs DNS Servers and run the script in the below mentioned KB to disable Name Resolution on ISA Server.
http://support.microsoft.com/default.aspx/kb/839510/en-us

Also, allow HTTP 1.1 in the Internet Explorer Tools > Internet options > Advanced > HTTP 1.1 Settings. This is because i can see that in logs it appears "Info:263EBDEC: The client doesn't request compression."


Moreover, you can test if that's DNS issue before even applying anything. Do the below mentioned simple test

On your ISA Server go to C:\Windows\System32\drivers\etc and open Hosts file in a notepad
Then just below the 12.0.0.1 entry type 65.55.12.249 then give a tab and write www.microsoft.com
In the next line type 66.35.255.33 and give a tab and then write www.trendmicro.com
Save the file and Test it from client machine

If it's DNS issue then it should not happen again with these websites. But that's only a temporary way. Follow the suggestion i gave you above to have a permanent solution

Moreover, you have IWSS integrated so anyhow DNS resolution is not necessary on ISA.

Hope that helps

< Message edited by inderjeet -- 29.Apr.2009 6:56:27 PM >


_____________________________

Inderjeet (MSFT)
My Blog: http://isingh.spaces.live.com

If you are a Microsoft Gold Partner, Contact us for Advisory/Consulting Services, Check https://partner.microsoft.com/US/supportsecurity/40012316

(in reply to gopichand)
Post #: 21

Page:   <<   < prev  1 [2] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 Firewall] >> HTTP Filtering >> RE: Microsoft & Trend sites are not working Page: <<   < prev  1 [2]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts