• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

ISA SSL Redirect - MSWord Issues

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 Publishing] >> SharePoint Publishing >> ISA SSL Redirect - MSWord Issues Page: [1]
Login
Message << Older Topic   Newer Topic >>
ISA SSL Redirect - MSWord Issues - 29.Jun.2009 1:22:52 PM   
ClintD

 

Posts: 1848
Joined: 26.Jan.2001
From: Keller, TX
Status: offline
I admit this isn't ISA related specifically, but I hope some of you have some good SharePoint experience and might have run into this before.

The problem I'm having is that my ISA 2006 config is setup so that all HTTP requests are redirected to use HTTPS. Works fine, with the exception of Word. If you browse to the SharePoint site and select Share Documents\New, this opens Word. Type in some garbage and select File\Save As.

It is supposed to show the Share Documents site in the Save As dialog but you receive the error

---------------------------
Error
---------------------------
Documents in this folder are not available.  The folder may have been moved or deleted, or network problems may be preventing a connection to the server.
---------------------------
OK  
---------------------------

I took a network sniff from my client and Word is sending the trafic out as 'plain ol HTTP' and when ISA redirects the request to use the HTTPS site, Word doesn't retry the request, hence the failure.

Have any of you ever seen this, or know of some good SharePoint sites that may cover this? My Google Kung-Foo is weak and I couldn't find anything. Still looking though.
Post #: 1
RE: ISA SSL Redirect - MSWord Issues - 30.Jun.2009 10:29:55 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi Clint,

Nice to hear from you!

Did you put the site on the IE trusted sites list?

Thanks!
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to ClintD)
Post #: 2
RE: ISA SSL Redirect - MSWord Issues - 2.Jul.2009 12:21:19 AM   
ClintD

 

Posts: 1848
Joined: 26.Jan.2001
From: Keller, TX
Status: offline
Hey Tom! Always good to hear from you! Heh.

Yeah, we added it into the Trusted Sites list but had the same problem. We just can't quite figure out if it's a SharePoint Access Mapping issue or just Word being lame and not following the redirect.

(in reply to tshinder)
Post #: 3
RE: ISA SSL Redirect - MSWord Issues - 6.Jul.2009 8:37:08 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Could be an AAM issue.

Did you see the redirect make it to the Word client on the network sniff?

Thanks!
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to ClintD)
Post #: 4
RE: ISA SSL Redirect - MSWord Issues - 7.Jul.2009 1:25:11 AM   
ClintD

 

Posts: 1848
Joined: 26.Jan.2001
From: Keller, TX
Status: offline
Yeah - we see the 302 come back to the client.

(in reply to tshinder)
Post #: 5
RE: ISA SSL Redirect - MSWord Issues - 7.Jul.2009 9:01:09 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
So Word just quits after getting the 302 redirect to https, or does it send again, but to http?

Thanks!
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to ClintD)
Post #: 6
RE: ISA SSL Redirect - MSWord Issues - 7.Jul.2009 11:09:36 PM   
ClintD

 

Posts: 1848
Joined: 26.Jan.2001
From: Keller, TX
Status: offline
There are 3 requests that Word makes - an OPTIONS, PROPFIND and a POST. These all receive a 302 response but Word doesn't chase the redirect. If we set ISA to not redirect to SSL, Word works correctly and the SharePoint site shows up in the Save As dialog box.

It appears that Word just retries it as HTTP because when we sniff the traffic when ISA doesn't redirect to SSL, Word only makes these 3 calls one time. When ISA redirects to SSL, Word appears to retry 3 times.

< Message edited by ClintD -- 7.Jul.2009 11:11:42 PM >

(in reply to tshinder)
Post #: 7
RE: ISA SSL Redirect - MSWord Issues - 8.Jul.2009 8:20:39 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
OK, got it. Pulling in some other resources and seeing if we can figure this out.

Thanks!
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to ClintD)
Post #: 8
RE: ISA SSL Redirect - MSWord Issues - 8.Jul.2009 11:05:54 AM   
ClintD

 

Posts: 1848
Joined: 26.Jan.2001
From: Keller, TX
Status: offline
We just opened a case with PSS so I'll let you know if I hear anything from my side as well.

(in reply to tshinder)
Post #: 9
RE: ISA SSL Redirect - MSWord Issues - 9.Jul.2009 7:16:01 AM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
Hi Clint,

Does this happen with a standard document library?

If so, I cannot reproduce the issue and my Word 'save as' works as expected.

This is a production systems with ISA Server 2006 SP1, MOSS 2007 and a web listener using HTTP to HTTPS redirection.

Cheers

JJ

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to ClintD)
Post #: 10
RE: ISA SSL Redirect - MSWord Issues - 9.Jul.2009 3:38:10 PM   
ClintD

 

Posts: 1848
Joined: 26.Jan.2001
From: Keller, TX
Status: offline
I'm not too savvy with the SharePoint side so I don't know what you mean by 'Standard Document Library'. It's a basic SP site - no customization. Does that answer your question?

What version of Office did you use? My Word version is 'Microsoft Word 2002 (10.6850.6845) SP3.

(in reply to Jason Jones)
Post #: 11
RE: ISA SSL Redirect - MSWord Issues - 9.Jul.2009 5:58:58 PM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
Me neither

I just went to one of our SharePoint document libraries and selected, New, Word Document and went from there...

I am using Office 2007 SP1.

I can probably do screenshots if this would help...drop me a PM for email etc.

Cheers

JJ

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to ClintD)
Post #: 12
RE: ISA SSL Redirect - MSWord Issues - 9.Jul.2009 6:19:19 PM   
ClintD

 

Posts: 1848
Joined: 26.Jan.2001
From: Keller, TX
Status: offline
Apparently, it doesn't happen in Word 2007. I was on the horn with MS Support and he could only reproduce it in Office XP (yeah, we're lame and that's the version we have deployed). I'll update the thread when/if we find anything.

Thanks for offering Jason - I'll take you up on your offer if it gets any more weird. lol

(in reply to Jason Jones)
Post #: 13
RE: ISA SSL Redirect - MSWord Issues - 9.Jul.2009 7:36:38 PM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
quote:

ORIGINAL: ClintD

Apparently, it doesn't happen in Word 2007. I was on the horn with MS Support and he could only reproduce it in Office XP (yeah, we're lame and that's the version we have deployed). I'll update the thread when/if we find anything.

Thanks for offering Jason - I'll take you up on your offer if it gets any more weird. lol


Ah, ok np.

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to ClintD)
Post #: 14
RE: ISA SSL Redirect - MSWord Issues - 10.Jul.2009 9:55:39 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi Clint,

Thanks! Please let us know what you find out with the old version of Office. Worth having that information on the boards.

Thanks!
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to Jason Jones)
Post #: 15
RE: ISA SSL Redirect - MSWord Issues - 5.Sep.2009 3:51:31 PM   
ClintD

 

Posts: 1848
Joined: 26.Jan.2001
From: Keller, TX
Status: offline
Looks like it's going to be a hotfix for this one. I'm somewhat surprised about this - the redirect to SSL should be an assumed and not too rare.  Not sure why Word can't handle it.

The MSFT SharePoint support folks had me use TTracer on the client and sent the results off to the Word support team. They had me configure anonymous access to /vti_inf.html* and /vti_bin/*, but we still had the same issue.

They're triaging (if that's a word) the hotfix now.

I'll update the thread once I have more.

(in reply to tshinder)
Post #: 16
RE: ISA SSL Redirect - MSWord Issues - 10.Sep.2009 9:08:37 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi Clint,

Thanks! Great info.

Looking forward to a resolution.

Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to ClintD)
Post #: 17
RE: ISA SSL Redirect - MSWord Issues - 6.Dec.2009 12:57:56 AM   
ClintD

 

Posts: 1848
Joined: 26.Jan.2001
From: Keller, TX
Status: offline
Un.
Bee.
Lee.
Vuh.
Bull.

AAM issue. 5 months and it took the Office Integration guy from MSFT 5 minutes to figure this out. I had about 4 months with the SharePoint guy and he checked the AAM config the first day I opened the case and he confirmed it was correct, which it obviously wasn't.

Grrrr....

(in reply to tshinder)
Post #: 18
RE: ISA SSL Redirect - MSWord Issues - 21.Dec.2009 9:00:53 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Ha! I thought it was an AAM issue

Well, good to hear that there was a final resolution and thanks for the follow up!

Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to ClintD)
Post #: 19

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 Publishing] >> SharePoint Publishing >> ISA SSL Redirect - MSWord Issues Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts