Troubleshooting poor performance for specific web sites? (Full Version)

All Forums >> [ISA Server 2004 Cache] >> General



Message


mcr -> Troubleshooting poor performance for specific web sites? (6.Jul.2009 11:52:23 AM)

I'm using an ISA 2004 server as a simple cacheing proxy. Most of the time it works very well, but there are a small number of web sites that perform extremely poorly through the proxy. Examples are the KLM and Air France online checkin sites and Travelocity.

If I remove the proxy setting from Internet Explorer on the client PCs the same sites perform perfectly well, so it doesn't seem to be a problem with the web sites or our internet connectivity. The same sites perform poorly from any client machine using the proxy, it's not specific to individual clients.

There are no errors or alerts in the event logs on the proxy, no other problems with the network, and the vast majority of sites are not affected. The server is high spec, probably overpowered for it's task - CPU use and disk IO are negligible, memory utilisation is around 1.5Gb of 2Gb available (ISA is set to use 50% for the cache).

Does anybody have any suggestions where I go next to troubleshooting this problem?




Rotorblade -> RE: Troubleshooting poor performance for specific web sites? (6.Jul.2009 4:19:01 PM)

In Troubleshooting, have you tried creating a non-caching rule for the problem sites? In reference to “extreme poor performance” as you defined, are requests just slow or are you getting time-outs? There could be a few things to check and DNS would be my first and PMTU discovery is the second. Is DNS setup correctly on ISA using an internal DNS server configured as a forwarder? PMTU discovery should be enabled.

http://support.microsoft.com/kb/902347

http://blogs.isaserver.org/shinder/2006/05/09/general-approach-to-solving-performance-issues-with-the-isa-firewall-part-1/

http://blogs.isaserver.org/shinder/2006/05/10/general-approach-to-solving-performance-issues-with-the-isa-firewall-part-2/  

 HTH

RB




mcr -> RE: Troubleshooting poor performance for specific web sites? (7.Jul.2009 5:50:27 AM)

Thanks for those. PMTU was already enabled in the registry but there was no rule set up in the firewall, so I've created that. I'd already checked everything that's listed in the other two documents... good checklists.

I'll see if the PMTU change makes any difference, if not I'll move on to try rules to prevent cacheing.




paulo.oliveira -> RE: Troubleshooting poor performance for specific web sites? (7.Jul.2009 5:52:29 PM)

Hi,

you can also run ISABPA.

Regards,
Paulo Oliveira.




Page: [1]