• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

WPAD dat file not published to auto discovery port

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Threat Management Gateway (TMG) 2010] >> General >> WPAD dat file not published to auto discovery port Page: [1]
Login
Message << Older Topic   Newer Topic >>
WPAD dat file not published to auto discovery port - 2.Mar.2010 8:43:42 AM   
nickspender

 

Posts: 35
Joined: 4.Nov.2009
Status: offline
Hello

WPAD dat file not published to auto discovery port, auto discovery port has been set to port 80, and web porxy 8080 (default), But when i browse to http://wpad/wpad.dat i get a 404, but when i browse to http://wpad:8080/wpad.dat i am able to download the dat file

Please help

Many Thanks
Post #: 1
RE: WPAD dat file not published to auto discovery port - 2.Mar.2010 3:14:11 PM   
SteveMoffat

 

Posts: 1130
Joined: 29.Jun.2001
From: Hamilton, Bermuda
Status: offline
DNS & DHCP entries required.

_____________________________

Thanks
Steve

ISA 2006 Book! - http://tinyurl.com/2gpoo8
TMG Bible - http://tinyurl.com/ykv85hr
www.isaserver.bm

The built in ISA help is likely the most comprehensive help built into an application anywhere. USE it!!! Search it!!! RTFM

(in reply to nickspender)
Post #: 2
RE: WPAD dat file not published to auto discovery port - 3.Mar.2010 6:39:17 AM   
nickspender

 

Posts: 35
Joined: 4.Nov.2009
Status: offline
"But when i browse to http://wpad/wpad.dat i get a 404, but when i browse to http://wpad:8080/wpad.dat i am able to download the dat file" , this should be some sort of inditcation that dns or dhcp is set up, i dont use the dhcp option, and its not required

(in reply to SteveMoffat)
Post #: 3
RE: WPAD dat file not published to auto discovery port - 3.Mar.2010 7:19:01 AM   
SteveMoffat

 

Posts: 1130
Joined: 29.Jun.2001
From: Hamilton, Bermuda
Status: offline
OK. Obviously ou know best.

_____________________________

Thanks
Steve

ISA 2006 Book! - http://tinyurl.com/2gpoo8
TMG Bible - http://tinyurl.com/ykv85hr
www.isaserver.bm

The built in ISA help is likely the most comprehensive help built into an application anywhere. USE it!!! Search it!!! RTFM

(in reply to nickspender)
Post #: 4
RE: WPAD dat file not published to auto discovery port - 3.Mar.2010 7:22:41 AM   
SteveMoffat

 

Posts: 1130
Joined: 29.Jun.2001
From: Hamilton, Bermuda
Status: offline
Configure Automatic Discovery to Check DNS Only
Problem:
By default, the automatic discovery mechanism checks for a WPAD entry in DHCP, and then DNS. How can it be configured to check only DNS?

Cause:
There may be some circumstances in which you want to skip the DHCP check, for example, to increase response times.

Solution:
You can configure Internet Explorer to use only DNS for automatic discovery. To do this, navigate to the following registry location:

HKEY_Current_User\Software\Microsoft\Windows\CurrentVersion\Internet Settings

Then add the following value:

DWORD: AutoProxyDetectType. Set the value to 2 to force DNS only.

_____________________________

Thanks
Steve

ISA 2006 Book! - http://tinyurl.com/2gpoo8
TMG Bible - http://tinyurl.com/ykv85hr
www.isaserver.bm

The built in ISA help is likely the most comprehensive help built into an application anywhere. USE it!!! Search it!!! RTFM

(in reply to SteveMoffat)
Post #: 5
RE: WPAD dat file not published to auto discovery port - 3.Mar.2010 7:27:01 AM   
nickspender

 

Posts: 35
Joined: 4.Nov.2009
Status: offline
ok so dns is configured, and there is a timeout where it will skip dhcp if option 252 is not found then move to DNS, i can resolve dns to wpad. but my issue is that the dat files are getting published to the wrong port

thanks for your help, and no i dont know best. do i do know some stuff but about this issue

(in reply to nickspender)
Post #: 6
RE: WPAD dat file not published to auto discovery port - 3.Mar.2010 7:33:47 AM   
SteveMoffat

 

Posts: 1130
Joined: 29.Jun.2001
From: Hamilton, Bermuda
Status: offline
Have you even tried the DHCP option? It forces discovery on whichever port you choose.

_____________________________

Thanks
Steve

ISA 2006 Book! - http://tinyurl.com/2gpoo8
TMG Bible - http://tinyurl.com/ykv85hr
www.isaserver.bm

The built in ISA help is likely the most comprehensive help built into an application anywhere. USE it!!! Search it!!! RTFM

(in reply to nickspender)
Post #: 7
RE: WPAD dat file not published to auto discovery port - 3.Mar.2010 7:40:08 AM   
nickspender

 

Posts: 35
Joined: 4.Nov.2009
Status: offline
yea i have used it before, but my question is why is the dat file been published to a different port  and not about dns or dhcp disovery. look i set the auto dovery port in "internal" in networks within TMG, theres a host a record for wpad. but when i go to http://wpad/wpad.dat i get nothing a 404 but if i change the url to 8080 then it down loads, so they is it not publishing on the port that i configured

thanks

(in reply to SteveMoffat)
Post #: 8
RE: WPAD dat file not published to auto discovery port - 31.Mar.2010 9:43:50 AM   
jgilbert

 

Posts: 9
Joined: 15.Apr.2005
From: U.K.
Status: offline
I also have a similar problem, I cannot obtain the wpad.dat on port 80.

On the “Auto Discovery” tab of the Internal Network properties I have ticked the “Publish automatic discovery information for this network” box and where it says “Use this port for automatic discovery requests:” I have entered 80. Wpad resolves to the internal IP of the TMG server. The web proxy http port is set to 8080.

Expected behaviour:

1. Get http://wpad/wpad.dat returns the wpad.dat file.
2. Get http://wpad/wspad.dat returns the wspad.dat file.

Actual behaviour:

1. Get http://wpad/wpad.dat returns a HTTP/1.1 200 OK\r\n. and then Connection: close\r\n
2. Get http://wpad/wspad.dat returns the wspad.dat file.
3. Get http://wpad:8080/wpad.dat returns the wpad.dat file.
4. Get http://wpad:8080/wspad.dat returns the wspad.dat file.

If I change the auto discovery port to 8081:

1. Get http://wpad:8081/wpad.dat returns the wpad.dat file.
2. Get http://wpad:8081/wspad.dat returns the wspad.dat file.
3. Get http://wpad:8080/wpad.dat returns the wpad.dat file.
4. Get http://wpad:8080/wspad.dat returns the wspad.dat file.

I use the DHCP discovery option and specify http://wpad/wpad.dat, this worked great with ISA 2006 but doesn’t work with TMG. The work around is to specify either http://wpad:8080/wpad.dat or http://wpad:8081/wpad.dat.

I would like to know why port 80 doesn’t work with TMG, anybody know?

Many Thanks

(in reply to nickspender)
Post #: 9
RE: WPAD dat file not published to auto discovery port - 31.Mar.2010 10:36:09 AM   
rino01

 

Posts: 69
Joined: 1.Jul.2005
From: Stockholm / Sweden
Status: offline
Sound strange I have installed 7 TMG servers Standard and Enterprise and http://wpad/wpad.dat have always worked for me. You don't have anything that uses port 80 installed before you installed the TMG firewall? Do you have any alerts indecating that this could be the problem?

_____________________________

Best Regards

//Rickard

(in reply to jgilbert)
Post #: 10
RE: WPAD dat file not published to auto discovery port - 31.Mar.2010 11:36:53 AM   
TreeFox

 

Posts: 18
Joined: 4.Feb.2010
From: Czech Rep.
Status: offline
Hi,

if you have IIS installed on your TMG server, make sure that it does not use port 80. Check your IIS setting and change port 80 to something else if necessary. At least this was my problem.

_____________________________

Jan Hroch

(in reply to rino01)
Post #: 11
RE: WPAD dat file not published to auto discovery port - 1.Apr.2010 11:13:37 AM   
jgilbert

 

Posts: 9
Joined: 15.Apr.2005
From: U.K.
Status: offline
No alerts indicating a problem, I do have IIS installed but the default website is stopped.

Thanks for the suggestions I have been able to find my problem is being caused by a web listener configured to listen on the internal network for connections on port 80. Nick maybe you have the same type of listener?

Strange how when you have a internal port 80 web listener wspad.dat is served but wpad.dat isn't.

(in reply to TreeFox)
Post #: 12
RE: WPAD dat file not published to auto discovery port - 7.Apr.2010 3:10:09 AM   
dmutsaers

 

Posts: 105
Joined: 1.Aug.2003
From: The Netherlands
Status: offline
Did you see this thread. You're not the only one with problems... "Automatically Detect Settings" in IE doesn't work.

(in reply to jgilbert)
Post #: 13
RE: WPAD dat file not published to auto discovery port - 8.Apr.2010 2:52:11 AM   
dmutsaers

 

Posts: 105
Joined: 1.Aug.2003
From: The Netherlands
Status: offline
quote:

ORIGINAL: rino01

Sound strange I have installed 7 TMG servers Standard and Enterprise and http://wpad/wpad.dat have always worked for me. You don't have anything that uses port 80 installed before you installed the TMG firewall? Do you have any alerts indecating that this could be the problem?


Strange I've installed about 5 and it always fails. Do you use RRAS with DHCP?

(in reply to rino01)
Post #: 14
RE: WPAD dat file not published to auto discovery port - 1.Feb.2011 3:01:45 AM   
simek

 

Posts: 5
Joined: 11.Oct.2006
Status: offline
Hi,

had a simmilar problem, but I was able to fix it. I had a used port 80 on the internal IP. I also had resource allocation errors on TMG for port 80 when I tried to publish WPAD.

I ran netstat -ano to see which PID was using the port, the offending PID was 4, which translates to Kernel/System.

After a lot of digging I found that I had BranchCache enabled, eventhough I don't use it.

You can check your used ports for yourself if you have the same problem:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\HTTP\Parameters\UrlAclInfo

(in reply to dmutsaers)
Post #: 15
RE: WPAD dat file not published to auto discovery port - 29.Mar.2013 6:53:08 AM   
daniels

 

Posts: 1
Joined: 29.Mar.2013
Status: offline
How did you solve your problem? I have the same problem. I have TMG standalone array in NLB which is working fine except access to wpad.dat on port 80 only on array manager TMG server(http://IPadressOfArrayManager/wpad.dat isn't working, http://IPadressOfArrayManager:8080/wpad.dat is downloading wpad.dat).

On the other hand, I can download WPAD from array managed server on both port 80 and 8080.

When I execute netstat -ano on array manager server I can see that proccess with PID 4(Image Name: System) is listening on port 80(and port 445).

Proto Local Address Foreign Address State PID
TCP 0.0.0.0:80 0.0.0.0:0 LISTENING 4
TCP 0.0.0.0:445 0.0.0.0:0 LISTENING 4

Of course, on Internal network, in the Auto Discovery tab, Publish automatic discovery information is enabled, and port 80 is specified in Use this port for automatic discovery requests(I tried to uncheck this option, reboot both servers, check the option again, reboot both servers but it didn't help).

However on array managed server there is no proccess assigned to port 80. I can see that proccess with PID 4 is listening only on port 445(and not on port 80).

Proto Local Address Foreign Address State PID
TCP 0.0.0.0:445 0.0.0.0:0 LISTENING 4

On both array members there is a registry key under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\HTTP\Parameters\UrlAclInfo with value http://+:80/Temporary_Listen_Addresses/.

I want my clients to discover WPAD using DNS and as I read WPAD must be accessed on port 80.
Does anyone have resolution for this issue?

EDIT.

Problem is solved. IIS was listening on port 80 on array manager TMG node(IIS rewuired for SQL Reporting, read here http://blogs.isaserver.org/shinder/?p=594). You just need to add IIS manager from Roles in Server Manager, browse to the IIS Default Web site and change Bindings to ahother port(I have used 81). Reboot the server. You can now see that command netstat -ano | findstr :80 shows you that TMG firewall service PID is using port 80.

< Message edited by daniels -- 1.Apr.2013 4:47:24 AM >

(in reply to simek)
Post #: 16

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Threat Management Gateway (TMG) 2010] >> General >> WPAD dat file not published to auto discovery port Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts