• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

ISA web filter issue

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 Misc.] >> ISA 2006 Programming >> ISA web filter issue Page: [1]
Login
Message << Older Topic   Newer Topic >>
ISA web filter issue - 9.Aug.2011 8:41:11 AM   
arunrams

 

Posts: 3
Joined: 5.Aug.2011
Status: offline
Hi,

I have installed a sample web filter Myauthfilter that comes with the ISA Server 2006 SDK, in the array addins.  I have followed the steps given in the Readme file which comes along with the SDK.
 
But I am not able to load the filter or send HTTP request from the client to the filter. I am not sure whether the issue is with the firewall policy rules settings. Can anyone help me in testing / debugging the  filter?



Thanks in advance!
Arun
Post #: 1
RE: ISA web filter issue - 10.Aug.2011 8:38:00 AM   
ferrix

 

Posts: 547
Joined: 16.Mar.2005
Status: offline
If you open a Microsoft PSS ticket and manage to get yourself routed to the "WinInet ISAPI" group (at least that's what it was called a couple years ago) they can offer troubleshooting assistance.

One thing I've learned is that MS samples rarely build and work properly out of the box.  There's usually something you have to change, fix, or update, or some kind of step they don't tell you that you have to perform.

It's been a *looong* time since I looked at ISA SDK samples, so I don't know what specifically to advise you.  If you want to test some custom functionality with a filter that is known to work, you can try IsaScript.  It will allow you to write in lua script and not have to bother with compiling a web filter and getting a million screwy details right.  (only 100 screwy details :)

(in reply to arunrams)
Post #: 2
RE: ISA web filter issue - 16.Aug.2011 2:23:33 AM   
arunrams

 

Posts: 3
Joined: 5.Aug.2011
Status: offline
Is it possible to create a HTTP listner in ISA server 2006? or will it support only HTTPS??

(in reply to ferrix)
Post #: 3

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 Misc.] >> ISA 2006 Programming >> ISA web filter issue Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts