• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

upload speed slow on TMG 2010

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [Threat Management Gateway (TMG) 2010] >> Installation >> upload speed slow on TMG 2010 Page: [1]
Login
Message << Older Topic   Newer Topic >>
upload speed slow on TMG 2010 - 21.Mar.2012 5:02:31 AM   
Ashokk001

 

Posts: 244
Joined: 6.Oct.2005
Status: offline
Hello all,

I've just installed a fresh copy of TMG 2010 standard and have patch it to the latest service package and the sp2 rollup update 1.

I noticed that there is MS tech article that talks about slow upload speed on TMG 2010 and i'm following the article:

http://support.microsoft.com/kb/2452980

We have 100mb leased line (100mb up.down) and so i'm trying to conigure the keys detailed in the article however what it does not tell me is what kind of keys they are i.e. string, dword etc?

Has anyone one done this and if so could you let me know which type of keys/value to create?

I don't seem to have the parameters key under the W3Proxy section so i'm guessing i need to create this as well.

Thanks,

Ash.
Post #: 1
RE: upload speed slow on TMG 2010 - 28.Feb.2013 12:50:30 PM   
wbplomp

 

Posts: 144
Joined: 18.Nov.2004
From: Netherlands, The
Status: offline
Have you found a solution for this issue.

I also encounter this issue on a new TMG Array. I have already installed all latest update, rollups and Service Packs. I have tried everything you can imagine. The update, the registry keys, the script, VMDq, SR-IOV, Path MTU Discovery and so on. One way or another I cannot get rid of this issue.

Our TMG servers (VM's) run on Hyper-V (Windows Server 2012). The Virtual Machines have a "Network Adapter". Somehow I got the feeling it might be caused by the Network Adapter (which is seen as a 10GB connection). My next step is to use a Legacy Network Adapter instead. But to do so I first have to break down NLB and etc.

Any suggestions?

(in reply to Ashokk001)
Post #: 2
RE: upload speed slow on TMG 2010 - 5.Mar.2013 9:47:18 AM   
tosla

 

Posts: 1
Joined: 5.Mar.2013
Status: offline
Hi,

You should NOT change the virtual NIC to legacy; the throughput is MUCH lower, as the legacy NIC is emulated, whereas the synthetic act as a proxy between the virtual computer and the NIC - here is a quite good explanation: http://trycatch.be/blogs/roggenk/archive/2008/11/04/hyper-v-and-virtual-devices-vdev-synthetic-versus-emulated-devices.aspx

Also notice running and emulated will consume CPU to run the emulation software.

BR
Torben

(in reply to wbplomp)
Post #: 3
RE: upload speed slow on TMG 2010 - 6.Mar.2013 7:00:03 AM   
wbplomp

 

Posts: 144
Joined: 18.Nov.2004
From: Netherlands, The
Status: offline
I know the Legacy Network Adapter is emulated. This is why I always use Network Adtapters. But I have to test things to be able to solve the proiblem. I have read about people doing that on a VMWare guest and solved their issue.

I have tested it on Hyper-V, but it didn't solve the problem. I noticed the problem occurs only when NLB is enabled. I have tried everything I can think of. I am now re-installing the servers and TMG. Checking the upload after every change and update.

(in reply to tosla)
Post #: 4
RE: upload speed slow on TMG 2010 - 4.Apr.2013 1:03:57 PM   
Ashokk001

 

Posts: 244
Joined: 6.Oct.2005
Status: offline
Hi,

Sorry for the late reply, i think i saw some info on this, can you change the speed setting on the NIC in TMG virtual server to 100mb say and re test. Might be worth a go rather than changing it to legacy adapter.

We're still not perfect with downloads of 94Mb and Upload of 51Mb on a 100mb symmetrical leased line connection. I'm just not sure what it could be, we have tried the script, reg keys etc. can i ask which keys you have a what value you ran the script at?

Thanks,

Ash.

(in reply to wbplomp)
Post #: 5
RE: upload speed slow on TMG 2010 - 23.Aug.2013 1:46:29 AM   
Naveed123

 

Posts: 1
Joined: 23.Aug.2013
Status: offline
so could you let me know which type of keys/value to create?

_____________________________

pass-4-sure http://www.pass-4-sure.net
leather4sure-motorcycle jackets for men leather4sure-motorcycle jackets for men

(in reply to Ashokk001)
Post #: 6
RE: upload speed slow on TMG 2010 - 14.Oct.2013 1:46:08 PM   
elmajdal

 

Posts: 6022
Joined: 16.Sep.2004
From: Lebanese in Kuwait
Status: offline
quote:

ORIGINAL: Ashokk001

I've just installed a fresh copy of TMG 2010 standard and have patch it to the latest service package and the sp2 rollup update 1.


I remember once i uninstalled Roll Update 1 and the problem was fixed.

_____________________________

Tarek Majdalani

Windows Expert - IT Pro MVP
Facebook : https://www.facebook.com/ElMajdal.Net

(in reply to Ashokk001)
Post #: 7
RE: upload speed slow on TMG 2010 - 5.Sep.2014 7:12:03 AM   
allamerican

 

Posts: 3
Joined: 5.Sep.2014
Status: offline
Have you filed complaint against the providers.

_____________________________

Business Telephone Systems Dallas
T1 Service Dallas

(in reply to Ashokk001)
Post #: 8

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [Threat Management Gateway (TMG) 2010] >> Installation >> upload speed slow on TMG 2010 Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts