• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

ISA Server Control Failure Problems with LAT?

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2000 General] >> General >> ISA Server Control Failure Problems with LAT? Page: [1]
Login
Message << Older Topic   Newer Topic >>
ISA Server Control Failure Problems with LAT? - 30.Oct.2001 3:36:00 AM   
x97steslicki

 

Posts: 5
Joined: 30.Oct.2001
Status: offline
I boot my machine then connect to my dsl line, bam everything works fine. I open the services applet and try to stop the ISA Server Control service but the option to stop/restart is greyed out, only the start option is available. next I open ISA Management console and try to re-construct the LAT, I made some changes and must have messed something up, when i choose construct LAT I get an error message saying "operation failed" with the details of ISA server control unreachable. I click ok and then i see the LAT box asking to include private ranges, and then below the dynamic box where it displays your adapters ip's, well I get an error massage that says "the ISA server cannot retrive this servers adapters list".

i am assuming that I screwed something up in the LAT, reboted, and when the box came back up everything was broken. Another symptom is when I restart the services (Firewall, proxy, and control) I get no web connectivity when I reconnect to the internat via my dsl.

I was reading in Tom's book on page 805 about a similar LAT problem and the need to reconstruct the LAT using the SDK script, but that really is not much help. Anyone have some suggestions other than to reinstall the ISA server, which is still a possibility but I hate to give up

-Adam

Post #: 1
RE: ISA Server Control Failure Problems with LAT? - 30.Oct.2001 2:36:00 PM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi X,

The vb code:

Constructing the Local Address Table
The Local Address Table (LAT) consists of a series of IP address ranges that define your internal network address space. Typically, the LAT contains all IP addresses associated with the internal network cards on the ISA Server computer, in addition to the private IP address ranges defined by the Internet Assigned Numbers Authority (IANA). For more information see the ISA product documentation.

You can use the ISA administration COM objects to build the LAT. The folder SDK\samples\admin\scripts includes the ConstructLAT script that constructs a LAT. It is provided in both VBScript and JScript.

Adding a LAT Entry
The following VBScript code demonstrates how to add an entry to the LAT:

Set objFPC = CreateObject ("FPC.Root")
Set objNetConfig = objFPC.Arrays(1).NetworkConfiguration
Set objLAT = objNetConfig.LAT
ObjLAT.Add "2.2.2.2","3.3.3.3"
ObjLAT.Save

HTH,
Tom

------------------
http://www.isaserver.org/shinder/


Get It Here!


(in reply to x97steslicki)
Post #: 2
RE: ISA Server Control Failure Problems with LAT? - 30.Oct.2001 4:39:00 PM   
x97steslicki

 

Posts: 5
Joined: 30.Oct.2001
Status: offline
I tried the VB script last night and I got the error "RPC Server unavailable". I uninstalled ISA, rebooted the machine, installed ISA, rebooted the machine, and bam everything works fine. The only catch is that during installation I must select all private address ranges, and the address ranges assigned to my nic's (192.168.0.x for internal lan, and 10.10.10.10 for my dsl nic, which through a virual adapter, PPPoE gets a real address.

When I say the only catch I mean that if I select anything but the entire set of addresses, like just my local addresses 192.168.0.x then ISA Server control fails with an invalid argument error. I am not done yet, even though I selected every addresses during the installation to construct the LAT from and I said it all works fine at that point, well as soon as I add a packet filter, and restart the services (Firewall, proxy, and control) the same damn error occurs. Later on tonight I am going to reinstall Advanced server, then ISA server, then try this whole process again. I mean no matter what I select in the installation construction of the LAT I still get the same error. Could this have something to do with my DSL line having a dynamic IP, and the order in which I start things, ISA first then DSL connection, or should I go DSL then ISA? I just can't seem to figure out what is wrong...

Thanks for the help.

-Adam

P.S. I own your book Tom


(in reply to x97steslicki)
Post #: 3

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2000 General] >> General >> ISA Server Control Failure Problems with LAT? Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts