• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Disable Web Publishing Cache

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 General ] >> Web Publishing >> Disable Web Publishing Cache Page: [1]
Login
Message << Older Topic   Newer Topic >>
Disable Web Publishing Cache - 23.Aug.2004 10:36:00 AM   
grantos

 

Posts: 4
Joined: 21.Jul.2004
Status: offline
Could somebody please offer some advice or point to some doco to disable the caching of published web pages.
I have set the IIS(5) setting to expire content immediately and have the default ISA 2004 caching rule active. However the pages from the published web site are returned from the ISA cache to the clients.

I still wish to cache outgoing web requests from internal clients.

Thanks,

Grant
Post #: 1
RE: Disable Web Publishing Cache - 24.Aug.2004 8:11:00 PM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi Grant,

You can turn on a cache rule to prevent caching of that site.

HTH,
Tom

(in reply to grantos)
Post #: 2
RE: Disable Web Publishing Cache - 25.Aug.2004 12:55:00 AM   
grantos

 

Posts: 4
Joined: 21.Jul.2004
Status: offline
Thanks Tom,

However I have had a failed attempt to do this so I guess I am looking for a bit of a guide on the correct way to do it.

Thanks

Grant

(in reply to grantos)
Post #: 3
RE: Disable Web Publishing Cache - 26.Aug.2004 9:19:00 PM   
rz

 

Posts: 36
Joined: 4.Dec.2003
Status: offline
quote:
Originally posted by grantos:
Thanks Tom,

However I have had a failed attempt to do this so I guess I am looking for a bit of a guide on the correct way to do it.

Thanks

Grant

I also cannot get this to work.
I created a URL set of our internal sites, created a cache rule, but it still caches. I even tried telneting into port 80 to make sure it isn't my browser. Help! Our users hate this.

Thanks,
-
Robert

(in reply to grantos)
Post #: 4
RE: Disable Web Publishing Cache - 30.Aug.2004 8:54:00 AM   
rz

 

Posts: 36
Joined: 4.Dec.2003
Status: offline
I got it to work, just had to uncheck "Enable HTTP caching" on the rule that prevents caching on internal webs.

-
Robert

(in reply to grantos)
Post #: 5
RE: Disable Web Publishing Cache - 2.Sep.2004 4:06:00 PM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
You can use the following example for OWA to see how to create a "do not cache for XYZ" rule...this is normally the best way as it allows you to leave HTTP caching enabled but create a rule to specifically stop caching of certain items...

"If you do not use ISA Server forms-based authentication, when the ISA Server caching feature is enabled, all Outlook Web Access objects will be cached. This can lead to unexpected logging off of users. To avoid this, you must create a cache rule to prevent the caching of Outlook Web Access objects except for images. The cache rule must have the following properties

Cache Rule Destination. A URL set containing http://nameofowaserver/exchweb/*. After you create the rule using the New Cache Rule Wizard, open the rule properties, and on the To tab, add http://nameofowaserver/exchweb/img/* to the Exceptions. This will allow caching of the img (images) path.

Content Retrieval. Only if a valid version of the object exists in the cache.

Cache Content. Never, no content will ever be cached.


To create a cache rule:

1.
Expand Microsoft ISA Server Management, expand Configuration and click Cache.

2.
In the task pane, on the Tasks tab, select Create a Cache Rule to start the New Cache Rule Wizard.

3.
On the Welcome page of the wizard, provide a name for the rule, and then click Next.

4.
On the Cache Rule Destination page, click Add to open the Add Network Entities dialog box, select the appropriate network entity, click Add, and then click Close. On the Access Rule Destination page, click Next.

5.
On the Content Retrieval page, leave the default selection Only if a valid version of the object exists in the cache, and then click Next.

6.
On the Cache Content page, select options as described earlier in this topic.

7.
You can use the default selections on the remaining wizard pages. Information about cache rule properties is provided in the product Help. Review the information on the wizard summary page, and then click Finish."

[ September 02, 2004, 04:07 PM: Message edited by: Jason Jones ]

(in reply to grantos)
Post #: 6
RE: Disable Web Publishing Cache - 19.Oct.2004 9:55:00 PM   
baskinz

 

Posts: 7
Joined: 19.Oct.2004
Status: offline
In ISA 2k, do you accomplish this with a network routing rule? If not, how would you turn off caching for just one publishing rule?

Regards,

Chris

(in reply to grantos)
Post #: 7
RE: Disable Web Publishing Cache - 19.Oct.2004 10:06:00 PM   
baskinz

 

Posts: 7
Joined: 19.Oct.2004
Status: offline
To elaborate on my last post, I have this routing rule in place and it is indeed not caching. However, when the client hit's F5 from their browser, it takes forever for it to repopulate the page (some images do not repopulate, as well).

Yet, if I turn off all http caching, this problem goes away even though it isn't caching (I've verified through cachedir that it isn't caching any objects).

Has anyone seen this behavior before?

Thanks,

Chris

(in reply to grantos)
Post #: 8

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2004 General ] >> Web Publishing >> Disable Web Publishing Cache Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts