• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Published Telnet Server Connection Hangs

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 General ] >> Server Publishing >> Published Telnet Server Connection Hangs Page: [1]
Login
Message << Older Topic   Newer Topic >>
Published Telnet Server Connection Hangs - 7.Oct.2005 4:31:00 PM   
KevinSawyer

 

Posts: 15
Joined: 26.May2004
From: Fairview Heights, IL, USA
Status: offline
I have a brand new SBS 2003 Premium with SP1 (ISA 2004) and it works great. There's a Linux-based server within the internal network. I've created a publishing rule for inbound Telnet access to that Linux server and it works...until I do something that results in a burst of text being sent back to the remote client, then the connection hangs.

If I telnet into the Linux server from within the local network, everything is fine. If I establish a VPN connection to the SBS then telnet to the Linux server, everything is fine. It's only when I telnet via the publishing rule that connections eventually hang. If I list the contents of a directory that only had a few files in it, it works. If I list the contents of a directory with many files (and therefore a larger burst of text), the connection will hang every time.

When I watch the ISA logs, there is nothing out of the ordinary...no "denied" or "connection closed" when the hang condition occurs. The Linux-based server is RedHat 7.3 with all available patches/updates. Any ideas?

--Kevin

[ October 07, 2005, 04:32 PM: Message edited by: Kevin Sawyer ]
Post #: 1
RE: Published Telnet Server Connection Hangs - 7.Oct.2005 5:37:00 PM   
KevinSawyer

 

Posts: 15
Joined: 26.May2004
From: Fairview Heights, IL, USA
Status: offline
Looks like we figured it out. The MTU on the Linux server was 1500. We lowered it to 1452 and now all is well. We needed to get it running quickly so I'm not sure what the max MTU could be without breaking it.

Since the MTU didn't break anything when we were using VPN or when we telnet directly from the SBS console, I can only conclude that the problem is within the ipnat.sys or other "router" code within ISA and/or Windows Server 2003. We found and reported a similar Microsoft bug in ISA 2000. Problems like this really make it frustrating that we don't have the source and can't fix it ourselves...but that's another rant.

--Kevin

(in reply to KevinSawyer)
Post #: 2
RE: Published Telnet Server Connection Hangs - 20.Feb.2006 5:52:05 PM   
denizyalcin

 

Posts: 122
Joined: 19.Jan.2005
From: Turkey
Status: offline
Hi, I know that this is a very old thread but I've got a problem similar to this. I've the same setup as Kewin Sawyer and I managed to publish my Linux server, too. But my problem is that my client's connection dies when it isn't being used for a few seconds. When my client does continuously use the connection, there isn't any problem but when it stops using the connection for a small time it's being dropped. What can be the cause for this ?

(in reply to KevinSawyer)
Post #: 3

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2004 General ] >> Server Publishing >> Published Telnet Server Connection Hangs Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts