• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

problem with upstream proxy server

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 Firewall] >> Network Infrastructure >> problem with upstream proxy server Page: [1]
Login
Message << Older Topic   Newer Topic >>
problem with upstream proxy server - 28.Feb.2005 1:10:00 PM   
Guest
Hello all,

need a help please! :-(
I try arrange network scenario, where ISA server 2004 is working like edge firewall with cache proxy. Also I would like to run antivirus proxy on the same machine where ISA is.
Problem is, that simple changing "last default rule" like in ISA 200 is not working anymore.

I can do anything but still obtaining error message 12206.
Microsoft tells, that thismeans cycling of communication.
But I'm unable to correct it.
Please does anybody know how to configure it?

P.S. of course I know that this can mean security risk...

Reg. Tomeek
  Post #: 1
RE: problem with upstream proxy server - 28.Feb.2005 2:36:00 PM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi Reg,

If the AV software was designed to work with the ISA firewall, the vendor should have detailed instructions on how to install and configure it. Haven't they provided that to you?

Thanks!
Tom

(in reply to Guest)
Post #: 2
RE: problem with upstream proxy server - 28.Feb.2005 3:17:00 PM   
Guest
no...
They did not provide any information.
You know, that this is not only problem of AV vendor.
Same troubles you can have with other 3rd party software installed right on ISA 2004 server.

This is btw my problem.

Thank you

(in reply to Guest)
  Post #: 3
RE: problem with upstream proxy server - 28.Jun.2005 3:45:00 AM   
Thinkagain

 

Posts: 6
Joined: 9.Nov.2004
Status: offline
Tomeek,

I've been trying to solve this problem as well and were not able to get this thing working.
I did find a document in the knowledgebase of the av vendor (TrendMicro in this case) stating that it is not possible to install an upstream proxy on the same machine
Link to KB article

I've contacted microsoft support on this issue and they came up with the solution to create two firewall rules, the first rule allows localhost to external for a custom added http protocol. In the custom added http protocol definition the "web proxy filter" is deselected. The second rule denies localhost to external for the standard http protocol.
This seemed to work but after some further investigation resulted in weird problems with several websites so i eventually removed this configuration. All problems seem to be related to the http proxy filter. If i disable the "web proxy filter" in the http protocol definition it works for the proxy clients (but from what i read it no longer works for the clients that route through the proxy).
Disabling the web proxy filter does not seem to be a nice solution as this is a major part of the traffic inspection of isa2004.

If anybody else has a good working isa2004 which connects to a locally installed proxy server please respond!

reg. Thinkagain

(in reply to Guest)
Post #: 4
RE: problem with upstream proxy server - 8.Jul.2005 4:01:00 AM   
Guest
Hi

I was looking in to this last week. I had to get ISA 2004 working with trend IWSS.
I got some documentation from trend advising to put IWSS between ISA and the users not upstream.

so I had IWSS listening on port 9999 and an Internal to local host rule to allow this.

I then put IWSS to use ISAs internal IP and port 9998 as its upstream proxy. Set ISA to listen on 9998 and created a rule to allow 9998 from local host to local host (thatĘs what made it work)

After doing that lot I got a connection but took upto 3 minutes to display a page.
We went with a different AV product so I could not do any more investigation.

the local host to local host rule looks very dodgy to me but it did get things working

I hope that is some help.

Jase

(in reply to Guest)
  Post #: 5

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2004 Firewall] >> Network Infrastructure >> problem with upstream proxy server Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts