• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

FwcTool.exe broken by SP1 client update

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 Firewall] >> Firewall Client >> FwcTool.exe broken by SP1 client update Page: [1]
Login
Message << Older Topic   Newer Topic >>
FwcTool.exe broken by SP1 client update - 3.Mar.2005 8:15:00 AM   
Guest
FYI, once you update the SP1 firewall client, the separate firewall client control tool download which provides scripted control of the firewall client fails with the following error:

c:\FwcTool.exe enable

FwcTool version 4.0.2161
Firewall Client for ISA Server 2004 support tool
Copyright (c) Microsoft Corporation. All rights reserved.

Action: Enable Firewall Client
User: current
Application: all applications

FwcTool failed. Error code 5, 70, 0x800706C6
Error Description: The array bounds are invalid.

When I run this on another test machine without the updated SP1 client is succeeds, both clients talking to a SP1 ISA server.

Note the build number of the tool which must be downloaded separately matches the pre-SP1 firewall client build number. Hopefully MS will release a new compatible build of this tool soon as I've seen this used a lot to manually control the firewall client. There are also a number of other separate utilities which I have not tested by suspect they may also fail.
  Post #: 1
RE: FwcTool.exe broken by SP1 client update - 3.Mar.2005 5:54:00 PM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi WW,

Whoa! You caught a good one.

I'll update the article.

Thanks!
Tom

(in reply to Guest)
Post #: 2
RE: FwcTool.exe broken by SP1 client update - 3.Mar.2005 11:54:00 PM   
WyldWolf

 

Posts: 246
Joined: 3.Mar.2005
From: Wisconsin
Status: offline
No problem! Hey maybe you have contacts at MS to report it to? I tried emailing the "feedback" and they thought I wanted to report another IE bug! I can't seem to figure out what the official MS procedure is for the public to report a bug, etc. without paying at least $99.....which doesn't make sense for me to do since I know what the problem is and I know they have no immediate fix.

By the way, love the site you do an excellent job! I've been using the MS-ISA line of products since proxy 1.0 and this is by far the best real-world resource for the product line!

(in reply to Guest)
Post #: 3
RE: FwcTool.exe broken by SP1 client update - 4.Mar.2005 2:33:00 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi WW,

Thanks for th compliments! I've been following your posts and you're pretty sharp on the ISA issues. Great to have you on board!

I'll report this issue to the ISA guys I know internally and hopefully we'll get a fix.

Thanks!
Tom

(in reply to Guest)
Post #: 4
RE: FwcTool.exe broken by SP1 client update - 14.Mar.2005 7:13:00 PM   
SteveCDN

 

Posts: 11
Joined: 2.Mar.2005
Status: offline
Tom, would appreciate a reply to this thread if you get some feedback re: fwctool. Hope it's fixed soon as it's holding up my rollout of the client.

Also, for existing ISA pre-SP1 FWC's, how can the update be applied. Does it require a re-install of the client or does it pull down the new client when SP1 is installed and the pre-SP1 FWC starts on the workstation? Doubt the latter, but one can hope. Assume I'll have to add another client install to my GPO.

Thanks.

(in reply to Guest)
Post #: 5
RE: FwcTool.exe broken by SP1 client update - 14.Mar.2005 8:56:00 PM   
WyldWolf

 

Posts: 246
Joined: 3.Mar.2005
From: Wisconsin
Status: offline
Steve,

Use your GPO to redeploy to all clients, it will redeploy using the updated .msi client file, assuming you're deploying from the mspclnt share on the ISA server.

I'm also hoping MS fixes the fwctool.exe soon, I'm very suprised they didn't catch it in their testing of SP1.

(in reply to Guest)
Post #: 6
RE: FwcTool.exe broken by SP1 client update - 14.Mar.2005 9:00:00 PM   
SteveCDN

 

Posts: 11
Joined: 2.Mar.2005
Status: offline
WW, have you deployed the SP1 FWC using GPO? Do you know if it prevents that initial FWC window asking the user to click OK or cancel for how to connect to ISA (auto or manual)? Pre SP1 deployment of FWC via GPO is poor with that window popping up for the user, the first time they logon after the client is installed. It'd be great if SP1 FWC fixed this.

In the meantime I may continue to deploy pre SP1 client with fwctool and then install SP1 and redeploy FWC after they fix the fwctool.

Thanks.

Steve.

(in reply to Guest)
Post #: 7
RE: FwcTool.exe broken by SP1 client update - 22.Mar.2005 1:49:00 AM   
Scotte

 

Posts: 11
Joined: 19.Mar.2005
Status: offline
Steve, SP1 does NOT fix the initial OK prompt. On pre-SP1, I got it everytime I logged on, but SP1 changes that to just 1 prompt on the first log on. Its fixable by just deleteing the shortcut in Start\All Programs\Startup. I created an MST file to remove it. You can create it pretty easily with Orca or download it from http://www.scottes.com/MS_FWC.zip

(in reply to Guest)
Post #: 8
RE: FwcTool.exe broken by SP1 client update - 22.Mar.2005 1:56:00 AM   
WyldWolf

 

Posts: 246
Joined: 3.Mar.2005
From: Wisconsin
Status: offline
Actually the initial popup asking the user to configure the client has not changed at all from non-SP to SP1. Either way it only pops up once and as long as there is a valid configuration (auto or manual) and the user clicks ok it will not appear again.

(in reply to Guest)
Post #: 9
RE: FwcTool.exe broken by SP1 client update - 12.Apr.2005 6:45:00 PM   
WyldWolf

 

Posts: 246
Joined: 3.Mar.2005
From: Wisconsin
Status: offline
Just to update/close this thread, here's the link to the updated tool version 4.0.3439.50 (funny MS sill refers to is as v1.0) which works properly with ISA2004's SP1 client:

http://www.microsoft.com/downloads/details.aspx?FamilyId=F20F6267-273D-4870-B1E8-799B261B4786&displaylang=en

(in reply to Guest)
Post #: 10
RE: FwcTool.exe broken by SP1 client update - 31.Oct.2005 10:19:00 AM   
bdpconsulting

 

Posts: 25
Joined: 8.Feb.2005
From: Ontario
Status: offline
I tried using the post SP1 FwcTool. Seems to have executed successfully, however, I see no change in the firewall client. The icon in the task bar does not have the normal red square to indicate that it's disabled, and if I right click, I still have the option of disabling it. I've rebooted the machine and still the same thing. Any idea's?

Thx
Derek

(in reply to Guest)
Post #: 11

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2004 Firewall] >> Firewall Client >> FwcTool.exe broken by SP1 client update Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts