• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Empty reports after enabling SQL logging in ISA 2004

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 Firewall] >> Logging and Reporting >> Empty reports after enabling SQL logging in ISA 2004 Page: [1]
Login
Message << Older Topic   Newer Topic >>
Empty reports after enabling SQL logging in ISA 2004 - 27.Jan.2005 11:26:00 PM   
Sanvean

 

Posts: 1
Joined: 22.Dec.2004
Status: offline
Hi!

I have configured my ISA 2004 to log into SQL database, after that all my reports are empty. Re-creating reports and jobs does not helped. Is this behavior by design or have I missed tomething?

Thank you!
Post #: 1
RE: Empty reports after enabling SQL logging in ISA 2004 - 1.Feb.2005 3:08:00 PM   
Kerry.Kriegel

 

Posts: 30
Joined: 17.Sep.2004
From: Racine, Wisconsin
Status: offline
I have ISA 2004 on a WIN2003 Server. Everything worked fine on the initial install and setup. The reports were working as advertised, and an email alert with a link was being sent.

After discovering how fast the SQL database was going to fill, I created a new database on a seperate server (bigger hard-drive), created a new ODBC pointing in the right direction, and edited my logging parameters.

Since then, all reports are empty. I have verified that ISA is logging the data in the new database using the new ODBC. The summaries are being created on a daily basis, but they are empty.

Can anyone help with this? I have found very little documentation on the summary creator, or how to troubleshoot and test it.

(in reply to Sanvean)
Post #: 2
RE: Empty reports after enabling SQL logging in ISA 2004 - 18.Feb.2005 4:27:00 AM   
Milly

 

Posts: 2
Joined: 21.Jan.2005
Status: offline
I have a similar problem. When I installed my ISA server, I chose to log to MSDE. My logs were consuming alot of space int he default area so I went to the place that lets you pick your own location. It created new logs in the new location. I tried to just move all the old logs to the new area, but ISA server now only recognizes the logging that's taken place since I moved the destination. I'm unable to report on the previous data I've accumulated. I'm thinking that I need to load my old data into the new DB somehow, but I'm not sure how. ISA creates that MSDE database, but it doesn't give you any tools to manage the database does it? I wonder if it's better or easier just to use text files?

(in reply to Sanvean)
Post #: 3
RE: Empty reports after enabling SQL logging in ISA 2004 - 10.Mar.2005 3:08:00 AM   
Guest
I have this exact same problem, it seems that support for this product is non-existent. The logs seem to go into the database no problem since I can query the sql server and get statistics that way. I don't see why ISA can't pull the stats out now. I've configured permissions properly, and just installed SP1 but no luck.

Does anyone have a solution for this??

(in reply to Sanvean)
  Post #: 4
RE: Empty reports after enabling SQL logging in ISA 2004 - 11.Mar.2005 2:20:00 AM   
Guest
I've tried a few other thing but I still cannot get this working:
- Removed MSDE from our ISA server
- Repaired ISA installation
- Disabled/re-Enabled logging
- Removed old MSDE logs
- Removed old ILS files
I query our SQL server and it is actually storing information into it, it just seems that it is not pulling info out of it. Before I uninstalled MSDE, I noticed that if I looked up reports on days prior to logging to SQL server that the repors would generate for those days so I'm led to beleive that ISA is still trying to look at MSDE data. Now that it is uninstalled, I cannot pull up these old reports and it gives me an error. Trying to generate new reports does not give me an error but doesn't display data.
Any help would be much appreciated
Thanks!

(in reply to Sanvean)
  Post #: 5

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2004 Firewall] >> Logging and Reporting >> Empty reports after enabling SQL logging in ISA 2004 Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts