• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Password to SA on MSDE

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 Firewall] >> Logging and Reporting >> Password to SA on MSDE Page: [1]
Login
Message << Older Topic   Newer Topic >>
Password to SA on MSDE - 20.May2005 4:44:00 AM   
andersmeyer

 

Posts: 20
Joined: 21.Feb.2005
Status: offline
HI

dos' any one know what the SA default password is to the MSDE on ISA 2004
Post #: 1
RE: Password to SA on MSDE - 18.Aug.2005 10:23:00 AM   
100supersport

 

Posts: 3
Joined: 29.Dec.2002
Status: offline
Hi, Here is some info from Microsoft KB:
How To Verify and Change the MSDE System Administrator Password
View products that this article applies to.
Article ID : 322336
Last Review : July 1, 2004
Revision : 1.0
On This Page
SUMMARY
How to Verify If the SA Password is Blank
How to Change Your SA Password
How to Determine or Change Your Authentication Mode
Security Best Practices for a SQL Server Installation
REFERENCES
APPLIES TO

SUMMARY
This step-by-step article discusses the steps you can use to change the SQL Server sa (system administrator) password.

You can configure Microsoft SQL Server Desktop Engine (MSDE) versions 2000, or earlier, to run in Mixed Authentication mode. The sa account is created during the installation process and the sa account has full rights in the SQL Server environment. By default, the sa password is blank (NULL), unless you change the password when you run the MSDE Setup program. To conform with the best security practices, you must change the sa password to a strong password at the first opportunity.

Back to the top

How to Verify If the SA Password is Blank
1. On the computer that is hosting the instance of MSDE to which you are connecting, open a command prompt window.
2. At the command prompt, type the following command, and then press ENTER:

osql -U sa

This connects you to the local, default instance of MSDE by using the sa account. To connect to a named instance installed on your computer type:

osql -U sa -S servername\instancename

You are now at the following prompt:

Password:
3. Press ENTER again. This will pass a NULL (blank) password for sa.

If you are now at the following prompt, after you press ENTER, then you do not have a password for the sa account:

1>

Microsoft recommends that you create a non-NULL, strong password to conform with security practices.

However, if you receive the following error message, you have entered an incorrect password. This error message indicates that a password has been created for the sa account:
"Login Failed for user 'sa'."
The following error message indicates that the computer that is running SQL Server is set to Windows Authentication only:
Login failed for user 'sa'. Reason: Not associated with a trusted SQL Server connection.
You cannot verify your sa password while in Windows Authentication mode. However, you can create a sa password so that your sa account is secure in case your authentication mode is changed to Mixed Mode in the future.

If you receive the following error message, SQL Server may not be running or you may have provided an incorrect name for the named instance of SQL Server that is installed:
[Shared Memory]SQL Server does not exist or access denied.
[Shared Memory]ConnectionOpen (Connect()).

Back to the top

How to Change Your SA Password
1. On the computer that is hosting the instance of MSDE to which you are connecting, open the command prompt window.
2. Type the following command, and then press ENTER:

osql -U sa

At the Password: prompt, press ENTER if your password is blank or type the current password. This connects you to the local, default instance of MSDE by using the sa account. To connect by using Windows authentication, type this command: use osql -E


3. Type the following commands, on separate lines, and then press ENTER:
sp_password @old = null, @new = 'complexpwd', @loginame ='sa'
go


NOTE: Make sure that you replace "complexpwd" with the new strong password. A strong password includes alpha-numeric and special characters, and a combination of upper and lower case characters.

You will receive the following informational message, which indicates that your password was changed successfully:
Password changed.

Regards,
Steve

(in reply to andersmeyer)
Post #: 2
RE: Password to SA on MSDE - 20.Aug.2005 4:51:00 AM   
rino01

 

Posts: 69
Joined: 1.Jul.2005
From: Stockholm / Sweden
Status: offline
The default SA password for ISA MSDE installations are blank.

(in reply to andersmeyer)
Post #: 3
RE: Password to SA on MSDE - 22.Aug.2005 5:27:00 PM   
abandonallhope

 

Posts: 5
Joined: 1.Feb.2005
From: Nashville
Status: offline
Mine isn't sa/blank or sa/sa. I've tried SQL Ent Manager, osql -U sa and the msdetotext but nothing can connect to my MSDE DB. No errors just no connections.

Any one have a suggestion?

(in reply to andersmeyer)
Post #: 4
RE: Password to SA on MSDE - 22.Aug.2005 6:15:00 PM   
MRIS

 

Posts: 58
Joined: 4.Aug.2005
Status: offline
you will need to run the server network library configuration utility on the box itself and enable at least 1 of the network transports. (eg TCP/IP).
On my box this was installed as part of MSDE, the executable is called "SQLNETCN.EXE", it's in the binn directory.

(in reply to andersmeyer)
Post #: 5
RE: Password to SA on MSDE - 23.Aug.2005 7:25:00 PM   
abandonallhope

 

Posts: 5
Joined: 1.Feb.2005
From: Nashville
Status: offline
Thanks that did the trick.

(in reply to andersmeyer)
Post #: 6
RE: Password to SA on MSDE - 1.Sep.2005 2:17:00 AM   
Guest
Hi MRIS,

I have used the SQLNETCN.EXE to set the db to use tcp but I still can not connect because I do not know the sa password. I have tried sa and blank but it does not work.

Please help.

Thanks.

Simon

(in reply to andersmeyer)
  Post #: 7
RE: Password to SA on MSDE - 1.Sep.2005 1:55:00 PM   
Guest
To overwrite the existing sa password, try this string from a command prompt:

osql -E -S servername/SQL instance name -Q "sp_password NULL, ' newpassword ', 'sa'"

(in reply to andersmeyer)
  Post #: 8
RE: Password to SA on MSDE - 5.Sep.2005 2:18:00 AM   
MRIS

 

Posts: 58
Joined: 4.Aug.2005
Status: offline
or just use integrated windows authentication

(in reply to andersmeyer)
Post #: 9
RE: Password to SA on MSDE - 5.Sep.2005 1:22:00 PM   
Guest
Still can not get this working.

I have tried this
osql -E -S servername/SQL instance name -Q "sp_password NULL, ' newpassword ', 'sa'"
yet to show because the default password seems not to be NULL.

I do not think I can chnage this to integrated if I can not log on to the sql.

Can I unistall and reinstall this myself using the SQL SP4 version.

Please help.

Thanks.

(in reply to andersmeyer)
  Post #: 10
RE: Password to SA on MSDE - 7.Sep.2005 7:36:00 PM   
MRIS

 

Posts: 58
Joined: 4.Aug.2005
Status: offline
you should be able to simply apply SP4 using the commands in the readme for SP4. If you're trying to connect to the MSDE, make sure that your ISA2004 rules allow this! [Smile] From memory I had to change the port that SQL was using, so that you don't have 2 instances of SQL server that try to use the same port. I think they should automatically use the next available port, but I thought I'd just mention what I had to do go gain access to my FW MSDE. (I changed the TCP port that the normal SQL server listens to so that it's out of the way)

[ September 07, 2005, 08:03 PM: Message edited by: MRIS ]

(in reply to andersmeyer)
Post #: 11

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2004 Firewall] >> Logging and Reporting >> Password to SA on MSDE Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts