HTTP Filtering blocking long urls? (Full Version)

All Forums >> [ISA Server 2004 Firewall] >> HTTP Filtering


Pegan -> HTTP Filtering blocking long urls? (24.Sep.2004 10:04:00 AM)

I have a question about http filtering. Im having trouble accessing long urls http filter blocks them.

try this one: 2%2C103%2C104%2C105%2C120&agandeformid=100%2C101%2C102%2C103%2C104%2C105%2C106%2C107&submited=yes&statisticsservice=hemnettogp&urval=1&area=5&kommun=188&villa=on&gard=on&prismin=0& prismax=max&nrOfRooms1=0&nrOfRooms2=max&livingArea1=0&livingArea2=max&avgiftmax=max&nyckelord=&prod=-1&next=N%E4sta%21

I have configured my http filter as other posts states but it doesnt help.

Here is my settings in Http Filter:
Those typed here is the ones that are checked..
Allow Any Payload

Methods, Extensions, Headers:
Allow All

Block Fake Google bar.

Jason Jones -> RE: HTTP Filtering blocking long urls? (24.Sep.2004 4:40:00 PM)

Try increasing the number in the fields on the general of them should be max URL length

Also check out:


[ September 24, 2004, 04:42 PM: Message edited by: Jason Jones ]

Pegan -> RE: HTTP Filtering blocking long urls? (24.Sep.2004 9:06:00 PM)

Thanks for the answer i tried and read everything but it still doesnt work.

Here is the error message:
Error Code: 502 Proxy Error. The parameter is incorrect. (87)

Another thing i discovered is that if you use msn messenger and firewall client. Have a rule that allows msn messenger when you are an authanticated user it works from the same subnet as the isaserver but not from the others..

tshinder -> RE: HTTP Filtering blocking long urls? (25.Sep.2004 10:47:00 PM)

Hi Andreas,

It could be that the URL is too long. If over 256 bytes, it gets blocked to prevent exploits.


Pegan -> RE: HTTP Filtering blocking long urls? (27.Sep.2004 10:19:00 AM)

Thanks for your answers but I still think there is something bogus about HTTP Filter or that its to secure..
Theese 2 links aint to long
This one is a word docment and you get an error when clicking this link.$/Arkiv/L%E4s%E5rstider+2003-04

This one is a pdf and it works clicking this link.$/Arkiv/Manual+Fronter

You cannot test thoose links because they are password protected.

To bad it is this way I had to disable http filter.

-moz- -> RE: HTTP Filtering blocking long urls? (19.Nov.2004 2:02:00 PM)

even crazier about the content filter is even if you go to the microsoft isa home page i get part of the page missing (at the top)


seems MS have ambigous extensions.

configure http->extensions->untick block ambiguos

[ November 19, 2004, 02:10 PM: Message edited by: -moz- ]

cyskon -> RE: HTTP Filtering blocking long urls? (11.Jan.2005 8:01:00 PM)


Your solution fixed my problem;f=33;t=000091


Page: [1]