• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

How to you get the cache to work?

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 Cache] >> General >> How to you get the cache to work? Page: [1]
Login
Message << Older Topic   Newer Topic >>
How to you get the cache to work? - 18.Feb.2004 5:58:00 AM   
jazzman42379

 

Posts: 7
Joined: 16.Jul.2003
Status: offline
Hi Everyone,

I just installed the 2k4 beta, and I must say I like it tons better than 2000. I'm having a little trouble getting the web proxy to cache anything, though. I'm running ISA using the Edge Firewall template, and have the rules set up to publish my web & mail server, and to let things outbound. This all works fine. I even have my IE setup to run through the ISA box on 8080, and that works (I'm going through it now).

However when I pull up the performance monitor, all the values for the Cache settings are 0. Also, when I quickly browse the same pages, the Cache Hit Ratio stays at 0.

It seems as though it's working, but not caching. Any ideas?

Thanks,
John
Post #: 1
RE: How to you get the cache to work? - 18.Feb.2004 1:28:00 PM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi John,

You need to create a cache drive. There will not be any caching by default. After the cache drive is created, the caching will start.

HTH,
Tom

(in reply to jazzman42379)
Post #: 2
RE: How to you get the cache to work? - 19.Feb.2004 5:02:00 AM   
jazzman42379

 

Posts: 7
Joined: 16.Jul.2003
Status: offline
Hi Tom,

Here's what I've done so far regarding the proxy...

While I was setting up the system, in the Cache screen under Configuration, I defined the cache drive as the C: and set the maximum size to 1500MB (it's kindof a small system...). I have not added any other Cache Rules; the only one I have is the Last Default Rule, which looked like it should work. Then in Configuration -> Networks, in the properties of the Internal network, on the Web Proxy tab, I have checked to enable Web Proxy clients, and Enable HTTP, and have the port set to 80 so it's transparent (I'm running my clients as SecureNAT so I don't have to configure anything on them.). As far as this setting goes, before I found it, I tried setting my internet options to run through ISA on 8080, and I assume the proxy is working fine beause I was able to browse. Now with it on 80, things still work fine.

Are the Isa Server Cache readings in the performance monitor a good (and working) indicator that the cache is running properly? Is there a better way to see if it's running?

Thanks for the help,
John

(in reply to jazzman42379)
Post #: 3
RE: How to you get the cache to work? - 19.Feb.2004 5:06:00 AM   
jazzman42379

 

Posts: 7
Joined: 16.Jul.2003
Status: offline
Hi Tom,

Its funny how sometimes you solve things on your own. Not 30 seconds after I posted the reply and went back to tinkering with ISA, I changed the drive cache size and applied the rule, and got the popup that the services would have to restart.

Well my problem was that I just didn't read it close enough the first time. When I originally set the cache drive, I think I just hit OK and went about my business. Little did I know at the time that the default is to not restart the services! [Roll Eyes] In the words of Homer Simpson, "D'oh!".

Anyways, thanks for the push in the right direction. I gotta say again that I like 2004 a lot more than I did 2000.

Thanks,
John

(in reply to jazzman42379)
Post #: 4
RE: How to you get the cache to work? - 19.Feb.2004 11:03:00 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi Jazzman,

Ha! Great! Happens to me everyday [Smile]

Good to hear you got it working and thanks for the follow up!

Tom

(in reply to jazzman42379)
Post #: 5

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2004 Cache] >> General >> How to you get the cache to work? Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts