• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

Turn off cache

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2004 Cache] >> General >> Turn off cache Page: [1]
Login
Message << Older Topic   Newer Topic >>
Turn off cache - 5.Nov.2004 7:30:00 PM   
pr0nd3xtr

 

Posts: 20
Joined: 6.Feb.2004
From: Thousand Oaks, CA
Status: offline
Is there any way to just turn off the cache feature? I am building a website and I want the web server logs to reflect the originating IP, not the ISA server IP. I have tried creating cache rules to that host, and have the cache size set to 0. This will be rather important in the long run, as I will need to log and retain archives of everything that accesses the web server.

Thanks.

Matt
Post #: 1
RE: Turn off cache - 6.Nov.2004 1:07:00 AM   
Johno

 

Posts: 23
Joined: 23.Dec.2002
From: Oz
Status: offline
Hi Matt
From what I see the cache is off by default during install.
If you open the cache configuration window with the task pane available there is a disable cache link which turns off cache and sets it to zero.
I'm no expert by any means but maybe that isnt the way to acheive the web server logs that you require? Wouldnt ISA server itself create those logs?
Sorry I'm not much help [Wink]

Johno

[ November 06, 2004, 01:13 AM: Message edited by: Johno ]

(in reply to pr0nd3xtr)
Post #: 2
RE: Turn off cache - 6.Nov.2004 4:30:00 AM   
Ara.A

 

Posts: 259
Joined: 21.Oct.2004
Status: offline
It is off by default install. If you are looking to log your incoming web server visit, use IIS feature∆s not the ISA one
If you host more than one site, make sure in publishing rule, the click that says send original host header is selected
[Wink]

(in reply to pr0nd3xtr)
Post #: 3
RE: Turn off cache - 7.Nov.2004 8:33:00 PM   
pr0nd3xtr

 

Posts: 20
Joined: 6.Feb.2004
From: Thousand Oaks, CA
Status: offline
The cache is turned off, but the only ip address I am seeing on the webserver logs is the ISA server. As it sits now though, I dont have a publishing rule, I just have it set to allow port 80 to that particlar ip of the web server.

Thanks for the replies.

[ November 07, 2004, 08:33 PM: Message edited by: Matt Bullock ]

(in reply to pr0nd3xtr)
Post #: 4
RE: Turn off cache - 7.Nov.2004 8:38:00 PM   
Ara.A

 

Posts: 259
Joined: 21.Oct.2004
Status: offline
Create publishing rule and there is a click when you publish a web server that says send original host header. That should do the job
Never use dumb port 80 forwarding to a web server [Wink]

[ November 07, 2004, 08:40 PM: Message edited by: Ara ]

(in reply to pr0nd3xtr)
Post #: 5
RE: Turn off cache - 9.Nov.2004 12:24:00 AM   
pr0nd3xtr

 

Posts: 20
Joined: 6.Feb.2004
From: Thousand Oaks, CA
Status: offline
The same option to send the original header is available with my port forwarding rule under Protocols --> Filtering --> Configure HTTP. Is this supposed to work in the same manner as with a publishing rule?

(in reply to pr0nd3xtr)
Post #: 6

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2004 Cache] >> General >> Turn off cache Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts