Getting cached copies even though the webpages are set to no cache...HELP (Full Version)

All Forums >> [ISA Server 2004 Cache] >> General



Message


JakinH -> Getting cached copies even though the webpages are set to no cache...HELP (8.Nov.2005 12:22:00 PM)

Alright, need some advice here.

I will use yahoo.com for my example because I see it there, but this is happening for many login type sites...some of which we control and have verified cache settings for.

I go to fantasysports.yahoo.com and receive the page just fine. I click sign-in and enter my credentials. It accepts them and redirects back to the main page and I appear to not be logged in....Unless I press CTRL-F5. Then I come up as logged in.

Now, I go to my neighbors PC and type in the URL. Bam! He is logged in as me.

I have viewed the headers, and they are have all the necessary settings to not cache. Yet it is obvious that the cached versions are being returned.

The only caching rule currently is the default one - Only if valid, cache, (user auth, dynamic, and offline all UNchecked.)

What is going on, and how do we fix it?




JakinH -> RE: Getting cached copies even though the webpages are set to no cache...HELP (16.Nov.2005 3:04:44 PM)

Ok, we seem to have gotten this working.  I created an identical rule to the default one and applied it, and now it works.

Is this a known bug?





engel.aloisius -> RE: Getting cached copies even though the webpages are set to no cache...HELP (18.Nov.2005 4:30:28 PM)

having a similar problem here: isa is caching everything, but  it is told not to do so in the file-headers. still cant get it up working ... [:@]

this is my code (1. for browser, 2. for isa)
Code:
<meta http-equiv="cache-control" content="no-cache">
<meta http-equiv="pragma" content="no-cache">





tshinder -> RE: Getting cached copies even though the webpages are set to no cache...HELP (18.Nov.2005 4:58:07 PM)

Most likely the browser cache. This is what I see in 99.97% of the cases like this.

HTH,
Tom




Page: [1]