Problem with remote scripting (Full Version)

All Forums >> [ISA Server 2004 Misc.] >> ISA Server 2004 Programming



Message


Evgeny76 -> Problem with remote scripting (21.Aug.2005 12:47:00 PM)

Hello, all!

I've got an ISA2004EE installed on remote computer (remote01), I'm trying to access it's properties from my local machine where management tools were installed. Here is the script -
code:
 set root = CreateObject("FPC.Root")
root.ConnectToConfigurationStorageServer("remote01")
set isaArray = root.GetContainingArray()

This script works fine when executed on remote01 machine, but every time when I run it on my machine 3rd line of it fails with following error message - FPC.Root.1: The system cannot find the file specified.

In ISA SDK I found a possible explanation for this problem -
ERROR_FILE_NOT_FOUND, indicating that the IFPCArray interface could not be found because the method was called on a remote management computer on which the Microsoft Firewall service is not running. In this case, the [out] parameter returned is a null object.

But I'm pretty sure that on a remote01 machine this service is running!

Any ideas, suggestions???




ISAServerTools -> RE: Problem with remote scripting (21.Aug.2005 6:48:00 PM)

You will have to install the ISA Management console on the remote computer and add the remote computer's IP address to the Remote Management Computers Computer Set.




Evgeny76 -> RE: Problem with remote scripting (22.Aug.2005 4:50:00 AM)

As I said the ISA2004EE was installed on a remote computer, management tools were included [Wink]
On my local machine I also have an ISA management tools installed, so I can manage remote ISA server installation from my local machine using mmc.
IP address of my local machine is included to 'Remote Management Computers' group, but script still doesn't work.

Does anybody know that is 'Enterprise Remote Management Computers' and am I able to add/remove computers to this set? Maybe this can help?




Page: [1]