• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

ISA's Web publishing behaving very weird.

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2000 General] >> Web Publishing >> ISA's Web publishing behaving very weird. Page: [1]
Login
Message << Older Topic   Newer Topic >>
ISA's Web publishing behaving very weird. - 14.Aug.2002 3:52:00 PM   
lck0925

 

Posts: 16
Joined: 7.Aug.2002
Status: offline
Hello.. wonder if anyone could explain why my ISA is behaving like this.

I have 5 web publishing rules. What I know is that when a client makes a request for a webpage.. ISA would look @ the 6 rules (one is default) from top to bottom and see if anyone matches the IP. If it doesn't then the default rule which would discard the request is performed. Here's my setup (these are fake ips that I made up..).

1st rule --> 10.0.0.25 (www.domain1.com)
2nd rule --> 10.0.0.27 (www.domain2.com)
3rd rule --> 10.0.0.29 (www.domain3.com)
4th rule --> 10.0.0.31 (www.domain4.com)
5th rule --> 10.0.0.32 (www.domain5.com)
6th rule --> discard request

For some reason if i type in the actual domain name I would be brought to the correct address. However.. if i happen to type in the ip I would always be forwarded to the 1st rule. For example:

If i type in 10.0.0.27 in my web browser I would be brought to the 10.0.0.25 webpage.. the same goes for all of the other ips. I get brought to the correct webpage if, say, i type in www.domain2.com. Could anyone tell me why this is happening?

Thanks.

T
Post #: 1
RE: ISA's Web publishing behaving very weird. - 17.Aug.2002 7:53:00 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi T,

I've heard other people have problems with publishing by IP address. Try using FQDN's and see if you have the same problem.

Thanks!

Tom

(in reply to lck0925)
Post #: 2
RE: ISA's Web publishing behaving very weird. - 19.Aug.2002 3:44:00 PM   
lck0925

 

Posts: 16
Joined: 7.Aug.2002
Status: offline
Hey Tom.. nope.. trying to access it via fqdn(S) works properly.. i'm just puzzled as to why this is happening.. is this a bug in ISA?.. Thanks.

T [Razz] [Wink] [Big Grin] [Embarrassed] [Frown]

(in reply to lck0925)
Post #: 3
RE: ISA's Web publishing behaving very weird. - 22.Aug.2002 8:23:00 PM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi lck,

Could be. I know that MS *highly recommends* that you do not publish Web sites using IP addresses in the Destination Sets. Maybe that's why?

Thanks!

Tom

(in reply to lck0925)
Post #: 4

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2000 General] >> Web Publishing >> ISA's Web publishing behaving very weird. Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts