• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

ISA not publishing correctly

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2000 General] >> Web Publishing >> ISA not publishing correctly Page: [1]
Login
Message << Older Topic   Newer Topic >>
ISA not publishing correctly - 21.Aug.2002 12:07:00 PM   
jwelby

 

Posts: 7
Joined: 1.Jul.2002
Status: offline
I have a small problem with web publishing rulesą

My current setup is as follows:-
I have 3 domains a.com, b.com and c.com each of these domains has an external IP address:-

Domain IP Address
a.com ###.###.##.99
b.com ###.###.##.100
c.com ###.###.##.101

These web sites sit on internal servers with the following IP addresses

Domain IP Address
a.com 192.168.1.1
b.com 192.168.1.4
c.com 192.168.1.6

a.comĘs server is also the ISA server and domain controller

if u ping the www.a.com, www.b.com or www.c.com from outside the network (internet land) I get the following
a.com ###.###.##.99
b.com ###.###.##.100
c.com ###.###.##.101

DNS settings internally give the following IP addresses
Domain IP Address
a.com 192.168.1.1
b.com 192.168.1.4
c.com 192.168.1.6

I have set up listeners for the external addresses

I have setup web publishing rules as follows

Each site has a Web publishing rule as follows
Selected Destination set
(this points to a Destination set for each site (IP Address))
Redirect the request to this internal web server
(www.a.com or 192.168.1.1 etc) both tested
(www.b.com or 192.168.1.4 etc) both tested
(www.c.com or 192.168.1.6 etc) both tested
Send original host header ū Yes
Bridge as defaults
Applies to any request.

There is also a All Except rule which applies to IP address ###.###.##.99 to ###.###.##.101 to forward to a.comĘs site.

The is also a Default to Deny all

What happens is as followsą.

All sites are directed to www.a.com when accessed from outside by the name. They go to there correct site if the IP addresses are used (###.###.##.99, ###.###.##.100, ###.###.##.101) if I ping www.b.com etc I get the correct IP address.

If I remove the All except rule then all are blocked!

Any one help please
Post #: 1
RE: ISA not publishing correctly - 22.Aug.2002 8:15:00 PM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi Julian,

Are you publishing by FQDN or IP address? Stay with FQDN and you'll minimize lots of problems.

HTH<
Tom

(in reply to jwelby)
Post #: 2

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2000 General] >> Web Publishing >> ISA not publishing correctly Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts