• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

OWA (SSL) through ISA - I've read all the other posts

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2000 General] >> Web Publishing >> OWA (SSL) through ISA - I've read all the other posts Page: [1]
Login
Message << Older Topic   Newer Topic >>
OWA (SSL) through ISA - I've read all the other posts - 1.May2003 5:39:00 PM   
ballca

 

Posts: 26
Joined: 1.May2002
From: Dublin, Ohio
Status: offline
Ok, I've read all the other articles, posts, have the ISA Server 2000 book by Tom and Debra Shinder, and have Windows Magazine's pullout on this. I have OWA published through Web Publishing rules. Have 2 IP addresses on my external nic. One of the outside IP address has DNS entries pointing to mail.mydomain.com. On that IP address I have cert for mail.mydomain.com with "enable SSL listeners" checked. Then using the wizard (did it without wizard for same affect) from the Feature Pack created the OWA web publishing rule. Have a dest. set for mail.mydomain.com with the 3 paths (/public*, /exchange*, /exchweb*) and the Web publishing rule uses this on dest. tab. Have the bridging tab to redirect SSL as HTTP. Action tabs points to our internal OWA server using FQDM with sending original host header. Applied registry hack from Q307347. Not requiring SSL (action tab) yet for troubleshooting purposes.

If I type in http://mail.mydomain.com:8081/exchange it works from anywhere. (Note: I have 8081 as the TCP port in the "Incoming Web Request" tab on properties of the ISA server.) But if I type in https://mail.mydomain.com/exchange it reports "page not found". Makes me think I made an error with my certificate. Can anyone tell me why I get this error only with SSL but not the other way? Really appreciate any help. Pulling my hair out!
Post #: 1
RE: OWA (SSL) through ISA - I've read all the other posts - 1.May2003 10:16:00 PM   
ballca

 

Posts: 26
Joined: 1.May2002
From: Dublin, Ohio
Status: offline
Just letting everyone know I got this fixed. On a whim I changed the port that ISA listens for SSL requests. Then connecting on this port it worked. That told me something was interfering with port 443 on the server. I do have IIS installed since it is required for one of my 3rd party ISA tools. When I setup the certicate on the ISA server I found an entry in the advanced IIS settings using port 443. When I removed this ISA starting working correctly on receiving SSL traffic. Took me two days to figure that out but now I can enjoy the weekend.

(in reply to ballca)
Post #: 2
RE: OWA (SSL) through ISA - I've read all the other posts - 2.May2003 12:38:00 AM   
rewerbe

 

Posts: 9
Joined: 24.Feb.2003
From: Cambridge
Status: offline
Thank you so much for taking the time to post your message and solution. I have been wracking my brain out for the longest time on this, especially this week and today. I decided to check out what other users were saying, and lo and behold was your message and solution was most recent. The culprit: running IIS on same server as ISA screws up the port settings. Once I changed the SSL port IIS was using, all went well. Now I can have a good weekend too. Thank you again!

(in reply to ballca)
Post #: 3
RE: OWA (SSL) through ISA - I've read all the other posts - 2.May2003 4:43:00 PM   
ingmarm

 

Posts: 3
Joined: 2.May2003
From: Netherlands
Status: offline
Thanks a lot for posting the solution to this problem. It took us a couple of days to solve this. I wasn't able to change the SSL port IIS uses, so I completely removed IIS. Now everything works fine but I would like to know how one changes the SSL port IIS keeps in use when there's no Certificate installed.

Thanks in advance

(in reply to ballca)
Post #: 4

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2000 General] >> Web Publishing >> OWA (SSL) through ISA - I've read all the other posts Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts