• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

"Ext. IP address not defined on this array" when publish server

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA Server 2000 General] >> Server Publishing >> "Ext. IP address not defined on this array" when publish server Page: [1]
Login
Message << Older Topic   Newer Topic >>
"Ext. IP address not defined on this array" w... - 8.Mar.2002 11:33:00 PM   
TRichter

 

Posts: 10
Joined: 8.Mar.2002
From: St. Louis, MO USA
Status: offline
I'm pretty new at this, so please forgive me if I'm overlooking something really basic, but I can't find a resolution anywhere.

We have an FTP server behind ISA that needs to be accessed by external clients. Clients from within the LAT can access the FTP server just fine.

When I use the New Server Publishing Rule Wizard, I type the internal IP address that points to the FTP server and the external IP address of the ISA Server, then click NEXT and get the following error:

"The IP address is not defined on this array. Please select the IP address from the array's external IPs."

Also, when I click BROWSE to select an IP from the list of external IPs, there are no IPs listed.

I read somewhere to stop and restart the ISA Server Control Service (and all related services) but that didn't help. I rebooted the ISA server, still the same.

I have one other Server Publishing rule allowing Telnet traffic from the Ext IP to an Internal router and it works fine, although if I try to modify this rule, I get the same error message as above when I click OK or APPLY.

I have tried to bind and use additional public IPs to the external NIC, but they do not show up either.

Any help would be GREATLY appreciated. Thanks in advance!

-Tim Richter
Post #: 1
RE: "Ext. IP address not defined on this array&quo... - 8.Mar.2002 11:52:00 PM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hi Tim,

maybe a stupid question, but during the creation of the rule, was the external interface active? I've seen once such a behaviour because the external interface was not connected (no link bit).

Regards,
Stefaan

(in reply to TRichter)
Post #: 2
RE: "Ext. IP address not defined on this array&quo... - 9.Mar.2002 12:08:00 AM   
TRichter

 

Posts: 10
Joined: 8.Mar.2002
From: St. Louis, MO USA
Status: offline
Thanks Stefaan,

The external NIC is connected and link light is on. Everything else operates fine: internal firewall clients can access the internet without any problems, external Term Svcs clients can access Term Svr on ISA too.

I am getting two errors during startup. In the System Log, Event ID 115, Source: w3svc, "The service could not bind instance 1. The data is the error code." And in the Application Log, Event ID 37, Source: WinMgmt, "WMI ADAP was unable to load the nntpctrs.DLL performance library due to an unknown problem within the library: 0x0"

Could these be related?

Thanks again!
-Tim

(in reply to TRichter)
Post #: 3
RE: "Ext. IP address not defined on this array&quo... - 9.Mar.2002 4:22:00 PM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hi Tim,

hmm... I never encountered such a problem. Personally I think those errors should be fixed first, but I have no idea where to start [Frown]

Hopefully somebody can help you any further.

Regards,
Stefaan

(in reply to TRichter)
Post #: 4
RE: "Ext. IP address not defined on this array&quo... - 11.Mar.2002 4:41:00 PM   
TRichter

 

Posts: 10
Joined: 8.Mar.2002
From: St. Louis, MO USA
Status: offline
Does anyone else have any thoughts on this?

I need to get outside access to this FTP as soon as possible.

Any ideas would be appreciated.

Thanks,
Tim

(in reply to TRichter)
Post #: 5
RE: "Ext. IP address not defined on this array&quo... - 14.Mar.2002 4:33:00 PM   
TRichter

 

Posts: 10
Joined: 8.Mar.2002
From: St. Louis, MO USA
Status: offline
Can anyone point me to another resource where I can look for help with this? I've already searched the MS KB and TechNet.

PLEASE! Any help will be appreciated.

Thanks,
Tim

(in reply to TRichter)
Post #: 6
RE: "Ext. IP address not defined on this array&quo... - 15.Mar.2002 12:06:00 AM   
spouseele

 

Posts: 12830
Joined: 1.Jun.2001
From: Belgium
Status: offline
Hi Tim,

have you already checked your Local Address Table? The external IP's should *not* be there.

Just another idea,
Stefaan

[ March 15, 2002, 12:07 AM: Message edited by: spouseele ]

(in reply to TRichter)
Post #: 7
RE: "Ext. IP address not defined on this array&quo... - 15.Mar.2002 1:08:00 AM   
TRichter

 

Posts: 10
Joined: 8.Mar.2002
From: St. Louis, MO USA
Status: offline
Hello Stefaan,

Thanks for the response. Yes, I've checked that and only internal IP addresses are in the LAT.

Thanks for the try,
Tim

(in reply to TRichter)
Post #: 8
RE: "Ext. IP address not defined on this array&quo... - 20.Mar.2002 12:46:00 AM   
jprice

 

Posts: 2
Joined: 20.Mar.2002
From: Minneapolis, MN
Status: offline
I am having the exact same issue.

Also, if I go into my LAT, if I try to have ISA rebuild the LAT table itself, it tells me it can't find ANY adapters on the computer. There are two on the server (one internal, one external), and both are functioning correctly. at a DOS prompt, if I type ipconfig /all both adapters are listed and everything appears correct. It's as if ISA for some reason or other cannot access the adapter information from Windows 2000.

Any more ideas? I'm banging my head against the wall on this one.

(in reply to TRichter)
Post #: 9
RE: "Ext. IP address not defined on this array&quo... - 26.Mar.2002 5:01:00 PM   
TRichter

 

Posts: 10
Joined: 8.Mar.2002
From: St. Louis, MO USA
Status: offline
JPrice,

I'm still banging my head against the wall on this one as well. I've tried to reconstruct the LAT too, and when I check the box to "add address ranges based on the selected computer's Windows 2000 routing table" it says that "ISA Server cannot retrieve this server's adapter list".

Do you have any errors/warnings in your event logs?

Anybody have any suggestions?

(in reply to TRichter)
Post #: 10
RE: "Ext. IP address not defined on this array&quo... - 1.Apr.2002 11:09:00 PM   
green18t

 

Posts: 11
Joined: 1.Apr.2002
From: Virginia
Status: offline
I have exactly the same problem. I have searched Technet / KB etc and I am stuck.

Any thoughts would be appreciated !

(in reply to TRichter)
Post #: 11
RE: "Ext. IP address not defined on this array&quo... - 2.Apr.2002 5:35:00 AM   
TRichter

 

Posts: 10
Joined: 8.Mar.2002
From: St. Louis, MO USA
Status: offline
I'm still having the same problem. But, I remembered something that I did a few months ago that I think may have caused the problem and wanted to see if anyone else experiencing this problem has done this, also.

After installing Win2K Server and ISA Server, everything was working great. Then, after several months, I changed the domain name of the ISA server using 'dcpromo'. I'm still using the old domain name on a different Win2k Server on same network.

Could changing the domain name lead to an adapter identification problem within ISA Server or Win2k Server?

My procrastination is not paying off . . . I may be forced to do a clean install. Please help!

Thanks,
Tim

(in reply to TRichter)
Post #: 12
RE: "Ext. IP address not defined on this array&quo... - 2.Apr.2002 11:46:00 PM   
Guest
I have had the same problem. If you look at computer under properties in the ISA server management tree does the full computer name match the full computer name in the system properties, Network Identification tab? If they don't this is the root of your problem.

There is a Registry setting under Hkey_local_machine, software, Microsoft, FPC, Arrays, Servers, {key_name}, msFPCFQDN that needs to be manually changed to match your Fully qualified server name in the System Properties, Network Id. tab. Once you do this you firewall will be able to see all adapters. I hope this solves your problem.

Tim Swietek
Ogden Publications, Inc.

(in reply to TRichter)
  Post #: 13
RE: "Ext. IP address not defined on this array&quo... - 3.Apr.2002 4:56:00 AM   
TRichter

 

Posts: 10
Joined: 8.Mar.2002
From: St. Louis, MO USA
Status: offline
Tim S.,

YOU ARE A LIFESAVER!

I followed your instructions and you were exactly right. The registry key still contained the "old" domain name. I changed it, and "PRESTO" - I can now see my adapters! I then easily created my FTP Server Publishing Rule and now my FTP server is up and running.

THANK YOU! THANK YOU! THANK YOU!

You have saved me several hours of time by not having to re-install the OS and ISA.

THANKS AGAIN!

-Tim R.

(in reply to TRichter)
Post #: 14
RE: "Ext. IP address not defined on this array&quo... - 3.Apr.2002 5:01:00 AM   
TRichter

 

Posts: 10
Joined: 8.Mar.2002
From: St. Louis, MO USA
Status: offline
For others also experiencing this problem,

When I checked the server name under ISA to see if it matched the name in the network identification properties, the server name under ISA did not contain the FQDN, it was just the "short name" so I added the domain name to the end of the "short name."

I did this in addition to the registry edit described by Tim S. above. I'm not sure if this step really mattered but thought I'd mention it just to be safe.

Good Luck to all!

Thanks again, Tim S.!

-TimR

(in reply to TRichter)
Post #: 15
RE: "Ext. IP address not defined on this array&quo... - 5.Apr.2002 5:28:00 PM   
timsw

 

Posts: 3
Joined: 2.Apr.2002
From: Topeka
Status: offline
Your welcome. I'm glad I could help. It's one of those annoying issues with ISA, that there is now documentation on any where. I spent several hours like you trying to figure it out. I'm glad it saved you time.

(in reply to TRichter)
Post #: 16
RE: "Ext. IP address not defined on this array&quo... - 11.Oct.2002 2:04:00 PM   
JRose

 

Posts: 6
Joined: 11.Oct.2002
From: St. Louis
Status: offline
I changed my domain about 2 months ago and really haven't had to make any changes to my firewall configuration since then. Yesterday I went in to create a new server publishing rule and the exact same problem as explained above was happening. My external adapter was not displaying in the list of adapters. I changed the registry key that user <tims> explained and it worked perfectly.

I too looked all over Microsoft's site and found nothing, isaserver.org is one of the best sites I have found for help with this product. Thanks, again and you saved me a great deal of suffering as well!

Jeff

(in reply to TRichter)
Post #: 17
RE: "Ext. IP address not defined on this array&quo... - 6.Sep.2004 8:26:00 PM   
Guest
thanks all. this is what i've spent a whole afternoon looking for.

worked perfectly.

cheers
sam

(in reply to TRichter)
  Post #: 18

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA Server 2000 General] >> Server Publishing >> "Ext. IP address not defined on this array" when publish server Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts