• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

setup failed to install ADAM (0x80072020)

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 General] >> Installation and Planning >> setup failed to install ADAM (0x80072020) Page: [1]
Login
Message << Older Topic   Newer Topic >>
setup failed to install ADAM (0x80072020) - 19.May2008 7:11:07 AM   
Richard365

 

Posts: 3
Joined: 19.May2008
Status: offline
I get the above error when trying to install ISA 2006 Enterprise edition on a Windows 2003 SE SP2 server.

Any ideas why ?

thanks,

Richard
Post #: 1
RE: setup failed to install ADAM (0x80072020) - 19.May2008 8:58:21 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Is the ISA Firewall machine a domain member?

Thanks!
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to Richard365)
Post #: 2
RE: setup failed to install ADAM (0x80072020) - 19.May2008 9:35:42 AM   
Richard365

 

Posts: 3
Joined: 19.May2008
Status: offline
Yes Tom, it is a domain member....

(in reply to Richard365)
Post #: 3
RE: setup failed to install ADAM (0x80072020) - 19.May2008 9:42:20 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Hi Richard,

OK, good.

Check your DNS to make sure that only the internal interface of the ISA Firewall is registered in the DNS.

HTH,
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to Richard365)
Post #: 4
RE: setup failed to install ADAM (0x80072020) - 19.May2008 11:12:30 AM   
Richard365

 

Posts: 3
Joined: 19.May2008
Status: offline
Hi Tom,

The IP address of the external NIC was in the DNS but it has now been removed and I still get the same error.

Any other suggestions ?

Thanks for your help....

Richard

(in reply to Richard365)
Post #: 5
RE: setup failed to install ADAM (0x80072020) - 20.May2008 7:48:53 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
Are you logged on as a domain admin?

Did you do any "special" customization of the security configuration of the ISA firewall machine?

Thanks!

Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to Richard365)
Post #: 6
RE: setup failed to install ADAM (0x80072020) - 20.May2008 8:48:49 AM   
gbarnas

 

Posts: 155
Joined: 27.Apr.2005
From: New Jersey
Status: offline
I've been playing with various installs in the lab recently, using W2K3 R2, and the ADAM install failed regularly. It can't seem to find the files on the install CD. I copied both CDs from the R2 install to a file share and now when it prompts for the W2K3 CD, I browse to the share, and then directly to the ADAM install folder and have had no further problems. It's almost as if it can't locate the install path in the R2 release.

Glenn

(in reply to tshinder)
Post #: 7
RE: setup failed to install ADAM (0x80072020) - 25.May2008 10:00:28 AM   
tshinder

 

Posts: 50013
Joined: 10.Jan.2001
From: Texas
Status: offline
So, when you install ISA, you're getting a prompt for the Windows CD so that it can install ADAM?

Also, R2 isn't really needed for ISA and might introduce overhead you don't need.

HTH,
Tom

_____________________________

Thomas W Shinder, M.D.

(in reply to gbarnas)
Post #: 8
RE: setup failed to install ADAM (0x80072020) - 10.Sep.2008 12:56:36 PM   
mjtibbz

 

Posts: 1
Joined: 10.Sep.2008
Status: offline
I also encounterd this problem in my lab environement.

When I installed my domain controller, I was currently on the 10.0.0.0/24 subnet.

I then moved it to a different subnet (172.16.0.0/24) and manually changed all the DNS records to conform to the new subnet.

The problem was, I forgot to ammend the reverse lookup zone, which was still hosting the reverse zone for the old subnet (10.0.0.0)

I changed this so 172.16.0.x and manually added PTR records for my domain computers and also the isa server. After that, the ADAM problem was gone.

so yes, make sure your DNS is configured properly.

--Mike

(in reply to Richard365)
Post #: 9
RE: setup failed to install ADAM (0x80072020) - 10.Sep.2008 7:45:38 PM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
quote:

ORIGINAL: mjtibbz


so yes, make sure your DNS is configured properly.

--Mike


This is the ISA mantra!

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to mjtibbz)
Post #: 10
RE: setup failed to install ADAM (0x80072020) - 24.Sep.2008 11:10:55 AM   
mmhubach

 

Posts: 14
Joined: 28.Aug.2008
Status: offline
I just had this problem last night. I was adding a 3rd ISA server and I got this exact same error. What I did was add the new server name/IP to Replicate Configuration Storage servers object underneath the Enterprise Array Computer Sets group. I was able to get by with that.

(in reply to Richard365)
Post #: 11
RE: setup failed to install ADAM (0x80072020) - 17.Nov.2008 8:24:48 AM   
zeppanen

 

Posts: 1
Joined: 17.Nov.2008
Status: offline
Hi,

I had exactly the same error message while installing ISA Server 2006 EE in fresh Windows Server 2003 R2 SP2 installation week ago. Nothing I found from the Internet helped, so I opened MS Premier case.

Result was that after I uninstalled Windows SP2 I was able to install ISA and even after that I reinstalled Windows SP2 and ISA 2006 SP1 and everything worked fine.

If you have Windows 2003 SP1 and ISA 2006 you have to install ADAM SP1 before installing Windows SP2 but in R2 the ADAM SP1 is included.

MS was not able to explain why this happened.

(in reply to mmhubach)
Post #: 12

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 General] >> Installation and Planning >> setup failed to install ADAM (0x80072020) Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts