• RSS
  • Twitter
  • FaceBook

Welcome to ISAserver.org

Forums | Register | Login | My Profile | Inbox | RSS RSS icon | My Subscription | My Forums | Address Book | Member List | Search | FAQ | Ticket List | Log Out

website reditrects not working

Users viewing this topic: none

Logged in as: Guest
  Printable Version
All Forums >> [ISA 2006 Publishing] >> Web Publishing >> website reditrects not working Page: [1]
Login
Message << Older Topic   Newer Topic >>
website reditrects not working - 17.Sep.2009 3:03:24 AM   
morne@afridata.net

 

Posts: 34
Joined: 19.Dec.2008
Status: offline
HI. I have an interesting situation. I have multiple http and https web publishing rules for multiple sites. All of them work fine. I have a third party application "isapi rewrite" that redirects all my ur's to one specific url. I.E mydomain.com is redirected to www.mydomain.com.

However, this does not seem to work and it looks like the isa firewall is the culprit. When i use a different firewall and just publish port 80 the redirect works fine but when using ISA the website url is not changed in my browser although i can surf the site fine. This is messing with my reporting because now my reporting is whong two reports, one for www. and one without for the domain. Is their a way of doing this redirect on the isa publishing rule? I am temporarily using asp code to do a redirect but this is not ideal. thanks for any input. morne.
Post #: 1
RE: website reditrects not working - 17.Sep.2009 4:12:46 AM   
Jason Jones

 

Posts: 4663
Joined: 30.Jul.2002
From: United Kingdom
Status: offline
You can create a deny rule and use the "Redirect HTTP requests to this Web page" field under the Action tab.

Cheers

JJ

_____________________________

Jason Jones | Forefront MVP | Silversands Ltd
My Blogs: http://blog.msedge.org.uk/ and http://blog.msfirewall.org.uk/

(in reply to morne@afridata.net)
Post #: 2
RE: website reditrects not working - 17.Sep.2009 6:20:04 AM   
morne@afridata.net

 

Posts: 34
Joined: 19.Dec.2008
Status: offline
Hi JJ. How would I go about creating this rule. a simple deny rule wont work.

(in reply to Jason Jones)
Post #: 3
RE: website reditrects not working - 17.Sep.2009 9:11:29 AM   
yeskaygee1

 

Posts: 51
Joined: 5.Dec.2008
From: Washington, DC
Status: offline
A simple deny rule will work.
Create a publishing rule for publishing mydomain.com. Instead of "Allow" select "Deny". In the Actions tab enable 'Redirect https requests to this webpage' and give the URL www.mydomain.com.

Regards,
Karthigeyan

(in reply to morne@afridata.net)
Post #: 4
RE: website reditrects not working - 18.Sep.2009 2:31:50 AM   
morne@afridata.net

 

Posts: 34
Joined: 19.Dec.2008
Status: offline
HI. Thanks to yeskaygee1 and Jason Jones.

The deny rule works perfectly, even where a single rule redirects multiple sites to a single site.

Although this solution works fine I am worried that now we have to have two rules for each site, a rule publishing the site and a rule redirecting the site. I would have though that the redirection could e handled on the publishing rule. maybe a new feature for microsoft to give us in the next release.

Thanks again for your excellent assistance in this regard.

morne

(in reply to yeskaygee1)
Post #: 5

Page:   [1] << Older Topic    Newer Topic >>
All Forums >> [ISA 2006 Publishing] >> Web Publishing >> website reditrects not working Page: [1]
Jump to:

New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts